summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-04-15 22:26:01 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-04-15 22:26:01 +0000
commitd9a98503b8c74d518be564028f37da60c9706705 (patch)
tree92377df2a1e4e68467030fc0e08632ad1d857386 /app-arch
parentVersion bump; masked for testing. Closes #18214. (diff)
downloadgentoo-2-d9a98503b8c74d518be564028f37da60c9706705.tar.gz
gentoo-2-d9a98503b8c74d518be564028f37da60c9706705.tar.bz2
gentoo-2-d9a98503b8c74d518be564028f37da60c9706705.zip
Version bump; masked for testing. Closes #18214.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdsfv/ChangeLog10
-rw-r--r--app-arch/bsdsfv/bsdsfv-1.14.ebuild25
-rw-r--r--app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff114
-rw-r--r--app-arch/bsdsfv/files/digest-bsdsfv-1.144
4 files changed, 150 insertions, 3 deletions
diff --git a/app-arch/bsdsfv/ChangeLog b/app-arch/bsdsfv/ChangeLog
index f23601e391fd..cd6e2e8eeb84 100644
--- a/app-arch/bsdsfv/ChangeLog
+++ b/app-arch/bsdsfv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/bsdsfv
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/ChangeLog,v 1.6 2003/02/12 02:56:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/ChangeLog,v 1.7 2003/04/15 22:25:56 absinthe Exp $
+
+*bsdsfv-1.14 (15 Apr 2003)
+
+ 15 Apr 2003; Dylan Carlson <absinthe@gentoo.org>
+ bsdsfv-1.14.ebuild, files/bsdsfv-1.14-gentoo.diff:
+ Version bump, masked for testing. The authors changed the versioning scheme.
+ This new version also includes a patch supplied by PJ to colorize the output
+ ( thanks to: PJ <PJ@EliteGamer.com> in #18214 )
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-arch/bsdsfv/bsdsfv-1.14.ebuild b/app-arch/bsdsfv/bsdsfv-1.14.ebuild
new file mode 100644
index 000000000000..1e18c3fa706f
--- /dev/null
+++ b/app-arch/bsdsfv/bsdsfv-1.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdsfv/bsdsfv-1.14.ebuild,v 1.1 2003/04/15 22:25:56 absinthe Exp $
+
+S="${WORKDIR}/bsdsfv"
+P="${PN}.${PV}"
+DESCRIPTION="BSDSFV: All-in-one SFV checksum utility"
+SRC_URI="mirror://sourceforge/bsdsfv/${P}.tar.gz"
+HOMEPAGE="http://bsdsfv.sourceforge.net/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff
+ emake || die
+}
+
+src_install() {
+ dobin bsdsfv
+ dodoc README MANUAL
+}
diff --git a/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff b/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff
new file mode 100644
index 000000000000..d09b0dc6472c
--- /dev/null
+++ b/app-arch/bsdsfv/files/bsdsfv-1.14-gentoo.diff
@@ -0,0 +1,114 @@
+--- bsdsfv.c 2003-03-17 00:26:16.000000000 -0800
++++ bsdsfv.c.pj 2003-03-26 04:41:44.000000000 -0800
+@@ -37,9 +37,18 @@
+
+ #define FNAMELEN 250
+ #define MAXSFVFILE 1024
+-#define BSDSFV_VERSION "BSDSFV for UNiX, $Revision: 1.1 $"
++#define BSDSFV_VERSION "BSDSFV for UNiX, $Revision: 1.1 $"
+ #define MISSINGTAG ".missing"
+ #define BADTAG ".bad"
++#define OPENBRACKET "\e[34;01m[\e[0m"
++#define CLOSEBRACKET "\e[34;01m]\e[0m"
++#define OKCOLOR "\e[32;01m"
++#define OKMSG "OK"
++#define BADCOLOR "\e[31;01m"
++#define BADMSG "BAD"
++#define MISSINGCOLOR "\e[33;01m"
++#define MISSINGMSG "MISSING"
++
+
+ typedef struct sfvtable
+ {
+@@ -523,7 +532,7 @@
+
+ if (listedcrc == mycrc)
+ {
+- printf ("OK\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, OKCOLOR, OKMSG, CLOSEBRACKET);
+ if (glftpdmode)
+ {
+ sprintf (crap, "%s%s", sfvTable[0].filename,
+@@ -535,7 +544,7 @@
+ }
+ else
+ {
+- printf ("BAD\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, BADCOLOR, BADMSG, CLOSEBRACKET);
+ badfiles++;
+ if (glftpdmode)
+ {
+@@ -549,16 +558,18 @@
+ }
+ else
+ {
+- printf ("MISSING\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, MISSINGCOLOR, MISSINGMSG, CLOSEBRACKET);
+ missingfiles++;
+ }
+ numfiles++;
+ paramcnt++;
+ }
+
+- printf ("\n%d file(s) tested - %d OK - %d bad - %d missing...\n",
+- numfiles, numfiles - badfiles - missingfiles, badfiles,
+- missingfiles);
++ printf ("\n%d file(s) tested - %s %s%d %s %s - %s %s%d %s %s - %s %s%d %s %s ...\n\n",
++ numfiles,
++ OPENBRACKET, OKCOLOR, numfiles - (badfiles + missingfiles), OKMSG, CLOSEBRACKET,
++ OPENBRACKET, BADCOLOR, badfiles, BADMSG, CLOSEBRACKET,
++ OPENBRACKET, MISSINGCOLOR, missingfiles, MISSINGMSG, CLOSEBRACKET);
+
+ if (badfiles || missingfiles)
+ return 1;
+@@ -635,18 +646,18 @@
+
+ if (mycrc == sfvTable[cnt].crc)
+ {
+- printf ("OK\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, OKCOLOR, OKMSG, CLOSEBRACKET);
+ }
+ else
+ {
+ if (mycrc == 0xffffffff)
+ {
+- printf ("MISSING\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, MISSINGCOLOR, MISSINGMSG, CLOSEBRACKET);
+ missingfiles++;
+ }
+ else
+ {
+- printf ("BAD\n");
++ printf ("%s %s%s %s\n", OPENBRACKET, BADCOLOR, BADMSG, CLOSEBRACKET);
+ badfiles++;
+ }
+ }
+@@ -668,8 +679,9 @@
+ }
+ else
+ {
+- printf ("Testing %s ... listed = 0x%08X ... Local = MISSING",
+- sfvTable[cnt].filename, sfvTable[cnt].crc);
++ printf ("Testing %s ... listed = 0x%08X ... local = ... %s %s%s %s\n",
++ sfvTable[cnt].filename, sfvTable[cnt].crc,
++ OPENBRACKET, MISSINGCOLOR, MISSINGMSG, CLOSEBRACKET);
+ missingfiles++;
+ if (glftpdmode)
+ {
+@@ -714,10 +726,12 @@
+ }
+ printf ("Completion Status: %s\n", NEWTAG);
+ }
+-
+- printf ("\n%d file(s) tested - %d OK - %d bad - %d missing ...\n\n",
+- numfiles, numfiles - (badfiles + missingfiles), badfiles,
+- missingfiles);
++
++ printf ("\n%d file(s) tested - %s %s%d %s %s - %s %s%d %s %s - %s %s%d %s %s ...\n\n",
++ numfiles,
++ OPENBRACKET, OKCOLOR, numfiles - (badfiles + missingfiles), OKMSG, CLOSEBRACKET,
++ OPENBRACKET, BADCOLOR, badfiles, BADMSG, CLOSEBRACKET,
++ OPENBRACKET, MISSINGCOLOR, missingfiles, MISSINGMSG, CLOSEBRACKET);
+
+ if (missingfiles)
+ return 2;
diff --git a/app-arch/bsdsfv/files/digest-bsdsfv-1.14 b/app-arch/bsdsfv/files/digest-bsdsfv-1.14
index 013aa661d9f6..348c5abe1f66 100644
--- a/app-arch/bsdsfv/files/digest-bsdsfv-1.14
+++ b/app-arch/bsdsfv/files/digest-bsdsfv-1.14
@@ -1,3 +1,3 @@
-MD5 7c07c2b69a5d29e31929e0085a3fecca /files/bsdsfv-1.14-gentoo.diff 3572
-MD5 bf6c82ca339f22dc0333d07c1fd62b44 /bsdsfv-1.14.ebuild 620
+MD5 2d74a9d0f80bc60b3c30bfdb89df6b09 /files/bsdsfv-1.14-gentoo.diff 3512
+MD5 578ccfc91c0aa4abce68e890aaff7e91 /bsdsfv-1.14.ebuild 620
MD5 67caa8503a2506b68aaf53aa655a9f04 bsdsfv.1.14.tar.gz 13327