summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
commitdf250d511b22c4321a4b8a2b31fce769b50b533f (patch)
tree27bf344f663fa1eb008b5b905aa232e8a0a430a7 /app-arch
parentold (diff)
downloadgentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.gz
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.bz2
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.zip
old
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/bzip2-1.0.2-r5.ebuild81
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r4.ebuild79
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch22
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-saneso.patch13
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.2-r51
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r41
-rw-r--r--app-arch/cpio/cpio-2.6-r3.ebuild47
-rw-r--r--app-arch/cpio/cpio-2.6-r4.ebuild48
-rw-r--r--app-arch/cpio/files/digest-cpio-2.6-r31
-rw-r--r--app-arch/cpio/files/digest-cpio-2.6-r41
10 files changed, 0 insertions, 294 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.2-r5.ebuild b/app-arch/bzip2/bzip2-1.0.2-r5.ebuild
deleted file mode 100644
index e00a58a90ba9..000000000000
--- a/app-arch/bzip2/bzip2-1.0.2-r5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.2-r5.ebuild,v 1.2 2005/03/31 15:52:22 kugelfang Exp $
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://sources.redhat.com/bzip2/"
-SRC_URI="ftp://sources.redhat.com/pub/bzip2/v102/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="build static"
-
-DEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-NULL-ptr-check.patch
- epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-saneso.patch
- epatch "${FILESDIR}"/${P}-progress.patch
- sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die
- # make the Makefile multilib aware <kugelfang@gentoo.org>
- sed -i -e "s:\/lib\(\ \|\/\|$\):\/$(get_libdir)\1:g" Makefile \
- || die "sed failed: get_libdir"
-
- use static && append-flags -static
-
- # bzip2 will to run itself after it has built itself which we
- # can't do if we are cross compiling. -solar
- if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
- sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die
- fi
-}
-
-src_compile() {
- local makeopts="
- CC=$(tc-getCC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- "
- if ! use build ; then
- emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
- fi
- emake ${makeopts} all || die "Make failed"
-}
-
-src_install() {
- if ! use build ; then
- make PREFIX="${D}"/usr install || die
- mv "${D}"/usr/bin "${D}"
-
- # These are symlinks to bzip2 ...
- for x in bunzip2 bzcat ; do
- if [[ -f ${D}/bin/${x} ]] ; then
- rm -f ${D}/bin/${x}
- dosym bzip2 /bin/${x}
- fi
- done
-
- dolib.so "${S}"/libbz2.so.${PV}
- dosym libbz2.so.${PV} /usr/$(get_libdir)/libbz2.so.1.0
- dosym libbz2.so.${PV} /usr/$(get_libdir)/libbz2.so
- dosym libbz2.so.${PV} /usr/$(get_libdir)/libbz2.so.1
-
- dodoc README CHANGES Y2K_INFO
- docinto txt
- dodoc *.txt
- docinto ps
- dodoc *.ps
- dohtml manual_*.html
- else
- into /
- dobin bzip2
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
- fi
-}
diff --git a/app-arch/bzip2/bzip2-1.0.3-r4.ebuild b/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
deleted file mode 100644
index 777e7d61d19b..000000000000
--- a/app-arch/bzip2/bzip2-1.0.3-r4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r4.ebuild,v 1.2 2005/07/06 00:51:54 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build static"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
- epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.2-chmod.patch
- sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
-
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:ln $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die "sed links"
-
- # bzip2 will to run itself after it has built itself which we
- # can't do if we are cross compiling. -solar
- if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
- sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
- fi
-}
-
-src_compile() {
- local makeopts="
- CC=$(tc-getCC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- "
- if ! use build ; then
- emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
- fi
- use static && append-flags -static
- emake ${makeopts} all || die "Make failed"
-}
-
-src_install() {
- if ! use build ; then
- make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
-
- # move bzip2 binaries to / and use the shared libbz2.so
- mv "${D}"/usr/bin "${D}"/
- into /
- if ! use static ; then
- newbin bzip2-shared bzip2 || die "dobin shared"
- fi
- dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /$(get_libdir)/${v}
- done
- gen_usr_ldscript libbz2.so
-
- dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
- else
- into /
- dobin bzip2 || die "dobin bzip2"
- fi
-
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch b/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch
deleted file mode 100644
index bf7d430f9496..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig 2004-12-26 16:30:06.354116536 -0500
-+++ Makefile 2004-12-26 16:32:13.617769520 -0500
-@@ -9,7 +9,7 @@
-
- # Suitably paranoid flags to avoid bugs in gcc-2.7
- BIGFILES=-D_FILE_OFFSET_BITS=64
--CFLAGS=-Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
-+CFLAGS+=-Wall -Winline -fno-strength-reduce $(BIGFILES)
-
- # Where you want it installed when you do 'make install'
- PREFIX=/usr
---- Makefile-libbz2_so.orig 2004-12-26 16:32:23.972195408 -0500
-+++ Makefile-libbz2_so 2004-12-26 16:32:34.835543928 -0500
-@@ -9,7 +9,7 @@
- SHELL=/bin/sh
- CC=gcc
- BIGFILES=-D_FILE_OFFSET_BITS=64
--CFLAGS=-fpic -fPIC -Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
-+CFLAGS+=-fpic -fPIC -Wall -Winline -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
-
- OBJS= blocksort.o \
- huffman.o \
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.2-saneso.patch
deleted file mode 100644
index 0231a3cf93de..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-saneso.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-taken from fedora
-
---- bzip2-1.0.2/Makefile-libbz2_so.saneso Wed Jan 30 15:44:10 2002
-+++ bzip2-1.0.2/Makefile-libbz2_so Wed Jan 30 15:44:26 2002
-@@ -20,7 +20,7 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.2 $(OBJS)
-+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.2 $(OBJS)
- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.2
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.2 libbz2.so.1.0
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.2-r5 b/app-arch/bzip2/files/digest-bzip2-1.0.2-r5
deleted file mode 100644
index 5b1f375c39ee..000000000000
--- a/app-arch/bzip2/files/digest-bzip2-1.0.2-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ee76864958d568677f03db8afad92beb bzip2-1.0.2.tar.gz 665198
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r4 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
deleted file mode 100644
index 24bf9c7e285a..000000000000
--- a/app-arch/bzip2/files/digest-bzip2-1.0.3-r4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075
diff --git a/app-arch/cpio/cpio-2.6-r3.ebuild b/app-arch/cpio/cpio-2.6-r3.ebuild
deleted file mode 100644
index 44a2d3fa1f36..000000000000
--- a/app-arch/cpio/cpio-2.6-r3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r3.ebuild,v 1.10 2005/05/04 22:50:16 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="A file archival tool which can also read and write tar files"
-HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
-SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 ppc-macos s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-rili-big-files.patch #68520
- epatch "${FILESDIR}"/${PV}-isnumber.patch #74929
- epatch "${FILESDIR}"/${PV}-umask.patch #79844
- epatch "${FILESDIR}"/${PV}-lstat.patch #80246
- epatch "${FILESDIR}"/${P}-chmodRaceC.patch #90619
- epatch "${FILESDIR}"/${P}-gcc4-tests.patch #89123
-}
-
-src_compile() {
- # The configure script has a useless check for gethostname in
- # libnsl ... but cpio doesn't utilize the lib/func anywhere,
- # so let's force the lib to not be detected
- ac_cv_lib_nsl_gethostname=no \
- econf \
- $(use_enable nls) \
- --bindir=/bin \
- --with-rmt=/usr/sbin/rmt \
- || die
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ChangeLog NEWS README INSTALL
- rm -f "${D}"/usr/share/man/man1/mt.1
- rmdir "${D}"/usr/libexec
-}
diff --git a/app-arch/cpio/cpio-2.6-r4.ebuild b/app-arch/cpio/cpio-2.6-r4.ebuild
deleted file mode 100644
index dbc689657e42..000000000000
--- a/app-arch/cpio/cpio-2.6-r4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6-r4.ebuild,v 1.10 2005/06/28 05:10:00 kumba Exp $
-
-inherit eutils
-
-DESCRIPTION="A file archival tool which can also read and write tar files"
-HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
-SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-rili-big-files.patch #68520
- epatch "${FILESDIR}"/${PV}-isnumber.patch #74929
- epatch "${FILESDIR}"/${PV}-umask.patch #79844
- epatch "${FILESDIR}"/${PV}-lstat.patch #80246
- epatch "${FILESDIR}"/${P}-chmodRaceC.patch #90619
- epatch "${FILESDIR}"/${P}-gcc4-tests.patch #89123
- epatch "${FILESDIR}"/${P}-dirTraversal.patch #90619
-}
-
-src_compile() {
- # The configure script has a useless check for gethostname in
- # libnsl ... but cpio doesn't utilize the lib/func anywhere,
- # so let's force the lib to not be detected
- ac_cv_lib_nsl_gethostname=no \
- econf \
- $(use_enable nls) \
- --bindir=/bin \
- --with-rmt=/usr/sbin/rmt \
- || die
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ChangeLog NEWS README INSTALL
- rm -f "${D}"/usr/share/man/man1/mt.1
- rmdir "${D}"/usr/libexec
-}
diff --git a/app-arch/cpio/files/digest-cpio-2.6-r3 b/app-arch/cpio/files/digest-cpio-2.6-r3
deleted file mode 100644
index 822d7f4e46f3..000000000000
--- a/app-arch/cpio/files/digest-cpio-2.6-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 25e0e8725bc60ed3460c9cde92752674 cpio-2.6.tar.bz2 448452
diff --git a/app-arch/cpio/files/digest-cpio-2.6-r4 b/app-arch/cpio/files/digest-cpio-2.6-r4
deleted file mode 100644
index 822d7f4e46f3..000000000000
--- a/app-arch/cpio/files/digest-cpio-2.6-r4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 25e0e8725bc60ed3460c9cde92752674 cpio-2.6.tar.bz2 448452