summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-20 15:40:09 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-20 15:40:09 +0000
commitea7bfa2d4293b3bfb0a9666661060ea3265d7115 (patch)
tree2fc5af881c6db72d0f496440efe7313ddfd2d311 /app-arch
parentstable ppc ppc64, bug #429196 (diff)
downloadgentoo-2-ea7bfa2d4293b3bfb0a9666661060ea3265d7115.tar.gz
gentoo-2-ea7bfa2d4293b3bfb0a9666661060ea3265d7115.tar.bz2
gentoo-2-ea7bfa2d4293b3bfb0a9666661060ea3265d7115.zip
Old.
(Portage version: 2.2.0_alpha129/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.16.2.ebuild95
-rw-r--r--app-arch/dpkg/dpkg-1.16.4.2-r1.ebuild90
-rw-r--r--app-arch/dpkg/dpkg-1.16.4.3.ebuild90
-rw-r--r--app-arch/dpkg/dpkg-1.16.6.ebuild91
-rw-r--r--app-arch/dpkg/dpkg-1.16.7.ebuild91
6 files changed, 6 insertions, 458 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 3ebdefaba4fe..78173b986034 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.202 2012/09/20 15:28:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.203 2012/09/20 15:40:09 jer Exp $
+
+ 20 Sep 2012; Jeroen Roovers <jer@gentoo.org> -dpkg-1.16.2.ebuild,
+ -dpkg-1.16.4.2-r1.ebuild, -dpkg-1.16.4.3.ebuild, -dpkg-1.16.6.ebuild,
+ -dpkg-1.16.7.ebuild:
+ Old.
20 Sep 2012; Anthony G. Basile <blueness@gentoo.org> dpkg-1.16.8.ebuild:
stable ppc64, bug #432422
diff --git a/app-arch/dpkg/dpkg-1.16.2.ebuild b/app-arch/dpkg/dpkg-1.16.2.ebuild
deleted file mode 100644
index d4ef2ce11268..000000000000
--- a/app-arch/dpkg/dpkg-1.16.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.2.ebuild,v 1.9 2012/07/08 15:33:47 armin76 Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.4.2-r1.ebuild b/app-arch/dpkg/dpkg-1.16.4.2-r1.ebuild
deleted file mode 100644
index 2efef3f67194..000000000000
--- a/app-arch/dpkg/dpkg-1.16.4.2-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.4.2-r1.ebuild,v 1.1 2012/06/12 15:37:28 jer Exp $
-
-EAPI=4
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-REQUIRED_USE="dselect? ( nls )"
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${P}-gzip-rsyncable.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- ${myconf} \
- $(use_enable dselect) \
- $(use_enable unicode) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --disable-compiler-optimisations \
- --disable-linker-optimisations \
- --without-selinux \
- --disable-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.4.3.ebuild b/app-arch/dpkg/dpkg-1.16.4.3.ebuild
deleted file mode 100644
index 7b77c6faa78c..000000000000
--- a/app-arch/dpkg/dpkg-1.16.4.3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.4.3.ebuild,v 1.1 2012/06/18 10:47:42 jer Exp $
-
-EAPI=4
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-REQUIRED_USE="dselect? ( nls )"
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.16.4.2-gzip-rsyncable.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- ${myconf} \
- $(use_enable dselect) \
- $(use_enable unicode) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --disable-compiler-optimisations \
- --disable-linker-optimisations \
- --without-selinux \
- --disable-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.6.ebuild b/app-arch/dpkg/dpkg-1.16.6.ebuild
deleted file mode 100644
index 26f5f1eed8bd..000000000000
--- a/app-arch/dpkg/dpkg-1.16.6.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.6.ebuild,v 1.1 2012/07/02 10:47:56 jer Exp $
-
-EAPI=4
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- nls? ( app-text/po4a )
- sys-devel/flex
- virtual/pkgconfig
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-REQUIRED_USE="dselect? ( nls )"
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.16.4.2-gzip-rsyncable.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- ${myconf} \
- $(use_enable dselect) \
- $(use_enable unicode) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --disable-compiler-optimisations \
- --disable-linker-optimisations \
- --without-selinux \
- --disable-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.7.ebuild b/app-arch/dpkg/dpkg-1.16.7.ebuild
deleted file mode 100644
index 562188fbb720..000000000000
--- a/app-arch/dpkg/dpkg-1.16.7.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.7.ebuild,v 1.1 2012/07/03 13:50:39 jer Exp $
-
-EAPI=4
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- nls? ( app-text/po4a )
- sys-devel/flex
- virtual/pkgconfig
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-REQUIRED_USE="dselect? ( nls )"
-
-src_prepare() {
- # do not expect Debian's gzip --rsyncable extension
- epatch "${FILESDIR}"/${PN}-1.16.4.2-gzip-rsyncable.patch
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- # test fails (bug #414095)
- sed -i utils/Makefile.am \
- -e '/^test_cases/d;/100_update_alternatives/d' || die
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- econf \
- ${myconf} \
- $(use_enable dselect) \
- $(use_enable unicode) \
- $(use_with bzip2 bz2) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --disable-compiler-optimisations \
- --disable-linker-optimisations \
- --without-selinux \
- --disable-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}