summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2006-10-20 07:53:42 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2006-10-20 07:53:42 +0000
commit2f6b21d08db3a71651b3d50df830157824a5f659 (patch)
tree38ac92623b90401bf9003586392c30eaf926184e /app-backup/ccollect/ccollect-0.5.1.ebuild
parentUse games_make_wrapper (diff)
downloadgentoo-2-2f6b21d08db3a71651b3d50df830157824a5f659.tar.gz
gentoo-2-2f6b21d08db3a71651b3d50df830157824a5f659.tar.bz2
gentoo-2-2f6b21d08db3a71651b3d50df830157824a5f659.zip
Version bump by upstream
(Portage version: 2.1.1)
Diffstat (limited to 'app-backup/ccollect/ccollect-0.5.1.ebuild')
-rw-r--r--app-backup/ccollect/ccollect-0.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-backup/ccollect/ccollect-0.5.1.ebuild b/app-backup/ccollect/ccollect-0.5.1.ebuild
new file mode 100644
index 000000000000..a508d287710b
--- /dev/null
+++ b/app-backup/ccollect/ccollect-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/ccollect/ccollect-0.5.1.ebuild,v 1.1 2006/10/20 07:53:42 killerfox Exp $
+
+DESCRIPTION="(pseudo) incremental backup with different exclude lists using
+hardlinks and rsync"
+HOMEPAGE="http://linux.schottelius.org/ccollect/"
+SRC_URI="http://linux.schottelius.org/ccollect/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~hppa ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( >=app-text/asciidoc-7.0.2 )"
+RDEPEND="sys-devel/bc
+ net-misc/rsync
+ app-arch/pax"
+
+src_compile() {
+ if use doc; then
+ make documentation
+ else
+ einfo 'Nothing to compile'
+ fi
+}
+
+src_install() {
+ dobin ccollect.sh
+
+ insinto /usr/share/${PN}/tools
+ doins tools/*
+
+ if use doc; then
+ dodoc doc/*
+
+ # dodoc is not recursive. So do a workaround.
+ insinto /usr/share/doc/${PF}/examples/
+ doins -r ${S}/conf
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from 0.3.X or less, please run"
+ ewarn "/usr/share/ccollect/tools/config-pre-0.4-to-0.4.sh"
+ ewarn "because the old configuration is no longer compatible."
+}
+