summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-20 12:03:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-20 12:03:38 +0000
commit943d8f17b2dadeeffa40d37aeae145cbbb11dae9 (patch)
tree1109f72c43706015ea76d54f63b25db491aedf31 /app-backup/fsarchiver/fsarchiver-0.6.12.ebuild
parentUse bundled tiff so that we can have tiff-4 from tree installed, #391071 (diff)
downloadgentoo-2-943d8f17b2dadeeffa40d37aeae145cbbb11dae9.tar.gz
gentoo-2-943d8f17b2dadeeffa40d37aeae145cbbb11dae9.tar.bz2
gentoo-2-943d8f17b2dadeeffa40d37aeae145cbbb11dae9.zip
Moved from sunrise overlay. Thanks to Marcin Miroslaw <bug@mejor.pl>. Bug #261106
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/fsarchiver/fsarchiver-0.6.12.ebuild')
-rw-r--r--app-backup/fsarchiver/fsarchiver-0.6.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/fsarchiver/fsarchiver-0.6.12.ebuild b/app-backup/fsarchiver/fsarchiver-0.6.12.ebuild
new file mode 100644
index 000000000000..ba04c2dbee71
--- /dev/null
+++ b/app-backup/fsarchiver/fsarchiver-0.6.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/fsarchiver/fsarchiver-0.6.12.ebuild,v 1.1 2011/11/20 12:03:38 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Flexible filesystem archiver for backup and deployment tool"
+HOMEPAGE="http://www.fsarchiver.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug lzma lzo static"
+
+DEPEND="dev-libs/libgcrypt
+ >=sys-fs/e2fsprogs-1.41.4
+ lzma? ( >=app-arch/xz-utils-4.999.9_beta )
+ lzo? ( >=dev-libs/lzo-2.02 )
+ static? ( lzma? ( app-arch/xz-utils[static-libs] ) )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am || die "seding
+ failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable lzma) \
+ $(use_enable lzo) \
+ $(use_enable static) \
+ $(use_enable debug devel)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}