summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-05-17 01:48:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-05-17 01:48:38 +0000
commit0d9b1b1ab3bd715ebcb151f1718cad9d90690a18 (patch)
tree2dfb658c8115eb8baea930bef6a7454ed12ccbd6 /app-backup/kdar/kdar-2.1.0.ebuild
parentp.mask =app-text/sword-modules-20041209 for removal (diff)
downloadgentoo-2-0d9b1b1ab3bd715ebcb151f1718cad9d90690a18.tar.gz
gentoo-2-0d9b1b1ab3bd715ebcb151f1718cad9d90690a18.tar.bz2
gentoo-2-0d9b1b1ab3bd715ebcb151f1718cad9d90690a18.zip
Version bumped.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-backup/kdar/kdar-2.1.0.ebuild')
-rw-r--r--app-backup/kdar/kdar-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/kdar/kdar-2.1.0.ebuild b/app-backup/kdar/kdar-2.1.0.ebuild
new file mode 100644
index 000000000000..8ff317dfba24
--- /dev/null
+++ b/app-backup/kdar/kdar-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/kdar/kdar-2.1.0.ebuild,v 1.1 2008/05/17 01:48:38 matsuu Exp $
+
+ARTS_REQUIRED="never"
+inherit flag-o-matic kde
+
+DESCRIPTION="KDE Disk Archiver."
+HOMEPAGE="http://kdar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dar32 dar64"
+
+DEPEND=">=app-backup/dar-2.3.5
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4"
+
+need-kde 3.3
+
+src_compile() {
+ local myconf
+
+ # Bug 116112
+ replace-flags "-Os" "-O2"
+
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ kde_src_compile
+}