summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-04 06:35:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-04 06:35:58 +0000
commita966d5766ec39ae383122905c96dffcecaef02dd (patch)
tree5710ae08c3a01ca6a89ecc00863af0cfae4719b5 /app-backup/mondo-rescue/mondo-rescue-2.10.ebuild
parentMoved net-misc/rsnapshot to app-backup/rsnapshot (diff)
downloadgentoo-2-a966d5766ec39ae383122905c96dffcecaef02dd.tar.gz
gentoo-2-a966d5766ec39ae383122905c96dffcecaef02dd.tar.bz2
gentoo-2-a966d5766ec39ae383122905c96dffcecaef02dd.zip
Moved from sys-apps/mondo-rescue to app-backup/mondo-rescue.
Diffstat (limited to 'app-backup/mondo-rescue/mondo-rescue-2.10.ebuild')
-rw-r--r--app-backup/mondo-rescue/mondo-rescue-2.10.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-backup/mondo-rescue/mondo-rescue-2.10.ebuild b/app-backup/mondo-rescue/mondo-rescue-2.10.ebuild
new file mode 100644
index 000000000000..36eb75c52c62
--- /dev/null
+++ b/app-backup/mondo-rescue/mondo-rescue-2.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/mondo-rescue/mondo-rescue-2.10.ebuild,v 1.1 2005/07/04 06:35:58 robbat2 Exp $
+
+inherit libtool
+
+DESCRIPTION="A program which a Linux user can utilize to create a rescue/restore CD/tape."
+HOMEPAGE="http://www.mondorescue.org/"
+SRC_URI="http://www.mondorescue.org/download/MondoCD/TGZS/${PN/-rescue/}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-libs/slang-1.4.1
+ >=dev-libs/newt-0.50"
+RDEPEND="app-arch/afio
+ sys-block/buffer
+ sys-devel/binutils
+ >=app-arch/bzip2-0.9
+ app-cdr/cdrtools
+ >=sys-apps/mindi-1.10
+ >=dev-libs/newt-0.50
+ >=sys-libs/slang-1.4.1
+ >=sys-boot/syslinux-1.52"
+
+S=${WORKDIR}/${PN/-rescue/}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ chmod 750 configure
+}
+
+src_compile() {
+ elibtoolize
+ econf || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ #make install DESTDIR=${D} || die "make install failed"
+ einstall || die "Install failed"
+ exeinto /usr/share/mondo
+ doexe mondo/autorun
+}
+
+pkg_postinst() {
+ einfo "${P} was successfully installed."
+ einfo "Please read the associated docs for help."
+ einfo "Or visit the website @ ${HOMEPAGE}"
+ echo
+ ewarn "This package is still in unstable."
+ ewarn "Please report bugs to http://bugs.gentoo.org/"
+ ewarn "However, please do an advanced query to search for bugs"
+ ewarn "before reporting. This will keep down on duplicates."
+ echo
+ einfo "Prior to running mondo, ensure /boot is mounted."
+ ewarn "Grub users need to have a symlink like this:"
+ ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
+ einfo "Unless you want to have mondo backup your distfiles,"
+ einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
+ echo
+}