summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-24 14:48:47 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-24 14:48:47 +0000
commit05d9ed81136773cff157b92df39c3072a3ff9ee6 (patch)
treecf7b55d6c9e65a63e256300fcf9e11edae86ec29 /app-backup
parentversion bump. (diff)
downloadgentoo-2-05d9ed81136773cff157b92df39c3072a3ff9ee6.tar.gz
gentoo-2-05d9ed81136773cff157b92df39c3072a3ff9ee6.tar.bz2
gentoo-2-05d9ed81136773cff157b92df39c3072a3ff9ee6.zip
Fix deprecation warning introduced by perl 5.16, fixing bug 495232.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/flexbackup/ChangeLog8
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.16-deprecation-warning.patch11
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.1-r12.ebuild85
3 files changed, 103 insertions, 1 deletions
diff --git a/app-backup/flexbackup/ChangeLog b/app-backup/flexbackup/ChangeLog
index 04fe69c54c0f..5bf6fffde45e 100644
--- a/app-backup/flexbackup/ChangeLog
+++ b/app-backup/flexbackup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/flexbackup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.46 2013/12/24 01:57:02 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.47 2013/12/24 14:48:47 graaff Exp $
+
+*flexbackup-1.2.1-r12 (24 Dec 2013)
+
+ 24 Dec 2013; Hans de Graaff <graaff@gentoo.org> +flexbackup-1.2.1-r12.ebuild,
+ +files/flexbackup-1.2.1-perl-5.16-deprecation-warning.patch:
+ Fix deprecation warning introduced by perl 5.16, fixing bug 495232.
24 Dec 2013; Tom Wijsman <TomWij@gentoo.org>
-files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch:
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.16-deprecation-warning.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.16-deprecation-warning.patch
new file mode 100644
index 000000000000..72d3abd838a7
--- /dev/null
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.16-deprecation-warning.patch
@@ -0,0 +1,11 @@
+--- /usr/bin/flexbackup 2010-12-30 08:09:10.000000000 +0100
++++ flexbackup 2013-12-24 15:44:25.000000000 +0100
+@@ -2688,7 +2688,7 @@
+ }
+
+ # Flag old config file
+- if (defined(@cfg::filesystems) or defined($cfg::mt_var_blksize)) {
++ if (@cfg::filesystems or $cfg::mt_var_blksize) {
+ # so strict shuts up
+ my $junk = @cfg::filesystems;
+ $junk = $cfg::mt_var_blksize;
diff --git a/app-backup/flexbackup/flexbackup-1.2.1-r12.ebuild b/app-backup/flexbackup/flexbackup-1.2.1-r12.ebuild
new file mode 100644
index 000000000000..fa40ac42b875
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.1-r12.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.1-r12.ebuild,v 1.1 2013/12/24 14:48:47 graaff Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/mt-st"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch from upstream adds optional lzma compression mode.
+ epatch "${FILESDIR}"/${P}-lzma.patch
+
+ # Fix bug #116510: cannot back up remote machines after patch CAN-2005-2965
+ epatch "${FILESDIR}"/${P}-secure-tempfile.patch
+
+ # Fix bug #96334: incorrectly determines bash 3.x to be bash 1.x
+ epatch "${FILESDIR}"/${P}-bash.patch
+
+ # Fix bug #171205: specifies wrong command line option for mbuffer / other small enhancements
+ epatch "${FILESDIR}"/${P}-mbuffer-switch.patch
+
+ # Fix bug #173672: remote host buffer test is broken
+ epatch "${FILESDIR}"/${P}-remote-bufftest.patch
+
+ # Fix bug #178126: subtle subtree pruning issue / other small issues
+ epatch "${FILESDIR}"/${P}-prune.patch
+
+ # Fix bug #184560: fails to back up targets with spaces in their names in some modes
+ epatch "${FILESDIR}"/${P}-spaces-in-filenames.patch
+
+ # Fix bug #190357: fails on very large files with afio back end
+ epatch "${FILESDIR}"/${P}-afio-large-files.patch
+
+ # Fix bug #235416: prevent normal status message during conf file read from going to stderr
+ epatch "${FILESDIR}"/${P}-quieten.patch
+
+ # Fix bug #331673: perl 5.12 deprecation warnings.
+ epatch "${FILESDIR}"/${P}-perl-5.12-deprecation-warning.patch
+
+ # Fix bug #495232: perl 5.16 deprecation warnings.
+ epatch "${FILESDIR}"/${P}-perl-5.16-deprecation-warning.patch
+
+ sed -i \
+ -e '/^\$type = /s:afio:tar:' \
+ -e "/^\$buffer = /s:'buffer':'false':" \
+ flexbackup.conf \
+ || die "Failed to set modified configuration defaults."
+
+ MY_PV=$(replace_all_version_separators '_')
+ sed -i \
+ -e "/^[[:blank:]]*my \$ver = /s:${MY_PV}:&-${PR}:" \
+ flexbackup \
+ || die "Failed to apply ebuild revision to internal version string."
+}
+
+src_install() {
+ dodir /etc /usr/bin /usr/share/man/man{1,5}
+ emake install \
+ PREFIX="${D}"/usr \
+ CONFFILE="${D}"/etc/flexbackup.conf \
+ || die "emake install failed"
+
+ dodoc CHANGES CREDITS README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/flexbackup.conf file to suit your"
+ elog "needs. If you are using devfs, the tape device should"
+ elog "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ elog "archiver other than tar, please emerge it separately."
+}