summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2006-05-16 16:56:18 +0000
committerLisa M. Seelye <lisa@gentoo.org>2006-05-16 16:56:18 +0000
commit9033af144b5aaa234d5f23c78f35f9e41ae3260d (patch)
tree7289935ad49a9638a52835d8bd01553b18a32b24 /app-backup
parentadd two packages with dxr3 use flag (diff)
downloadgentoo-2-9033af144b5aaa234d5f23c78f35f9e41ae3260d.tar.gz
gentoo-2-9033af144b5aaa234d5f23c78f35f9e41ae3260d.tar.bz2
gentoo-2-9033af144b5aaa234d5f23c78f35f9e41ae3260d.zip
Fix bug 133409 and other sandbox violations i hope. Also put this in ~arch.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bobs/ChangeLog7
-rw-r--r--app-backup/bobs/bobs-0.6.2-r1.ebuild13
-rw-r--r--app-backup/bobs/files/Makefile-fixcmdloopd.patch11
3 files changed, 26 insertions, 5 deletions
diff --git a/app-backup/bobs/ChangeLog b/app-backup/bobs/ChangeLog
index 8fce3dff17ff..520b5b882df1 100644
--- a/app-backup/bobs/ChangeLog
+++ b/app-backup/bobs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/bobs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/ChangeLog,v 1.3 2006/05/15 12:45:12 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/ChangeLog,v 1.4 2006/05/16 16:56:18 lisa Exp $
+
+ 16 May 2006; Lisa Seelye <lisa@gentoo.org>
+ +files/Makefile-fixcmdloopd.patch, -bobs-0.6.2.ebuild,
+ bobs-0.6.2-r1.ebuild:
+ Fix bug 133409 and put this in ~arch. Not sure how it got committed without it.
*bobs-0.6.2-r1 (15 May 2006)
diff --git a/app-backup/bobs/bobs-0.6.2-r1.ebuild b/app-backup/bobs/bobs-0.6.2-r1.ebuild
index 975945e4f33e..be8df95236ea 100644
--- a/app-backup/bobs/bobs-0.6.2-r1.ebuild
+++ b/app-backup/bobs/bobs-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/bobs-0.6.2-r1.ebuild,v 1.1 2006/05/15 12:45:12 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bobs/bobs-0.6.2-r1.ebuild,v 1.2 2006/05/16 16:56:18 lisa Exp $
inherit webapp eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/bobs/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86"
+KEYWORDS="~x86"
IUSE=""
@@ -22,6 +22,9 @@ src_unpack() {
epatch ${FILESDIR}/bobs-0.6.2.patch
+ #Makefile was executing commands out of the sandbox (bug #133409)
+ epatch ${FILESDIR}/Makefile-fixcmdloopd.patch
+
# Original configure looks for httpd process. Hardwire to apache2...
sed -e "s:\$(ps -C httpd:\$(ps -C apache2:" \
-i 'configure' || die "Autodetect of Apache user failed"
@@ -39,8 +42,8 @@ src_unpack() {
}
src_compile() {
- ./configure \
- --with-webdir=/usr/share/webapps/${PN}/${PV}/htdocs \
+ econf \
+ --with-webdir=/usr/share/webapps/${PN}/${PVR}/htdocs \
|| die "configure failed"
emake || die "emake failed"
@@ -48,6 +51,7 @@ src_compile() {
src_install() {
webapp_src_preinst
+# MY_HTDOCSDIR="/usr/share/webapps/${PN}/${PVR}"
if [[ ! `built_with_use virtual/php posix` ]]; then
ewarn "Your PHP does not appear to support POSIX functions. ${P} requires"
ewarn "POSIX functions to be enabled. I will continue to install ${P} but"
@@ -76,4 +80,5 @@ src_install() {
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
+ einfo "Add /etc/init.d/cmdloopd to default runlevel"
}
diff --git a/app-backup/bobs/files/Makefile-fixcmdloopd.patch b/app-backup/bobs/files/Makefile-fixcmdloopd.patch
new file mode 100644
index 000000000000..835480455b51
--- /dev/null
+++ b/app-backup/bobs/files/Makefile-fixcmdloopd.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.dist 2006-05-15 23:22:50.000000000 +0100
++++ Makefile.in 2006-05-15 23:23:10.000000000 +0100
+@@ -539,7 +539,7 @@
+ echo "*******************************"; \
+ fi
+
+- -$(myrealSYSCONFDIR)/init.d/cmdloopd start
++# -$(myrealSYSCONFDIR)/init.d/cmdloopd start
+
+ # Remove some other crap for 'make distclean'
+