summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2010-08-21 01:27:23 +0000
committerRichard Freeman <rich0@gentoo.org>2010-08-21 01:27:23 +0000
commitb5b004aa77a8b0f56fb8971a30d24cb8f17224b4 (patch)
tree85369c1dad9f71392e3ddc11fe724303da075cf6 /app-backup
parentVersion bump (diff)
downloadgentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.tar.gz
gentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.tar.bz2
gentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.zip
bump - 322817, thanks all for patience
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/sarab/ChangeLog10
-rw-r--r--app-backup/sarab/files/1.0.0-better-defaults-gentoo.patch21
-rw-r--r--app-backup/sarab/sarab-1.0.0.ebuild40
3 files changed, 69 insertions, 2 deletions
diff --git a/app-backup/sarab/ChangeLog b/app-backup/sarab/ChangeLog
index cfe41a64b927..938e0b365c97 100644
--- a/app-backup/sarab/ChangeLog
+++ b/app-backup/sarab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/sarab
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/ChangeLog,v 1.11 2009/03/31 21:48:28 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/ChangeLog,v 1.12 2010/08/21 01:27:21 rich0 Exp $
+
+*sarab-1.0.0 (20 Aug 2010)
+
+ 20 Aug 2010; Richard Freeman <rich0@gentoo.org>
+ +files/1.0.0-better-defaults-gentoo.patch, +sarab-1.0.0.ebuild:
+ bump - 322817, thanks all for patience
*sarab-0.2.7 (31 Mar 2009)
diff --git a/app-backup/sarab/files/1.0.0-better-defaults-gentoo.patch b/app-backup/sarab/files/1.0.0-better-defaults-gentoo.patch
new file mode 100644
index 000000000000..ecb8b558e067
--- /dev/null
+++ b/app-backup/sarab/files/1.0.0-better-defaults-gentoo.patch
@@ -0,0 +1,21 @@
+--- sarab-1.0.0.orig/etc/sarab.conf 2010-02-21 06:13:22.000000000 -0500
++++ sarab-1.0.0/etc/sarab.conf 2010-08-20 18:30:41.630323933 -0400
+@@ -76,10 +76,10 @@
+
+ # The location of the DAR executable file
+ # This line is only effective if not added by install.sh later in this file
+-DAR_BINARY="/usr/local/bin/dar"
++DAR_BINARY="/usr/bin/dar"
+
+ # The location of the statically-compiled DAR executable file
+-DAR_STATIC="/usr/local/bin/dar_static"
++DAR_STATIC="/usr/bin/dar_static"
+
+ # The temporary directory name that backups will be created in. This will be created underneath $DESTINATION.
+ WORK_DIR=".sarab_temp_workdir"
+@@ -88,4 +88,4 @@
+ DAR_CREATE="$DESTINATION/$WORK_DIR/$BASENAME"
+
+ # Location and name of temporary log file
+-TEMP_LOG="$SARAB_ETC/sarab_temp.log"
++TEMP_LOG="/var/log/sarab_temp.log"
diff --git a/app-backup/sarab/sarab-1.0.0.ebuild b/app-backup/sarab/sarab-1.0.0.ebuild
new file mode 100644
index 000000000000..aeab495faaee
--- /dev/null
+++ b/app-backup/sarab/sarab-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/sarab-1.0.0.ebuild,v 1.1 2010/08/21 01:27:23 rich0 Exp $
+
+inherit eutils
+
+DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR."
+HOMEPAGE="http://sarab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-backup/dar
+ virtual/mailx"
+
+src_unpack() {
+ cd "${S}"
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${PV}-better-defaults-gentoo.patch
+}
+
+src_install() {
+ dobin sarab.sh
+ insinto /etc/sarab
+ doins -r etc/*
+ # sarab.conf could contain passphrase information
+ fperms 600 /etc/sarab/sarab.conf
+ dodoc CHANGELOG FAQ INSTALL README
+ dodoc "${FILESDIR}"/README.Gentoo
+}
+
+pkg_postinstl() {
+ ewarn "The configuration format for DAR encryption has changed in Sarab 0.2.4."
+ ewarn "Replace DAR_ENCRYPTION_OPTIONS=\"--key blowfish:PASSPHRASE\""
+ ewarn "by SARAB_KEY=\"blowfish:PASSPHRASE\" in /etc/sarab/sarab.conf"
+}