summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:21 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:21 +0000
commit7debca8b7ec7d8f31ca862d3c5090636edb8a70c (patch)
tree7ad1e18dec22595deb567eb2311294c2a028c19d /app-benchmarks/bonnie++
parentMoved app-misc/bonnie++ to app-benchmarks/bonnie++ (diff)
downloadgentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.tar.gz
gentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.tar.bz2
gentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.zip
Moved app-misc/bonnie++ to app-benchmarks/bonnie++
Diffstat (limited to 'app-benchmarks/bonnie++')
-rw-r--r--app-benchmarks/bonnie++/ChangeLog41
-rw-r--r--app-benchmarks/bonnie++/Manifest6
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild28
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.03.ebuild31
-rw-r--r--app-benchmarks/bonnie++/files/digest-bonnie++-1.02c-r11
-rw-r--r--app-benchmarks/bonnie++/files/digest-bonnie++-1.031
6 files changed, 105 insertions, 3 deletions
diff --git a/app-benchmarks/bonnie++/ChangeLog b/app-benchmarks/bonnie++/ChangeLog
new file mode 100644
index 000000000000..60e5700891d9
--- /dev/null
+++ b/app-benchmarks/bonnie++/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for app-misc/bonnie++
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/ChangeLog,v 1.1 2003/06/25 20:51:56 mholzer Exp $
+
+*bonnie++-1.02c-r1 (25 Jun 2003)
+
+ 25 Jun 2003; Martin Holzer <mholzer@gentoo.org> bonnie++-1.02c-r1.ebuild,
+ bonnie++-1.03.ebuild:
+ Moved app-misc/bonnie++ to app-benchmarks/bonnie++
+
+*bonnie++-1.03 (6 Dec 2002)
+
+ 08 Jan 2003; Jack Morgan <jmorgan@gentoo.org> bonnie++-1.03.ebuild :
+ Removed sparc64 keyword
+
+ 4 Jan 2003; George Shapovalov <george@gentoo.org> bonnie++-1.03.ebuild :
+ for whatever reason got this one assigned to me.
+ Checked and committed.
+
+ 5 Dec 2002; William McArthur <sandymac@gentoo.org> bonnie++-1.03.ebuild :
+
+ Bummped the ebuild file name and added IUSE and DEPEND lines.
+
+*bonnie++-1.02c-r1 (14 Oct 2002)
+
+ 14 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ In gcc3.x, 'vector.h' is detected as not being installed (due to the
+ fact that you're *supposed* to call it 'vector') ... and zcav is not
+ built. if you force the compilation ('make zcav') it will work, just
+ complain that you're using an old header file (#9073)
+ The version bump is because the install would continue even if zcav
+ wasnt created/installed
+
+*bonnie++-1.02c (26 Apr 2002)
+
+ 26 Apr 2002; William McArthur <sandymac@gentoo.org> bonnie++-1.02c.ebuild :
+ Just renamed the ebuild for a newer version of the upstream package. Version
+ 1.02c fixes "a very serious bug in reporting of seek test results."
+
+*bonnie++-1.02a (1 Feb 2002)
+
diff --git a/app-benchmarks/bonnie++/Manifest b/app-benchmarks/bonnie++/Manifest
index 0468de104292..7098e890cb78 100644
--- a/app-benchmarks/bonnie++/Manifest
+++ b/app-benchmarks/bonnie++/Manifest
@@ -1,5 +1,5 @@
-MD5 a99af49bfa1d6f1115d2edbfe757ffbf ChangeLog 1380
-MD5 0455e3018789d11387ce583a4183e6df bonnie++-1.02c-r1.ebuild 830
-MD5 1b66bbe822b8642dbd3b9c95cbcf5239 bonnie++-1.03.ebuild 946
+MD5 3fe3d91309429e52346252420dec65c8 ChangeLog 1575
+MD5 b62b69e0e0c3a589db994a57e970d41f bonnie++-1.02c-r1.ebuild 837
+MD5 9c2bc7e5abca73485b96e8429fc23470 bonnie++-1.03.ebuild 953
MD5 0c790252377cc712ba5b9d715e4fa9b7 files/digest-bonnie++-1.02c-r1 62
MD5 f7a1f45cf334317f5cbafa8ac9cea78a files/digest-bonnie++-1.03 61
diff --git a/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild b/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild
new file mode 100644
index 000000000000..3ffb08fcc4f0
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.02c-r1.ebuild,v 1.1 2003/06/25 20:51:56 mholzer Exp $
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf=""
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+
+ econf ${myconf}
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav
+ dobin bon_csv2html bon_csv2txt
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt copyright.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
new file mode 100644
index 000000000000..7e19d4e7a24f
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.1 2003/06/25 20:51:56 mholzer Exp $
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+
+SLOT="0"
+LICENSE="GPL-2"
+# I think this should work on other than x86 platforms (by sandymac)
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf=""
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+
+ econf ${myconf}
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav
+ dobin bon_csv2html bon_csv2txt
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt copyright.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/files/digest-bonnie++-1.02c-r1 b/app-benchmarks/bonnie++/files/digest-bonnie++-1.02c-r1
new file mode 100644
index 000000000000..35e71cc59e1a
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/digest-bonnie++-1.02c-r1
@@ -0,0 +1 @@
+MD5 25d6f9882a7d8b7b538e3ed869bcb701 bonnie++-1.02c.tgz 60011
diff --git a/app-benchmarks/bonnie++/files/digest-bonnie++-1.03 b/app-benchmarks/bonnie++/files/digest-bonnie++-1.03
new file mode 100644
index 000000000000..a22287983873
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/digest-bonnie++-1.03
@@ -0,0 +1 @@
+MD5 0ce81f00b40fa5549503494cda8de25a bonnie++-1.03.tgz 76101