summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-11-23 09:56:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-11-23 09:56:37 +0000
commita9cb3a5f41447e28b4098d10180b419692917a0d (patch)
tree649f0936765f65783bbe97d2f9ff9b476fb5a574 /app-benchmarks/bonnie++
parentBump to 4.0, fixups on 2.0, benchmark herd taking over the world one (diff)
downloadgentoo-2-a9cb3a5f41447e28b4098d10180b419692917a0d.tar.gz
gentoo-2-a9cb3a5f41447e28b4098d10180b419692917a0d.tar.bz2
gentoo-2-a9cb3a5f41447e28b4098d10180b419692917a0d.zip
Bump.
(Portage version: 2.2_rc14/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'app-benchmarks/bonnie++')
-rw-r--r--app-benchmarks/bonnie++/ChangeLog9
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.94.ebuild40
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.94-64bit.patch15
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch46
4 files changed, 109 insertions, 1 deletions
diff --git a/app-benchmarks/bonnie++/ChangeLog b/app-benchmarks/bonnie++/ChangeLog
index 5bb674ed8913..d921de6f0a7b 100644
--- a/app-benchmarks/bonnie++/ChangeLog
+++ b/app-benchmarks/bonnie++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-benchmarks/bonnie++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/ChangeLog,v 1.22 2008/05/02 14:21:50 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/ChangeLog,v 1.23 2008/11/23 09:56:37 patrick Exp $
+
+*bonnie++-1.94 (23 Nov 2008)
+
+ 23 Nov 2008; Patrick Lauer <patrick@gentoo.org>
+ +files/bonnie++-1.94-64bit.patch,
+ +files/bonnie++-1.94-missing_include.patch, +bonnie++-1.94.ebuild:
+ Bump to 1.94
02 May 2008; Tiziano Müller <dev-zero@gentoo.org>
+files/bonnie++-1.93c-missing_include.patch, bonnie++-1.93c.ebuild:
diff --git a/app-benchmarks/bonnie++/bonnie++-1.94.ebuild b/app-benchmarks/bonnie++/bonnie++-1.94.ebuild
new file mode 100644
index 000000000000..045413eb1f26
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.94.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.94.ebuild,v 1.1 2008/11/23 09:56:37 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-64bit.patch" \
+ "${FILESDIR}/${P}-missing_include.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.94-64bit.patch b/app-benchmarks/bonnie++/files/bonnie++-1.94-64bit.patch
new file mode 100644
index 000000000000..2af76d8f8c80
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.94-64bit.patch
@@ -0,0 +1,15 @@
+--- getc_putc.cpp.old 2004-09-15 02:37:21.500489552 +0200
++++ getc_putc.cpp 2004-09-15 02:40:58.623481840 +0200
+@@ -165,7 +165,11 @@
+ int size = 0, wrote;
+ while(size < file_size)
+ {
+- wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ //wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ /*
++ * gcc doesn't like above line. ? : should do the job as good as min()...
++ */
++ wrote = write(FILE_FD, buf, (sizeof(buf) < (file_size - size) ? (sizeof(buf)):(file_size - size)));
+ if(wrote < 0)
+ {
+ fprintf(stderr, "Can't extend file - disk full?\n");
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()