summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-13 08:12:28 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-13 08:12:28 +0000
commit63bb247271ccc53e0b16777e988f3082cca7602e (patch)
tree7e539c7a494e0a7a746890823976bd2d81fb9f6a /app-benchmarks/ioping
parentAdd ruby19. (diff)
downloadgentoo-2-63bb247271ccc53e0b16777e988f3082cca7602e.tar.gz
gentoo-2-63bb247271ccc53e0b16777e988f3082cca7602e.tar.bz2
gentoo-2-63bb247271ccc53e0b16777e988f3082cca7602e.zip
New inclusion, #398735; thanks Vladimir Berezhnoy for the initial ebuild
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/ioping')
-rw-r--r--app-benchmarks/ioping/ChangeLog10
-rw-r--r--app-benchmarks/ioping/Manifest5
-rw-r--r--app-benchmarks/ioping/files/ioping-0.6-makefile.patch26
-rw-r--r--app-benchmarks/ioping/ioping-0.6.ebuild26
-rw-r--r--app-benchmarks/ioping/metadata.xml7
5 files changed, 74 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/ChangeLog b/app-benchmarks/ioping/ChangeLog
new file mode 100644
index 000000000000..3e00ed690fc8
--- /dev/null
+++ b/app-benchmarks/ioping/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-benchmarks/ioping
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ioping/ChangeLog,v 1.1 2012/01/13 08:12:28 jlec Exp $
+
+*ioping-0.6 (13 Jan 2012)
+
+ 13 Jan 2012; Justin Lecher <jlec@gentoo.org> +ioping-0.6.ebuild,
+ +files/ioping-0.6-makefile.patch, +metadata.xml:
+ New inclusion, #398735; thanks Vladimir Berezhnoy for the initial ebuild
+
diff --git a/app-benchmarks/ioping/Manifest b/app-benchmarks/ioping/Manifest
new file mode 100644
index 000000000000..93499a2d855d
--- /dev/null
+++ b/app-benchmarks/ioping/Manifest
@@ -0,0 +1,5 @@
+AUX ioping-0.6-makefile.patch 697 RMD160 c811e07614a2cb885501d4ba3e9c31b726b92f90 SHA1 9433ab171a7422ee5cec601dad7f59ee02c56331 SHA256 54846d3dff89ef8be97e4c9b7ddf78a073e76efa4da333d24e60d6fa66b8dde5
+DIST ioping-0.6.tar.gz 6957 RMD160 1142f2a59a51434eadc4a4b4893b94f4b604f071 SHA1 4b3860a6af0755467ebe67c09f36ddaebd9be3e7 SHA256 1d14469b1bfa9243f992be784cc0e3cd86c66bb7edc1b83e22360075c5435ceb
+EBUILD ioping-0.6.ebuild 516 RMD160 70eebb72346a139a0d145aae893e8939bcaac84c SHA1 c05edd1790a75372fa8af72a9fd1dfa72167317c SHA256 80426e6aba16eb0495508193b0c0411682ab36e81391286d06690c7057f622d3
+MISC ChangeLog 343 RMD160 a3d7a38d888b53a0fe724f7a5d10d96d3a536828 SHA1 c58d391a9ca0674c659371a10398a493fb261c84 SHA256 6a75a97c9bfa5c02d0b027df644ef743a4f63c5aab773c241f5a336c4e3b31c5
+MISC metadata.xml 201 RMD160 a6c5202673c0843bd9d1453b78b3f6bddc62a1f7 SHA1 6c7c52b9cddff4c6507fe6e49be0bbd53611d236 SHA256 180014e727f4e39b95bfeadf7661f97f2a0c8fe30658a82cd676fac065c7b3c9
diff --git a/app-benchmarks/ioping/files/ioping-0.6-makefile.patch b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
new file mode 100644
index 000000000000..b5836696e9f4
--- /dev/null
+++ b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
@@ -0,0 +1,26 @@
+ Makefile | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b3d741e..79022e9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+-CFLAGS+=-std=c99 -g -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+-LDFLAGS=-lm
+-PREFIX=/usr/local
++CFLAGS+=-std=c99 -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++LIBS=-lm
++PREFIX?=/usr/local
+ BINDIR=$(PREFIX)/bin
+ MAN1DIR=$(PREFIX)/share/man/man1
+
+@@ -30,7 +30,7 @@ install: $(BINS) $(MANS)
+ $(CC) $(CFLAGS) -DVERSION=\"${VERSION}\" -c -o $@ $^
+
+ ioping: $(OBJS)
+- $(CC) -o $@ $^ $(CFLAGS) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ dist: $(DISTDIR).tar.gz
+
diff --git a/app-benchmarks/ioping/ioping-0.6.ebuild b/app-benchmarks/ioping/ioping-0.6.ebuild
new file mode 100644
index 000000000000..2a6f935701d7
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ioping/ioping-0.6.ebuild,v 1.1 2012/01/13 08:12:28 jlec Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="http://code.google.com/p/ioping/"
+SRC_URI="http://ioping.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr"
+}
diff --git a/app-benchmarks/ioping/metadata.xml b/app-benchmarks/ioping/metadata.xml
new file mode 100644
index 000000000000..c845479d513e
--- /dev/null
+++ b/app-benchmarks/ioping/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>