summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-25 01:56:21 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-25 01:56:21 +0000
commitfc81224717c605549c1f16bc1958e4733018e1fb (patch)
tree3a034ab8dbeb3792e3d63ffaeeb0beee697e85bf /app-benchmarks/ltp/ltp-20041104.ebuild
parentMarked ~amd64 (diff)
downloadgentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.tar.gz
gentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.tar.bz2
gentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.zip
fixed to use treecopy for BSD compatibility - bug #106443
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-benchmarks/ltp/ltp-20041104.ebuild')
-rw-r--r--app-benchmarks/ltp/ltp-20041104.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-benchmarks/ltp/ltp-20041104.ebuild b/app-benchmarks/ltp/ltp-20041104.ebuild
index 108dcecb6e08..ea5415a91a3a 100644
--- a/app-benchmarks/ltp/ltp-20041104.ebuild
+++ b/app-benchmarks/ltp/ltp-20041104.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041104.ebuild,v 1.3 2005/01/01 12:05:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041104.ebuild,v 1.4 2005/09/25 01:56:21 dragonheart Exp $
-inherit eutils
+inherit eutils portability
MY_P="${PN}-full-${PV}"
S="${WORKDIR}/${MY_P}"
@@ -35,7 +35,7 @@ src_install() {
make install || die "install failed"
mkdir -p ${D}/usr/libexec/ltp/testcases ${D}/usr/bin/ || die "mkdir failed"
- cp --parents -r testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
+ treecopy testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
cp runltp runalltests.sh ${D}/usr/bin || die "cp failed"
# TODO: fix this so it works from "outside" the source tree