summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:24:20 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:24:20 +0000
commit1964beb2c1116f0a0c309dbec977caef1d2854ab (patch)
treeff87187af841249aba674131d621a83e408efe68 /app-benchmarks/siege
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-1964beb2c1116f0a0c309dbec977caef1d2854ab.tar.gz
gentoo-2-1964beb2c1116f0a0c309dbec977caef1d2854ab.tar.bz2
gentoo-2-1964beb2c1116f0a0c309dbec977caef1d2854ab.zip
Changed econf||die to econf
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/siege-2.55.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/app-benchmarks/siege/siege-2.55.ebuild b/app-benchmarks/siege/siege-2.55.ebuild
index 973c214e0b7d..dd76644ca839 100644
--- a/app-benchmarks/siege/siege-2.55.ebuild
+++ b/app-benchmarks/siege/siege-2.55.ebuild
@@ -1,36 +1,31 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.55.ebuild,v 1.4 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.55.ebuild,v 1.5 2002/11/30 02:24:20 vapier Exp $
-IUSE="ssl"
-
-S=${WORKDIR}/${P}
DESCRIPTION="An http regression testing and benchmarking utility"
SRC_URI="ftp://ftp.armstrong.com/pub/siege/${P}.tar.gz"
-HOMEPAGE="http://www.joedog.org/siege"
+HOMEPAGE="http://www.joedog.org/siege/"
SLOT="0"
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
+IUSE="ssl"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
src_compile() {
-
local myconf
use ssl && myconf="--with-ssl" || myconf="--with-ssl=off"
-
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
src_install() {
-
# makefile tries to install into $HOME by default... bad monkey!
dodir /usr/share/doc/${P}
- einstall SIEGERC="${D}/usr/share/doc/${P}/siegerc-example" || die
+ einstall SIEGERC="${D}/usr/share/doc/${P}/siegerc-example"
# all non-html docs must be gzip'd
gzip ${D}/usr/share/doc/${P}/siegerc-example