summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-21 13:19:42 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-21 13:19:42 +0000
commit4ac43768fafd819b857fe0111d2c0175a63fd37f (patch)
treedd25c9176c5a64b504d0a607aca70d89ef5be216 /app-benchmarks/spew
parentFix for automake-1.13, bug #468070 (diff)
downloadgentoo-2-4ac43768fafd819b857fe0111d2c0175a63fd37f.tar.gz
gentoo-2-4ac43768fafd819b857fe0111d2c0175a63fd37f.tar.bz2
gentoo-2-4ac43768fafd819b857fe0111d2c0175a63fd37f.zip
Fix automake-1.13, bug #467550; respect $AR
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-benchmarks/spew')
-rw-r--r--app-benchmarks/spew/ChangeLog5
-rw-r--r--app-benchmarks/spew/files/fix-automake-1.13.patch28
-rw-r--r--app-benchmarks/spew/spew-1.0.8.ebuild11
3 files changed, 39 insertions, 5 deletions
diff --git a/app-benchmarks/spew/ChangeLog b/app-benchmarks/spew/ChangeLog
index 1da2fbba1061..3a56eb8d4477 100644
--- a/app-benchmarks/spew/ChangeLog
+++ b/app-benchmarks/spew/ChangeLog
@@ -1,4 +1,6 @@
-
+# ChangeLog for app-benchmarks/spew
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/ChangeLog,v 1.7 2013/06/21 13:19:42 blueness Exp $
14 Jul 2012; Anthony G. Basile <blueness@gentoo.org> spew-1.0.8.ebuild:
Keyword ~arm ~mips
@@ -20,4 +22,3 @@
06 Apr 2011; Anthony G. Basile <blueness@gentoo.org> +spew-1.0.8.ebuild,
+files/remove-symlinks-makefile.patch, +metadata.xml:
Initial commit.
-
diff --git a/app-benchmarks/spew/files/fix-automake-1.13.patch b/app-benchmarks/spew/files/fix-automake-1.13.patch
new file mode 100644
index 000000000000..c046c1b955eb
--- /dev/null
+++ b/app-benchmarks/spew/files/fix-automake-1.13.patch
@@ -0,0 +1,28 @@
+diff -Naur spew-1.0.8.orig/configure.ac spew-1.0.8/configure.ac
+--- spew-1.0.8.orig/configure.ac 2010-05-14 01:17:52.000000000 -0400
++++ spew-1.0.8/configure.ac 2013-06-21 09:06:42.000000000 -0400
+@@ -2,20 +2,13 @@
+ # Process this file with autoconf to produce a configure script.
+
+ AC_PREREQ(2.57)
+-AC_INIT(src/spew.cpp)
++AC_INIT(spew, 1.0.8)
++AC_CONFIG_SRCDIR(src/spew.cpp)
+ AC_CONFIG_AUX_DIR(config)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AM_MAINTAINER_MODE
+
+-SPEW_AGE=1
+-SPEW_REVISION=0
+-SPEW_CURRENT=8
+-AC_SUBST(SPEW_AGE)
+-AC_SUBST(SPEW_REVISION)
+-AC_SUBST(SPEW_CURRENT)
+-VERSION=$SPEW_AGE.$SPEW_REVISION.$SPEW_CURRENT
+-
+-AM_INIT_AUTOMAKE(spew, $VERSION)
++AM_INIT_AUTOMAKE
+
+ # Checks for programs.
+ AC_PROG_CXX
diff --git a/app-benchmarks/spew/spew-1.0.8.ebuild b/app-benchmarks/spew/spew-1.0.8.ebuild
index 8c32d6eafe3f..d20e38e5c41d 100644
--- a/app-benchmarks/spew/spew-1.0.8.ebuild
+++ b/app-benchmarks/spew/spew-1.0.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.6 2012/07/14 12:36:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.7 2013/06/21 13:19:42 blueness Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Measures I/O performance and/or generates I/O load"
HOMEPAGE="http://spew.berlios.de/"
@@ -20,6 +20,7 @@ DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/fix-automake-1.13.patch
epatch "${FILESDIR}"/remove-symlinks-makefile.patch
eautoreconf
}
@@ -28,6 +29,10 @@ src_configure() {
econf $(use_enable static static-link)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
emake DESTDIR="${D}" install
dosym ${PN} /usr/bin/gorge