summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-06-02 01:24:57 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-06-02 01:24:57 +0000
commit46d623dd993a114634192cb0095ccefeefd33381 (patch)
treeac2b807f9a879a76f8f91ea448faf26ba51dca5a /app-benchmarks
parentnew dev version of gimp (diff)
downloadgentoo-2-46d623dd993a114634192cb0095ccefeefd33381.tar.gz
gentoo-2-46d623dd993a114634192cb0095ccefeefd33381.tar.bz2
gentoo-2-46d623dd993a114634192cb0095ccefeefd33381.zip
new dbench ebuild and app-benchmarks category
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/dbench/dbench-1.3.ebuild34
-rw-r--r--app-benchmarks/dbench/files/digest-dbench-1.31
2 files changed, 35 insertions, 0 deletions
diff --git a/app-benchmarks/dbench/dbench-1.3.ebuild b/app-benchmarks/dbench/dbench-1.3.ebuild
new file mode 100644
index 000000000000..6251d6b9d511
--- /dev/null
+++ b/app-benchmarks/dbench/dbench-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/dbench/dbench-1.3.ebuild,v 1.1 2002/06/02 01:24:57 drobbins Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Popular filesystem benchmark"
+SRC_URI="ftp://samba.org/pub/tridge/dbench/${P}.tar.gz"
+HOMEPAGE="ftp://samba.org/pub/tridge/dbench/"
+DEPEND="virtual/glibc sys-apps/sed"
+SLOT=0
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -Wall:${CFLAGS}:g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin dbench tbench tbench_srv
+ dodoc README
+ insinto /usr/share/dbench
+ doins client.txt
+}
+
+pkg_postinst() {
+ einfo "dbench info:"
+ einfo "You can find the client.txt file in ${ROOT}usr/share/dbench."
+ echo
+}
diff --git a/app-benchmarks/dbench/files/digest-dbench-1.3 b/app-benchmarks/dbench/files/digest-dbench-1.3
new file mode 100644
index 000000000000..d22deb5fe436
--- /dev/null
+++ b/app-benchmarks/dbench/files/digest-dbench-1.3
@@ -0,0 +1 @@
+MD5 38d6e6dcb6a4482e3e210f0f9c4050f9 dbench-1.3.tar.gz 266746