summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-19 13:22:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-19 13:22:12 +0000
commit9731c9013258b761afde83b546c4caa4aaa83671 (patch)
tree1b2e13f695600e467a4bbe90bb53566df3c95157 /app-benchmarks
parentStable for HPPA (bug #529392). (diff)
downloadgentoo-2-9731c9013258b761afde83b546c4caa4aaa83671.tar.gz
gentoo-2-9731c9013258b761afde83b546c4caa4aaa83671.tar.bz2
gentoo-2-9731c9013258b761afde83b546c4caa4aaa83671.zip
Fix bug #529764
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/spew/ChangeLog10
-rw-r--r--app-benchmarks/spew/files/fix-ncurses-tinfo.patch29
-rw-r--r--app-benchmarks/spew/spew-1.0.8-r1.ebuild43
3 files changed, 80 insertions, 2 deletions
diff --git a/app-benchmarks/spew/ChangeLog b/app-benchmarks/spew/ChangeLog
index 3a56eb8d4477..679d867e8db8 100644
--- a/app-benchmarks/spew/ChangeLog
+++ b/app-benchmarks/spew/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/spew
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/ChangeLog,v 1.7 2013/06/21 13:19:42 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/ChangeLog,v 1.8 2014/11/19 13:22:12 blueness Exp $
+
+*spew-1.0.8-r1 (19 Nov 2014)
+
+ 19 Nov 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/fix-ncurses-tinfo.patch, +spew-1.0.8-r1.ebuild:
+ Fix bug #529764
14 Jul 2012; Anthony G. Basile <blueness@gentoo.org> spew-1.0.8.ebuild:
Keyword ~arm ~mips
diff --git a/app-benchmarks/spew/files/fix-ncurses-tinfo.patch b/app-benchmarks/spew/files/fix-ncurses-tinfo.patch
new file mode 100644
index 000000000000..9905e2057042
--- /dev/null
+++ b/app-benchmarks/spew/files/fix-ncurses-tinfo.patch
@@ -0,0 +1,29 @@
+diff -Naur spew-1.0.8.orig/configure.ac spew-1.0.8/configure.ac
+--- spew-1.0.8.orig/configure.ac 2014-11-19 08:15:31.284273029 -0500
++++ spew-1.0.8/configure.ac 2014-11-19 08:16:07.063274657 -0500
+@@ -21,6 +21,7 @@
+ # Checks for libraries.
+ AC_CHECK_LIB(popt, poptGetContext, ,AC_MSG_ERROR([PACKAGE] requires popt))
+ AC_CHECK_LIB(ncurses, wresize, ,AC_MSG_ERROR([PACKAGE] requires ncurses))
++PKG_CHECK_MODULES(NCURSES, [ncurses])
+
+ # Checks for header files.
+ AC_HEADER_STDC
+diff -Naur spew-1.0.8.orig/src/Makefile.am spew-1.0.8/src/Makefile.am
+--- spew-1.0.8.orig/src/Makefile.am 2014-11-19 08:15:31.311273030 -0500
++++ spew-1.0.8/src/Makefile.am 2014-11-19 08:16:57.034276932 -0500
+@@ -24,7 +24,7 @@
+ libtui_a_SOURCES = \
+ Tui.cpp Tui.h
+
+-LDADD = libcommon.a libtui.a
++LDADD = libcommon.a libtui.a $(NCURSES_LIBS)
+
+ bin_PROGRAMS = spew
+ spew_SOURCES = spew.cpp \
+@@ -37,4 +37,5 @@
+ SpewTuiStatisticsWindow.cpp SpewTuiStatisticsWindow.h \
+ SpewTuiStatusWindow.cpp SpewTuiStatusWindow.h
+
++spew_CFLAGS = $(NCURSES_CFLAGS)
+ spew_LDFLAGS = $(STATIC_LINK)
diff --git a/app-benchmarks/spew/spew-1.0.8-r1.ebuild b/app-benchmarks/spew/spew-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..9aa684f8409c
--- /dev/null
+++ b/app-benchmarks/spew/spew-1.0.8-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8-r1.ebuild,v 1.1 2014/11/19 13:22:12 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Measures I/O performance and/or generates I/O load"
+HOMEPAGE="http://spew.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/spew/1.0.8/spew-1.0.8.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="static"
+
+DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
+ !static? ( sys-libs/ncurses dev-libs/popt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-automake-1.13.patch
+ epatch "${FILESDIR}"/remove-symlinks-makefile.patch
+ epatch "${FILESDIR}"/fix-ncurses-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dosym ${PN} /usr/bin/gorge
+ dosym ${PN} /usr/bin/regorge
+ dosym ${PN}.1.bz2 /usr/share/man/man1/gorge.1.bz2
+ dosym ${PN}.1.bz2 /usr/share/man/man1/reorge.1.bz2
+}