summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2012-11-04 22:46:26 +0000
committerSven Wegener <swegener@gentoo.org>2012-11-04 22:46:26 +0000
commitf8a022ee4c763800bf9b72f2bfa98fe12049bece (patch)
tree6a466c306a3155afe122d77afcb7bf0667962e6c /app-benchmarks
parentRequire old version of otr for API compability, bug #438956. (diff)
downloadgentoo-2-f8a022ee4c763800bf9b72f2bfa98fe12049bece.tar.gz
gentoo-2-f8a022ee4c763800bf9b72f2bfa98fe12049bece.tar.bz2
gentoo-2-f8a022ee4c763800bf9b72f2bfa98fe12049bece.zip
Rename aligned_alloc to tio_aligned_alloc, bug #429912.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/tiobench/ChangeLog8
-rw-r--r--app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch21
-rw-r--r--app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild5
3 files changed, 30 insertions, 4 deletions
diff --git a/app-benchmarks/tiobench/ChangeLog b/app-benchmarks/tiobench/ChangeLog
index edd6510dae24..cfdcee292a1e 100644
--- a/app-benchmarks/tiobench/ChangeLog
+++ b/app-benchmarks/tiobench/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-benchmarks/tiobench
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/ChangeLog,v 1.16 2009/09/13 22:22:21 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/ChangeLog,v 1.17 2012/11/04 22:46:26 swegener Exp $
+
+ 04 Nov 2012; Sven Wegener <swegener@gentoo.org> tiobench-0.3.3-r2.ebuild,
+ +files/0.3.3-glibc-2.16.patch:
+ Rename aligned_alloc to tio_aligned_alloc, bug #429912.
13 Sep 2009; Patrick Lauer <patrick@gentoo.org> tiobench-0.3.3-r2.ebuild:
Removing virtual/libc deps
diff --git a/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch b/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch
new file mode 100644
index 000000000000..fed845a51d62
--- /dev/null
+++ b/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch
@@ -0,0 +1,21 @@
+diff -Nur tiobench-0.3.3.orig/tiotest.c tiobench-0.3.3/tiotest.c
+--- tiobench-0.3.3.orig/tiotest.c 2001-03-05 02:34:00.000000000 +0000
++++ tiobench-0.3.3/tiotest.c 2012-11-04 22:44:41.695677071 +0000
+@@ -31,7 +31,7 @@
+ */
+ ArgumentOptions args;
+
+-static void * aligned_alloc(ssize_t size)
++static void * tio_aligned_alloc(ssize_t size)
+ {
+ caddr_t a;
+ a = mmap((caddr_t )0, size,
+@@ -281,7 +281,7 @@
+ pthread_attr_setscope(&(d->threads[i].thread_attr),
+ PTHREAD_SCOPE_SYSTEM);
+
+- d->threads[i].buffer = aligned_alloc( d->threads[i].blockSize );
++ d->threads[i].buffer = tio_aligned_alloc( d->threads[i].blockSize );
+ if( d->threads[i].buffer == NULL )
+ {
+ perror("Error allocating memory");
diff --git a/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild b/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild
index 605b4be6537a..5a11bed11a2d 100644
--- a/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild
+++ b/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild,v 1.5 2009/09/13 22:22:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild,v 1.6 2012/11/04 22:46:26 swegener Exp $
inherit eutils toolchain-funcs
@@ -22,6 +22,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-column-description-fix.patch
epatch "${FILESDIR}"/${PV}-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PV}-glibc-2.16.patch
sed -i \
-e 's:/usr/local/bin:/usr/sbin:' tiobench.pl \