summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-21 00:09:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-21 00:09:07 +0000
commit4a1918b99be1502f2f274481652d5788559c1d4a (patch)
tree7a9093b95b5b2594002d55a1f694d628e0ca6527 /app-cdr/k3b/k3b-0.12.15.ebuild
parentVersion bump, thanks to Alon Bar-Lev in bug #137396. (diff)
downloadgentoo-2-4a1918b99be1502f2f274481652d5788559c1d4a.tar.gz
gentoo-2-4a1918b99be1502f2f274481652d5788559c1d4a.tar.bz2
gentoo-2-4a1918b99be1502f2f274481652d5788559c1d4a.zip
Fix i18n packages to use the new $KDE_S variable, thanks to miste78 for reporting in bug #135692.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'app-cdr/k3b/k3b-0.12.15.ebuild')
-rw-r--r--app-cdr/k3b/k3b-0.12.15.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/app-cdr/k3b/k3b-0.12.15.ebuild b/app-cdr/k3b/k3b-0.12.15.ebuild
index 1b56d1c8c995..66df20102fc5 100644
--- a/app-cdr/k3b/k3b-0.12.15.ebuild
+++ b/app-cdr/k3b/k3b-0.12.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.15.ebuild,v 1.2 2006/05/31 16:05:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.15.ebuild,v 1.3 2006/06/21 00:09:07 flameeyes Exp $
inherit kde eutils
@@ -97,26 +97,20 @@ src_compile() {
kde_src_compile
# Build process of K3b-i18n
- local _S=${S}
if [ -d "${WORKDIR}/${I18N}" ]; then
- S="${WORKDIR}/${I18N}"
- cd "${S}"
+ KDE_S="${WORKDIR}/${I18N}" \
kde_src_compile
fi
- S=${_S}
}
src_install() {
kde_src_install
dodoc FAQ KNOWNBUGS PERMISSIONS
- local _S=${S}
if [ -d "${WORKDIR}/${I18N}" ]; then
- S="${WORKDIR}/${I18N}"
- cd "${S}"
+ KDE_S="${WORKDIR}/${I18N}" \
kde_src_install
fi
- S=${_S}
# Move menu entry
if use kde; then