summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 21:05:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 21:05:57 +0000
commitd27c4ef69dcea74eec5ca2e625a472397f3603d2 (patch)
treeb3ef7fcad45701d22c7086a4b5e115c959ce08ba /app-cdr/k3b
parentfix for arm/linuxthreads/gcc-4 (diff)
downloadgentoo-2-d27c4ef69dcea74eec5ca2e625a472397f3603d2.tar.gz
gentoo-2-d27c4ef69dcea74eec5ca2e625a472397f3603d2.tar.bz2
gentoo-2-d27c4ef69dcea74eec5ca2e625a472397f3603d2.zip
Add patch from Josh Coalson to be able to build with flac 1.1.3 (and an extra one to build with flac 1.1.3-beta2).
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'app-cdr/k3b')
-rw-r--r--app-cdr/k3b/ChangeLog9
-rw-r--r--app-cdr/k3b/files/k3b-0.12.17+flac-1.1.3.patch165
-rw-r--r--app-cdr/k3b/files/k3b-0.12.17-flac-beta.patch19
-rw-r--r--app-cdr/k3b/files/k3b-1.0_pre2+flac-1.1.3.patch165
-rw-r--r--app-cdr/k3b/files/k3b-1.0_pre2-flac-beta.patch17
-rw-r--r--app-cdr/k3b/k3b-0.12.17.ebuild12
-rw-r--r--app-cdr/k3b/k3b-1.0_pre2.ebuild9
7 files changed, 389 insertions, 7 deletions
diff --git a/app-cdr/k3b/ChangeLog b/app-cdr/k3b/ChangeLog
index 1b6e5c561c0e..e912c6de8352 100644
--- a/app-cdr/k3b/ChangeLog
+++ b/app-cdr/k3b/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-cdr/k3b
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.164 2006/10/19 17:41:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.165 2006/10/21 21:05:57 flameeyes Exp $
+
+ 21 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/k3b-0.12.17+flac-1.1.3.patch, +files/k3b-0.12.17-flac-beta.patch,
+ +files/k3b-1.0_pre2+flac-1.1.3.patch, +files/k3b-1.0_pre2-flac-beta.patch,
+ k3b-0.12.17.ebuild, k3b-1.0_pre2.ebuild:
+ Add patch from Josh Coalson to be able to build with flac 1.1.3 (and an
+ extra one to build with flac 1.1.3-beta2).
19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> k3b-0.12.14.ebuild,
k3b-0.12.15.ebuild, k3b-0.12.16.ebuild, k3b-0.12.17.ebuild,
diff --git a/app-cdr/k3b/files/k3b-0.12.17+flac-1.1.3.patch b/app-cdr/k3b/files/k3b-0.12.17+flac-1.1.3.patch
new file mode 100644
index 000000000000..fdfa0563a075
--- /dev/null
+++ b/app-cdr/k3b/files/k3b-0.12.17+flac-1.1.3.patch
@@ -0,0 +1,165 @@
+--- k3b-0.12.17/configure.in.in 2006-08-23 00:32:30.000000000 -0700
++++ k3b-0.12.17-b2/configure.in.in 2006-10-17 19:23:48.000000000 -0700
+@@ -248,7 +248,7 @@
+ have_flac=no
+ if test "$ac_cv_use_flac" = "yes"; then
+ KDE_CHECK_HEADERS(FLAC++/decoder.h, [
+- AC_CHECK_LIB(FLAC,FLAC__seekable_stream_decoder_process_single,
++ AC_CHECK_LIB(FLAC,FLAC__stream_decoder_process_single,
+ have_flac=yes,[],$all_libraries)])
+
+ # Hack to get the flac version since I was not able to handle the code from
+--- k3b-0.12.17/plugins/decoder/flac/k3bflacdecoder.cpp 2006-08-23 00:31:46.000000000 -0700
++++ k3b-0.12.17-b2/plugins/decoder/flac/k3bflacdecoder.cpp 2006-10-18 14:32:24.000000000 -0700
+@@ -36,11 +36,21 @@
+ #include <taglib/flacfile.h>
+ #endif
+
++#if !defined FLACPP_API_VERSION_CURRENT || FLACPP_API_VERSION_CURRENT < 6
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ K_EXPORT_COMPONENT_FACTORY( libk3bflacdecoder, K3bPluginFactory<K3bFLACDecoderFactory>( "libk3bflacdecoder" ) )
+
+
+ class K3bFLACDecoder::Private
++#ifdef LEGACY_FLAC
+ : public FLAC::Decoder::SeekableStream
++#else
++ : public FLAC::Decoder::Stream
++#endif
+ {
+ public:
+ void open(QFile* f) {
+@@ -64,7 +74,11 @@
+ }
+
+ Private(QFile* f)
++#ifdef LEGACY_FLAC
+ : FLAC::Decoder::SeekableStream(),
++#else
++ : FLAC::Decoder::Stream(),
++#endif
+ comments(0) {
+ internalBuffer = new QBuffer();
+ internalBuffer->open(IO_ReadWrite);
+@@ -93,10 +107,17 @@
+ FLAC__uint64 samples;
+
+ protected:
++#ifdef LEGACY_FLAC
+ virtual FLAC__SeekableStreamDecoderReadStatus read_callback(FLAC__byte buffer[], unsigned *bytes);
+ virtual FLAC__SeekableStreamDecoderSeekStatus seek_callback(FLAC__uint64 absolute_byte_offset);
+ virtual FLAC__SeekableStreamDecoderTellStatus tell_callback(FLAC__uint64 *absolute_byte_offset);
+ virtual FLAC__SeekableStreamDecoderLengthStatus length_callback(FLAC__uint64 *stream_length);
++#else
++ virtual FLAC__StreamDecoderReadStatus read_callback(FLAC__byte buffer[], size_t *bytes);
++ virtual FLAC__StreamDecoderSeekStatus seek_callback(FLAC__uint64 absolute_byte_offset);
++ virtual FLAC__StreamDecoderTellStatus tell_callback(FLAC__uint64 *absolute_byte_offset);
++ virtual FLAC__StreamDecoderLengthStatus length_callback(FLAC__uint64 *stream_length);
++#endif
+ virtual bool eof_callback();
+ virtual void error_callback(FLAC__StreamDecoderErrorStatus){};
+ virtual void metadata_callback(const ::FLAC__StreamMetadata *metadata);
+@@ -112,6 +133,7 @@
+ return file->atEnd();
+ }
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderReadStatus K3bFLACDecoder::Private::read_callback(FLAC__byte buffer[], unsigned *bytes) {
+ long retval = file->readBlock((char *)buffer, (*bytes));
+ if(-1 == retval) {
+@@ -121,7 +143,19 @@
+ return FLAC__SEEKABLE_STREAM_DECODER_READ_STATUS_OK;
+ }
+ }
++#else
++FLAC__StreamDecoderReadStatus K3bFLACDecoder::Private::read_callback(FLAC__byte buffer[], size_t *bytes) {
++ long retval = file->readBlock((char *)buffer, (*bytes));
++ if(-1 == retval) {
++ return FLAC__STREAM_DECODER_READ_STATUS_ABORT;
++ } else {
++ (*bytes) = retval;
++ return FLAC__STREAM_DECODER_READ_STATUS_CONTINUE;
++ }
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderSeekStatus
+ K3bFLACDecoder::Private::seek_callback(FLAC__uint64 absolute_byte_offset) {
+ if(file->at(absolute_byte_offset) == FALSE)
+@@ -129,18 +163,43 @@
+ else
+ return FLAC__SEEKABLE_STREAM_DECODER_SEEK_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderSeekStatus
++K3bFLACDecoder::Private::seek_callback(FLAC__uint64 absolute_byte_offset) {
++ if(file->at(absolute_byte_offset) == FALSE)
++ return FLAC__STREAM_DECODER_SEEK_STATUS_ERROR;
++ else
++ return FLAC__STREAM_DECODER_SEEK_STATUS_OK;
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderTellStatus
+ K3bFLACDecoder::Private::tell_callback(FLAC__uint64 *absolute_byte_offset) {
+ (*absolute_byte_offset) = file->at();
+ return FLAC__SEEKABLE_STREAM_DECODER_TELL_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderTellStatus
++K3bFLACDecoder::Private::tell_callback(FLAC__uint64 *absolute_byte_offset) {
++ (*absolute_byte_offset) = file->at();
++ return FLAC__STREAM_DECODER_TELL_STATUS_OK;
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderLengthStatus
+ K3bFLACDecoder::Private::length_callback(FLAC__uint64 *stream_length) {
+ (*stream_length) = file->size();
+ return FLAC__SEEKABLE_STREAM_DECODER_LENGTH_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderLengthStatus
++K3bFLACDecoder::Private::length_callback(FLAC__uint64 *stream_length) {
++ (*stream_length) = file->size();
++ return FLAC__STREAM_DECODER_LENGTH_STATUS_OK;
++}
++#endif
+
+
+ void K3bFLACDecoder::Private::metadata_callback(const FLAC__StreamMetadata *metadata) {
+@@ -260,6 +319,7 @@
+ int bytesCopied;
+ int bytesAvailable;
+
++#ifdef LEGACY_FLAC
+ if(d->internalBuffer->size() == 0) {
+ // want more data
+ switch(d->get_state()) {
+@@ -274,6 +334,19 @@
+ return -1;
+ }
+ }
++#else
++ if(d->internalBuffer->size() == 0) {
++ // want more data
++ if(d->get_state() == FLAC__STREAM_DECODER_END_OF_STREAM)
++ d->finish();
++ else if(d->get_state() < FLAC__STREAM_DECODER_END_OF_STREAM) {
++ if(! d->process_single())
++ return -1;
++ }
++ else
++ return -1;
++ }
++#endif
+
+ bytesAvailable = d->internalBuffer->size() - d->internalBuffer->at();
+ bytesToCopy = QMIN(maxLen, bytesAvailable);
diff --git a/app-cdr/k3b/files/k3b-0.12.17-flac-beta.patch b/app-cdr/k3b/files/k3b-0.12.17-flac-beta.patch
new file mode 100644
index 000000000000..812d405b06ab
--- /dev/null
+++ b/app-cdr/k3b/files/k3b-0.12.17-flac-beta.patch
@@ -0,0 +1,19 @@
+Index: k3b-0.12.17/configure.in.in
+===================================================================
+--- k3b-0.12.17.orig/configure.in.in
++++ k3b-0.12.17/configure.in.in
+@@ -22,11 +22,11 @@ if test "$ac_cv_use_flac" = "yes"; then
+ # Hack to get the flac version since I was not able to handle the code from
+ # the flac guys. This is a strange usage of tr but I don't know too much about
+ # shell scripting and this works, so...
+ # BUT: this does not work if we want to use another flac version than the one installed
+ # where the flac binary is found!
+- K3B_FLAC_VERSION_MAJOR=`flac --version|tr -d "flac "|cut -d "." -f 1`
+- K3B_FLAC_VERSION_MINOR=`flac --version|tr -d "flac "|cut -d "." -f 2`
+- K3B_FLAC_VERSION_PATCHLEVEL=`flac --version|tr -d "flac "|cut -d "." -f 3`
++ K3B_FLAC_VERSION_MAJOR=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 1`
++ K3B_FLAC_VERSION_MINOR=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 2`
++ K3B_FLAC_VERSION_PATCHLEVEL=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 3`
+ if test \( "$K3B_FLAC_VERSION_MAJOR" -gt 1 -o \
+ \( "$K3B_FLAC_VERSION_MAJOR" -eq 1 -a \( "$K3B_FLAC_VERSION_MINOR" -gt 1 -o \
+ \( "$K3B_FLAC_VERSION_MINOR" -eq 1 -a "$K3B_FLAC_VERSION_PATCHLEVEL" -gt 1 \) \
diff --git a/app-cdr/k3b/files/k3b-1.0_pre2+flac-1.1.3.patch b/app-cdr/k3b/files/k3b-1.0_pre2+flac-1.1.3.patch
new file mode 100644
index 000000000000..35e45d8e9006
--- /dev/null
+++ b/app-cdr/k3b/files/k3b-1.0_pre2+flac-1.1.3.patch
@@ -0,0 +1,165 @@
+--- k3b-1.0pre2/plugins/decoder/flac/configure.in.in 2006-08-23 00:32:30.000000000 -0700
++++ k3b-1.0pre2-b2/plugins/decoder/flac/configure.in.in 2006-10-17 19:23:48.000000000 -0700
+@@ -248,7 +248,7 @@
+ have_flac=no
+ if test "$ac_cv_use_flac" = "yes"; then
+ KDE_CHECK_HEADERS(FLAC++/decoder.h, [
+- AC_CHECK_LIB(FLAC,FLAC__seekable_stream_decoder_process_single,
++ AC_CHECK_LIB(FLAC,FLAC__stream_decoder_process_single,
+ have_flac=yes,[],$all_libraries)])
+
+ # Hack to get the flac version since I was not able to handle the code from
+--- k3b-1.0pre2/plugins/decoder/flac/k3bflacdecoder.cpp 2006-08-23 00:31:46.000000000 -0700
++++ k3b-1.0pre2-b2/plugins/decoder/flac/k3bflacdecoder.cpp 2006-10-18 14:32:24.000000000 -0700
+@@ -36,11 +36,21 @@
+ #include <taglib/flacfile.h>
+ #endif
+
++#if !defined FLACPP_API_VERSION_CURRENT || FLACPP_API_VERSION_CURRENT < 6
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ K_EXPORT_COMPONENT_FACTORY( libk3bflacdecoder, K3bPluginFactory<K3bFLACDecoderFactory>( "libk3bflacdecoder" ) )
+
+
+ class K3bFLACDecoder::Private
++#ifdef LEGACY_FLAC
+ : public FLAC::Decoder::SeekableStream
++#else
++ : public FLAC::Decoder::Stream
++#endif
+ {
+ public:
+ void open(QFile* f) {
+@@ -64,7 +74,11 @@
+ }
+
+ Private(QFile* f)
++#ifdef LEGACY_FLAC
+ : FLAC::Decoder::SeekableStream(),
++#else
++ : FLAC::Decoder::Stream(),
++#endif
+ comments(0) {
+ internalBuffer = new QBuffer();
+ internalBuffer->open(IO_ReadWrite);
+@@ -93,10 +107,17 @@
+ FLAC__uint64 samples;
+
+ protected:
++#ifdef LEGACY_FLAC
+ virtual FLAC__SeekableStreamDecoderReadStatus read_callback(FLAC__byte buffer[], unsigned *bytes);
+ virtual FLAC__SeekableStreamDecoderSeekStatus seek_callback(FLAC__uint64 absolute_byte_offset);
+ virtual FLAC__SeekableStreamDecoderTellStatus tell_callback(FLAC__uint64 *absolute_byte_offset);
+ virtual FLAC__SeekableStreamDecoderLengthStatus length_callback(FLAC__uint64 *stream_length);
++#else
++ virtual FLAC__StreamDecoderReadStatus read_callback(FLAC__byte buffer[], size_t *bytes);
++ virtual FLAC__StreamDecoderSeekStatus seek_callback(FLAC__uint64 absolute_byte_offset);
++ virtual FLAC__StreamDecoderTellStatus tell_callback(FLAC__uint64 *absolute_byte_offset);
++ virtual FLAC__StreamDecoderLengthStatus length_callback(FLAC__uint64 *stream_length);
++#endif
+ virtual bool eof_callback();
+ virtual void error_callback(FLAC__StreamDecoderErrorStatus){};
+ virtual void metadata_callback(const ::FLAC__StreamMetadata *metadata);
+@@ -112,6 +133,7 @@
+ return file->atEnd();
+ }
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderReadStatus K3bFLACDecoder::Private::read_callback(FLAC__byte buffer[], unsigned *bytes) {
+ long retval = file->readBlock((char *)buffer, (*bytes));
+ if(-1 == retval) {
+@@ -121,7 +143,19 @@
+ return FLAC__SEEKABLE_STREAM_DECODER_READ_STATUS_OK;
+ }
+ }
++#else
++FLAC__StreamDecoderReadStatus K3bFLACDecoder::Private::read_callback(FLAC__byte buffer[], size_t *bytes) {
++ long retval = file->readBlock((char *)buffer, (*bytes));
++ if(-1 == retval) {
++ return FLAC__STREAM_DECODER_READ_STATUS_ABORT;
++ } else {
++ (*bytes) = retval;
++ return FLAC__STREAM_DECODER_READ_STATUS_CONTINUE;
++ }
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderSeekStatus
+ K3bFLACDecoder::Private::seek_callback(FLAC__uint64 absolute_byte_offset) {
+ if(file->at(absolute_byte_offset) == FALSE)
+@@ -129,18 +163,43 @@
+ else
+ return FLAC__SEEKABLE_STREAM_DECODER_SEEK_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderSeekStatus
++K3bFLACDecoder::Private::seek_callback(FLAC__uint64 absolute_byte_offset) {
++ if(file->at(absolute_byte_offset) == FALSE)
++ return FLAC__STREAM_DECODER_SEEK_STATUS_ERROR;
++ else
++ return FLAC__STREAM_DECODER_SEEK_STATUS_OK;
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderTellStatus
+ K3bFLACDecoder::Private::tell_callback(FLAC__uint64 *absolute_byte_offset) {
+ (*absolute_byte_offset) = file->at();
+ return FLAC__SEEKABLE_STREAM_DECODER_TELL_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderTellStatus
++K3bFLACDecoder::Private::tell_callback(FLAC__uint64 *absolute_byte_offset) {
++ (*absolute_byte_offset) = file->at();
++ return FLAC__STREAM_DECODER_TELL_STATUS_OK;
++}
++#endif
+
++#ifdef LEGACY_FLAC
+ FLAC__SeekableStreamDecoderLengthStatus
+ K3bFLACDecoder::Private::length_callback(FLAC__uint64 *stream_length) {
+ (*stream_length) = file->size();
+ return FLAC__SEEKABLE_STREAM_DECODER_LENGTH_STATUS_OK;
+ }
++#else
++FLAC__StreamDecoderLengthStatus
++K3bFLACDecoder::Private::length_callback(FLAC__uint64 *stream_length) {
++ (*stream_length) = file->size();
++ return FLAC__STREAM_DECODER_LENGTH_STATUS_OK;
++}
++#endif
+
+
+ void K3bFLACDecoder::Private::metadata_callback(const FLAC__StreamMetadata *metadata) {
+@@ -260,6 +319,7 @@
+ int bytesCopied;
+ int bytesAvailable;
+
++#ifdef LEGACY_FLAC
+ if(d->internalBuffer->size() == 0) {
+ // want more data
+ switch(d->get_state()) {
+@@ -274,6 +334,19 @@
+ return -1;
+ }
+ }
++#else
++ if(d->internalBuffer->size() == 0) {
++ // want more data
++ if(d->get_state() == FLAC__STREAM_DECODER_END_OF_STREAM)
++ d->finish();
++ else if(d->get_state() < FLAC__STREAM_DECODER_END_OF_STREAM) {
++ if(! d->process_single())
++ return -1;
++ }
++ else
++ return -1;
++ }
++#endif
+
+ bytesAvailable = d->internalBuffer->size() - d->internalBuffer->at();
+ bytesToCopy = QMIN(maxLen, bytesAvailable);
diff --git a/app-cdr/k3b/files/k3b-1.0_pre2-flac-beta.patch b/app-cdr/k3b/files/k3b-1.0_pre2-flac-beta.patch
new file mode 100644
index 000000000000..ec34de688854
--- /dev/null
+++ b/app-cdr/k3b/files/k3b-1.0_pre2-flac-beta.patch
@@ -0,0 +1,17 @@
+Index: k3b-1.0pre2/plugins/decoder/flac/configure.in.in
+===================================================================
+--- k3b-1.0pre2.orig/plugins/decoder/flac/configure.in.in
++++ k3b-1.0pre2/plugins/decoder/flac/configure.in.in
+@@ -22,9 +22,9 @@ if test "$ac_cv_use_flac" = "yes"; then
+ AC_CHECK_PROG( have_flac_bin, flac, 1, 0 )
+
+ if test "$have_flac_bin" = "1"; then
+- K3B_FLAC_VERSION_MAJOR=`flac --version|tr -d "flac "|cut -d "." -f 1`
+- K3B_FLAC_VERSION_MINOR=`flac --version|tr -d "flac "|cut -d "." -f 2`
+- K3B_FLAC_VERSION_PATCHLEVEL=`flac --version|tr -d "flac "|cut -d "." -f 3`
++ K3B_FLAC_VERSION_MAJOR=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 1`
++ K3B_FLAC_VERSION_MINOR=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 2`
++ K3B_FLAC_VERSION_PATCHLEVEL=`flac --version|tr -d "flac "|cut -d '-' -f 1|cut -d "." -f 3`
+ if test \( "$K3B_FLAC_VERSION_MAJOR" -gt 1 -o \
+ \( "$K3B_FLAC_VERSION_MAJOR" -eq 1 -a \( "$K3B_FLAC_VERSION_MINOR" -gt 1 -o \
+ \( "$K3B_FLAC_VERSION_MINOR" -eq 1 -a "$K3B_FLAC_VERSION_PATCHLEVEL" -gt 1 \) \
diff --git a/app-cdr/k3b/k3b-0.12.17.ebuild b/app-cdr/k3b/k3b-0.12.17.ebuild
index d43d7a980997..7007a3a5482c 100644
--- a/app-cdr/k3b/k3b-0.12.17.ebuild
+++ b/app-cdr/k3b/k3b-0.12.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.4 2006/10/19 17:41:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.5 2006/10/21 21:05:57 flameeyes Exp $
inherit kde eutils
@@ -21,7 +21,7 @@ DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
>=media-sound/cdparanoia-3.9.8
sndfile? ( media-libs/libsndfile )
ffmpeg? ( media-video/ffmpeg )
- flac? ( ~media-libs/flac-1.1.2 )
+ flac? ( media-libs/flac )
mp3? ( media-libs/libmad )
musepack? ( media-libs/libmpcdec )
vorbis? ( media-libs/libvorbis )
@@ -76,11 +76,15 @@ src_unpack() {
done
rm -f configure
fi
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}+flac-1.1.3.patch"
+ epatch "${FILESDIR}/${P}-flac-beta.patch"
+ rm -f "${S}/configure"
}
src_compile() {
- local myconf="--enable-libsuffix= \
- --with-external-libsamplerate \
+ local myconf="--with-external-libsamplerate \
--without-resmgr \
$(use_with kde k3bsetup) \
$(use_with hal) \
diff --git a/app-cdr/k3b/k3b-1.0_pre2.ebuild b/app-cdr/k3b/k3b-1.0_pre2.ebuild
index 4b845a49071f..a77a4fcae2e9 100644
--- a/app-cdr/k3b/k3b-1.0_pre2.ebuild
+++ b/app-cdr/k3b/k3b-1.0_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0_pre2.ebuild,v 1.3 2006/10/19 17:41:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0_pre2.ebuild,v 1.4 2006/10/21 21:05:57 flameeyes Exp $
inherit kde eutils
@@ -24,7 +24,7 @@ DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
>=media-sound/cdparanoia-3.9.8
sndfile? ( media-libs/libsndfile )
ffmpeg? ( media-video/ffmpeg )
- flac? ( ~media-libs/flac-1.1.2 )
+ flac? ( media-libs/flac )
mp3? ( media-libs/libmad )
musepack? ( media-libs/libmpcdec )
vorbis? ( media-libs/libvorbis )
@@ -87,6 +87,11 @@ src_unpack() {
done
rm -f configure
fi
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}+flac-1.1.3.patch"
+ epatch "${FILESDIR}/${P}-flac-beta.patch"
+ rm -f "${S}/configure"
}
src_compile() {