summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2010-01-25 20:08:34 +0000
committerCarsten Lohrke <carlo@gentoo.org>2010-01-25 20:08:34 +0000
commit67941db41bb4e524b25aa93629af1f53f9cf5766 (patch)
treea929196ac8b2811f2294bdb8a45e08a636e9cc8f /app-cdr/qpxtool/files
parentRemove old versions. (diff)
downloadgentoo-2-67941db41bb4e524b25aa93629af1f53f9cf5766.tar.gz
gentoo-2-67941db41bb4e524b25aa93629af1f53f9cf5766.tar.bz2
gentoo-2-67941db41bb4e524b25aa93629af1f53f9cf5766.zip
Fix a parallel build issue, bug #298662, a parallel install issue and build with --as-needed.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-cdr/qpxtool/files')
-rw-r--r--app-cdr/qpxtool/files/qpxtool-0.7.0-ldlibs.patch32
-rw-r--r--app-cdr/qpxtool/files/qpxtool-0.7.0-locale-install-race-patch33
2 files changed, 65 insertions, 0 deletions
diff --git a/app-cdr/qpxtool/files/qpxtool-0.7.0-ldlibs.patch b/app-cdr/qpxtool/files/qpxtool-0.7.0-ldlibs.patch
new file mode 100644
index 000000000000..3f7b35b43879
--- /dev/null
+++ b/app-cdr/qpxtool/files/qpxtool-0.7.0-ldlibs.patch
@@ -0,0 +1,32 @@
+--- qpxtool-0.7.0.old/console/f1tattoo/Makefile 2010-01-09 12:05:18.000000000 +0100
++++ qpxtool-0.7.0/console/f1tattoo/Makefile 2010-01-09 12:21:39.000000000 +0100
+@@ -5,7 +5,7 @@
+
+ CXXFLAGS += -I. -I../../lib/include $(LPNG_INC)
+ CFLAGS += -I. -I../../lib/include $(LPNG_INC)
+-LDLIBS += -lqpxtransport -lqpxyamaha $(LPNG_LIB) -L../../lib/lib
++LDLIBS += -lqpxtransport -lqpxyamaha -L../../lib/lib $(LPNG_LIB)
+
+ $(BIN): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+--- qpxtool-0.7.0/console/qscan/Makefile.orig 2010-01-23 19:37:37.201487022 +0100
++++ qpxtool-0.7.0/console/qscan/Makefile 2010-01-23 19:44:07.915487435 +0100
+@@ -5,7 +5,7 @@
+
+ CXXFLAGS += -I. -I../../lib/include
+ CFLAGS += -I. -I../../lib/include
+-LDLIBS += -lqpxtransport -lqpxscan -lqpxplextor -L../../lib/lib $(LIBS_DL)
++LDLIBS += -lqpxtransport -lqpxscan -lqpxplextor -L../../lib/lib
+
+ $(BIN): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+--- qpxtool-0.7.0/lib/qpxscan/Makefile.orig 2010-01-25 18:27:39.373641192 +0100
++++ qpxtool-0.7.0/lib/qpxscan/Makefile 2010-01-25 18:18:03.420641552 +0100
+@@ -12,6 +12,6 @@
+ VER_MINOR = 7
+ VER_MICRO = 0
+
+-LDLIBS += -lqpxtransport -lqpxplextor -L../lib $(LIBS_INET)
++LDLIBS += $(LIBS_DL) -lqpxtransport -lqpxplextor -L../lib $(LIBS_INET)
+
+ include ../Makefile.lib
diff --git a/app-cdr/qpxtool/files/qpxtool-0.7.0-locale-install-race-patch b/app-cdr/qpxtool/files/qpxtool-0.7.0-locale-install-race-patch
new file mode 100644
index 000000000000..9192a90a7892
--- /dev/null
+++ b/app-cdr/qpxtool/files/qpxtool-0.7.0-locale-install-race-patch
@@ -0,0 +1,33 @@
+--- qpxtool-0.7.0/gui/updateqm.pri.orig 2010-01-25 19:44:45.061640334 +0100
++++ qpxtool-0.7.0/gui/updateqm.pri 2010-01-25 19:40:03.711640850 +0100
+@@ -0,0 +1,19 @@
++isEmpty(QMAKE_LRELEASE) {
++
++ win32:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]\lrelease.exe
++
++ else:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease
++
++}
++
++updateqm.input = TRANSLATIONS
++
++updateqm.output = ${QMAKE_FILE_PATH}/${QMAKE_FILE_BASE}.qm
++
++updateqm.commands = $$QMAKE_LRELEASE ${QMAKE_FILE_IN} -qm ${QMAKE_FILE_PATH}/${QMAKE_FILE_BASE}.qm
++
++updateqm.CONFIG += no_link
++
++QMAKE_EXTRA_COMPILERS += updateqm
++
++PRE_TARGETDEPS += compiler_updateqm_make_all
+--- qpxtool-0.7.0/gui/qpxtool.pro.orig 2010-01-25 19:46:45.011641756 +0100
++++ qpxtool-0.7.0/gui/qpxtool.pro 2010-01-25 19:47:08.397640627 +0100
+@@ -2,6 +2,8 @@
+ # Automatically generated by qmake (2.01a) ?? ???. 24 12:26:02 2009
+ ######################################################################
+
++include( updateqm.pri )
++
+ MOC_DIR=moc
+ OBJECTS_DIR=obj
+ QT+=network