summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-11-11 04:51:57 +0000
committerLars Weiler <pylon@gentoo.org>2006-11-11 04:51:57 +0000
commitcc0e5c03079586765b18e9b4c70430a8be8968e8 (patch)
tree92587fcf566ea863d5a3abdb08b873b38b107af9 /app-cdr/xcdroast
parentLast try, signed manifest (diff)
downloadgentoo-2-cc0e5c03079586765b18e9b4c70430a8be8968e8.tar.gz
gentoo-2-cc0e5c03079586765b18e9b4c70430a8be8968e8.tar.bz2
gentoo-2-cc0e5c03079586765b18e9b4c70430a8be8968e8.zip
Added some patches (from upstream and from Debian) so that xcdroast works
with current cdrkit and cdrtools. (Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/ChangeLog10
-rw-r--r--app-cdr/xcdroast/files/cdrecord2wodim.patch71
-rw-r--r--app-cdr/xcdroast/files/cdrecord_versions.patch15
-rw-r--r--app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha15-r46
-rw-r--r--app-cdr/xcdroast/files/modern_cdrtools.patch21
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild4
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild68
7 files changed, 192 insertions, 3 deletions
diff --git a/app-cdr/xcdroast/ChangeLog b/app-cdr/xcdroast/ChangeLog
index e636cb4e90c2..c8d355b91131 100644
--- a/app-cdr/xcdroast/ChangeLog
+++ b/app-cdr/xcdroast/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-cdr/xcdroast
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.48 2006/10/28 14:56:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/ChangeLog,v 1.49 2006/11/11 04:51:57 pylon Exp $
+
+*xcdroast-0.98_alpha15-r4 (11 Nov 2006)
+
+ 11 Nov 2006; Lars Weiler <pylon@gentoo.org> +files/cdrecord2wodim.patch,
+ +files/cdrecord_versions.patch, +files/modern_cdrtools.patch,
+ xcdroast-0.98_alpha15-r3.ebuild, +xcdroast-0.98_alpha15-r4.ebuild:
+ Added some patches (from upstream and from Debian) so that xcdroast works
+ with current cdrkit and cdrtools.
28 Oct 2006; Lars Weiler <pylon@gentoo.org>
xcdroast-0.98_alpha15-r3.ebuild:
diff --git a/app-cdr/xcdroast/files/cdrecord2wodim.patch b/app-cdr/xcdroast/files/cdrecord2wodim.patch
new file mode 100644
index 000000000000..8a9c486e7253
--- /dev/null
+++ b/app-cdr/xcdroast/files/cdrecord2wodim.patch
@@ -0,0 +1,71 @@
+diff -urNad xcdroast-0.98+0alpha15~/src/io.c xcdroast-0.98+0alpha15/src/io.c
+--- xcdroast-0.98+0alpha15~/src/io.c 2006-09-09 16:24:37.000000000 +0200
++++ xcdroast-0.98+0alpha15/src/io.c 2006-09-09 16:26:32.000000000 +0200
+@@ -1273,7 +1273,7 @@
+ drvcount = 0;
+
+ get_wrap_path_cdrecord(line);
+- strcat(line," driver=help 2>&1");
++ strcat(line," driver=help 2>&1 | sed -n '/Driver types:/,//p'");
+
+ dodebug(1, "calling: %s\n", line);
+ if ((fpin = popen(line,"r")) == NULL) {
+@@ -5856,7 +5856,7 @@
+ drvcount = 0;
+
+ get_wrap_path_cdrecord(line);
+- strcat(line," blank=help 2>&1");
++ strcat(line," blank=help 2>&1 | sed -n '/Blanking options:/,//p'");
+
+ dodebug(1, "calling: %s\n", line);
+
+@@ -9913,7 +9913,7 @@
+ } else {
+ get_wrap_path("CDRECORD",line);
+ }
+- strcat(line," -version 2>/dev/null");
++ strcat(line," -version 2>&1");
+
+ dodebug(1, "calling: %s\n", line);
+ if ((fpin = popen(line,"r")) == NULL) {
+@@ -10137,7 +10137,7 @@
+
+ strcpy(ver,"");
+ get_wrap_path("READCD",line);
+- strcat(line," -version 2>/dev/null");
++ strcat(line," -version 2>/dev/null | head -n 1");
+
+ dodebug(1, "calling: %s\n", line);
+ if ((fpin = popen(line,"r")) == NULL) {
+
+diff -urNad xcdroast-0.98alpha15.orig/src/main.c xcdroast-0.98alpha15/src/main.c
+--- xcdroast-0.98alpha15.orig/src/main.c 2006-11-11 04:38:39.000000000 +0100
++++ xcdroast-0.98alpha15/src/main.c 2006-11-11 04:39:33.000000000 +0100
+@@ -586,13 +586,13 @@
+ }
+
+ /* if we are in DVD mode, check if the security-key is set */
+- if (curset.isProDVD == 1) {
++ /* if (curset.isProDVD == 1) {
+ keyenv = getenv("CDR_SECURITY");
+ if (keyenv == NULL) {
+ show_dialog(ICO_WARN, _("Warning: You have not entered a cdrecord-ProDVD key in setup.\nPlease see the FAQ on how to obtain your free key.\nYou also have to renew the key every few months because it got an\nexpire date. You will not be able to properly write DVDs without it."), T_OK, NULL, NULL, 0);
+ }
+
+- }
++ } */
+
+ dolog(1,"Starting X-CD-Roast\n");
+
+diff -urNad xcdroast-0.98alpha15.orig/src/xcdroast.h xcdroast-0.98alpha15/src/xcdroast.h
+--- xcdroast-0.98alpha15.orig/src/xcdroast.h 2006-11-11 04:38:39.000000000 +0100
++++ xcdroast-0.98alpha15/src/xcdroast.h 2006-11-11 04:38:51.000000000 +0100
+@@ -113,7 +113,7 @@
+ /usr/local/lib/xcdroast-0.98/bin/cdrecord) */
+
+ #define CDRECORD "bin/cdrecord"
+-#define CDRECORDPRODVD "bin/cdrecord.prodvd"
++#define CDRECORDPRODVD "bin/cdrecord"
+ #define CDDA2WAV "bin/cdda2wav"
+ #define READCD "bin/readcd"
+ #define MKISOFS "bin/mkisofs"
diff --git a/app-cdr/xcdroast/files/cdrecord_versions.patch b/app-cdr/xcdroast/files/cdrecord_versions.patch
new file mode 100644
index 000000000000..3b303e8625f0
--- /dev/null
+++ b/app-cdr/xcdroast/files/cdrecord_versions.patch
@@ -0,0 +1,15 @@
+diff -urNad trunk~/src/xcdroast.h trunk/src/xcdroast.h
+--- trunk~/src/xcdroast.h 2006-05-06 15:18:20.000000000 +0200
++++ trunk/src/xcdroast.h 2006-05-08 11:47:57.000000000 +0200
+@@ -124,8 +124,8 @@
+ IT WONT WORK WITH LOWER VERSIONS, EVEN WHEN YOU THINK IT DOES! */
+
+ #define CDRECORD_VERSION "1.11a34"
+-#define CDRECORD_PRODVD_VERSION "2.01a11"
+-#define CDRECORD_VERSION_WITH_ONTHFLYAUDIO "2.01a13"
++#define CDRECORD_PRODVD_VERSION "2.01.01"
++#define CDRECORD_VERSION_WITH_ONTHFLYAUDIO "2.01.01"
+ #define MKISOFS_VERSION "1.15a17"
+ #define CDDA2WAV_VERSION "1.11a34"
+ #define READCD_VERSION "1.11a34"
+
diff --git a/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha15-r4 b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha15-r4
new file mode 100644
index 000000000000..83df78c8a710
--- /dev/null
+++ b/app-cdr/xcdroast/files/digest-xcdroast-0.98_alpha15-r4
@@ -0,0 +1,6 @@
+MD5 8ad7858aa96d29466b74b093ee82149b xcdroast-0.98_alpha15_new_configure.tar.gz 82301
+RMD160 125c5a48462bac3515c93f7e9f6e428cb901d80c xcdroast-0.98_alpha15_new_configure.tar.gz 82301
+SHA256 0e33617f9315482dd95e1228e27461e45bea4516abaebfb5b6449aedaec9de90 xcdroast-0.98_alpha15_new_configure.tar.gz 82301
+MD5 2a9c1d9f2ef58713c453e674b989be3e xcdroast-0.98alpha15.tar.gz 3282794
+RMD160 9198f67659023ce8f508fa2c331df9d9c8b81a8f xcdroast-0.98alpha15.tar.gz 3282794
+SHA256 40be77142b23fa62265a23e473bd3af43df6ab01332ea991a5ef3069530b28d8 xcdroast-0.98alpha15.tar.gz 3282794
diff --git a/app-cdr/xcdroast/files/modern_cdrtools.patch b/app-cdr/xcdroast/files/modern_cdrtools.patch
new file mode 100644
index 000000000000..3aba1e8268ba
--- /dev/null
+++ b/app-cdr/xcdroast/files/modern_cdrtools.patch
@@ -0,0 +1,21 @@
+--- xcdroast-0.98alpha15/src/io.c 2003-10-26 15:24:48.000000000 +0100
++++ xcdroast-0.98alpha15-P/src/io.c 2006-09-25 20:07:33.000000000 +0200
+@@ -9026,7 +9026,7 @@
+ strcat(tmp2,"-D ");
+ }
+ if (masterparam.opt[7]) {
+- strcat(tmp2,"-L ");
++ strcat(tmp2,"-allow-leading-dots ");
+ }
+ if (masterparam.opt[8]) {
+ strcat(tmp2,"-d ");
+@@ -9160,7 +9160,7 @@
+ }
+ if (masterparam.publisher) {
+ strcpy(tmptmp, masterparam.publisher);
+- g_snprintf(tmp5,MAXLINE,"-P \"%s\" ",
++ g_snprintf(tmp5,MAXLINE,"-publisher \"%s\" ",
+ convert_escape(tmptmp));
+ strcat(tmp4,tmp5);
+ }
+
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild
index e22bf5f63481..ea1b3af83bca 100644
--- a/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild,v 1.21 2006/10/28 14:56:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha15-r3.ebuild,v 1.22 2006/11/11 04:51:57 pylon Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
-IUSE="nls"
+IUSE="nls dvdr"
DEPEND=">=x11-libs/gtk+-2.0.3
dev-util/pkgconfig"
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild
new file mode 100644
index 000000000000..6c694f7238f1
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha15-r4.ebuild,v 1.1 2006/11/11 04:51:57 pylon Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P/_/}
+DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+HOMEPAGE="http://www.xcdroast.org/"
+SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz
+ mirror://gentoo/${P}_new_configure.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="nls dvdr"
+
+DEPEND=">=x11-libs/gtk+-2.0.3
+ dev-util/pkgconfig"
+
+RDEPEND="virtual/cdrtools"
+
+src_unpack() {
+ unpack ${P/_/}.tar.gz
+ cd ${S}
+ unpack ${P}_new_configure.tar.gz
+
+ cd ${S}/src
+ epatch ${FILESDIR}/gtk2locale.patch
+ epatch ${FILESDIR}/modern_cdrtools.patch
+ epatch ${FILESDIR}/cdrecord_versions.patch
+ epatch ${FILESDIR}/cdrecord2wodim.patch
+ use amd64 && epatch ${FILESDIR}/64bit_gsize.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --enable-gtk2 \
+ --disable-dependency-tracking || die
+
+ make PREFIX=/usr || die
+}
+
+src_install() {
+ make PREFIX=/usr DESTDIR=${D} install || die
+
+ cd ${S}/doc
+ dodoc DOCUMENTATION FAQ README* TRANSLATION.HOWTO
+
+ # move man pages to /usr/share/man to be LFH compliant
+ mv ${D}/usr/man ${D}/usr/share
+
+ # remove extraneous directory
+ rm ${D}/usr/etc -rf
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins ${S}/xpms/xcdricon.xpm xcdroast.xpm
+
+ make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
+}
+
+pkg_postinst() {
+ if use dvdr; then
+ einfo "As both cdrkit and cdrtools are capable of DVD writing they"
+ einfo "can be used with xcdroast. But you have to start xcdroast"
+ einfo "with the option '-n' to skip the version check."
+ fi
+}