summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 16:55:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 16:55:16 +0000
commitffebf12c371873b00c9a1b75241bbc751e717106 (patch)
treeadfa3135386c3f42a649ae3e539a01e2db9d0f0b /app-cdr
parentVersion bump. (diff)
downloadgentoo-2-ffebf12c371873b00c9a1b75241bbc751e717106.tar.gz
gentoo-2-ffebf12c371873b00c9a1b75241bbc751e717106.tar.bz2
gentoo-2-ffebf12c371873b00c9a1b75241bbc751e717106.zip
Use Python 2 (bug #308321).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu/ChangeLog6
-rw-r--r--app-cdr/cdemu/cdemu-1.2.0.ebuild17
2 files changed, 16 insertions, 7 deletions
diff --git a/app-cdr/cdemu/ChangeLog b/app-cdr/cdemu/ChangeLog
index b151474c3802..6ba0cc73f7c0 100644
--- a/app-cdr/cdemu/ChangeLog
+++ b/app-cdr/cdemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-cdr/cdemu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.21 2010/02/01 20:22:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.22 2010/07/06 16:55:16 arfrever Exp $
+
+ 06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ cdemu-1.2.0.ebuild:
+ Use Python 2 (bug #308321).
01 Feb 2010; Peter Volkov <pva@gentoo.org> -cdemu-0.8.ebuild,
-cdemu-1.1.0.ebuild, -cdemu-1.1.0-r1.ebuild, cdemu-1.2.0.ebuild:
diff --git a/app-cdr/cdemu/cdemu-1.2.0.ebuild b/app-cdr/cdemu/cdemu-1.2.0.ebuild
index fe1764e51436..5adbc03e82e0 100644
--- a/app-cdr/cdemu/cdemu-1.2.0.ebuild
+++ b/app-cdr/cdemu/cdemu-1.2.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-1.2.0.ebuild,v 1.3 2010/02/01 20:22:06 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-1.2.0.ebuild,v 1.4 2010/07/06 16:55:16 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
-NEED_PYTHON="2.4"
-inherit multilib python
+inherit python
DESCRIPTION="Client of cdemu suite, which mounts all kinds of cd images"
HOMEPAGE="http://cdemu.org"
@@ -23,6 +23,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/cdemu-client-${PV}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
# disable compilation of python modules
rm py-compile && \
@@ -35,10 +40,10 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "$(python_get_sitedir)/cdemu"
+ python_mod_optimize cdemu
python_need_rebuild
}
pkg_postrm() {
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/cdemu"
+ python_mod_cleanup cdemu
}