summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-16 11:05:13 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-16 11:05:13 +0000
commitc836625345d7d23b12306ee6f07d71c2f8230141 (patch)
treee8680e6d4c99e344897dfde26e42fe98e57de8a9 /app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild
parentInitial import (diff)
downloadgentoo-2-c836625345d7d23b12306ee6f07d71c2f8230141.tar.gz
gentoo-2-c836625345d7d23b12306ee6f07d71c2f8230141.tar.bz2
gentoo-2-c836625345d7d23b12306ee6f07d71c2f8230141.zip
Initial import
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild')
-rw-r--r--app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild
new file mode 100644
index 000000000000..f2a15309c8b9
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.4.ebuild,v 1.1 2006/12/16 11:05:13 alonbl Exp $
+
+DESCRIPTION="ASEDriveIIIe Serial Card Reader"
+HOMEPAGE="http://www.athena-scs.com"
+SRC_URI="http://www.athena-scs.com/downloads/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+RDEPEND=">=sys-apps/pcsc-lite-1.3.0
+ >=dev-libs/libusb-0.1.10"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_install() {
+ local conf="/etc/reader.conf.d/${PN}.conf"
+
+ make install DESTDIR="${D}" || die
+
+ dodoc LICENSE
+ dodoc README
+
+ dodir "$(dirname "${conf}")"
+ insinto "$(dirname "${conf}")"
+ newins "etc/reader.conf" "$(basename "${conf}")"
+
+ einfo "NOTICE:"
+ einfo "1. update ${conf} file"
+ einfo "2. run update-reader.conf, yes this is a command..."
+ einfo "3. restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g')" ]; then
+ rm "${conf}"
+ update-reader.conf
+ einfo "NOTICE:"
+ einfo "You need to restart pcscd"
+ fi
+}
+