summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-05 19:55:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-05 19:55:46 +0000
commit3a57b7aa9c790159055c7fb68938cc4945bbba99 (patch)
tree1fab02f8005e243aba6110df0be32b56a8d4be39 /app-crypt/ccid
parentAdd new version 7.5.2; remove old versions (diff)
downloadgentoo-2-3a57b7aa9c790159055c7fb68938cc4945bbba99.tar.gz
gentoo-2-3a57b7aa9c790159055c7fb68938cc4945bbba99.tar.bz2
gentoo-2-3a57b7aa9c790159055c7fb68938cc4945bbba99.zip
Add a patch to reintroduce compatibility with a few readers such as the O2Micro Oz776 and the blutronics bludrive II CCID that were threw off 1.4.x series after the libusb 1.0 switch.
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/ChangeLog11
-rw-r--r--app-crypt/ccid/ccid-1.4.1-r2.ebuild45
2 files changed, 54 insertions, 2 deletions
diff --git a/app-crypt/ccid/ChangeLog b/app-crypt/ccid/ChangeLog
index 8746d76508c6..ea667ba0ecbd 100644
--- a/app-crypt/ccid/ChangeLog
+++ b/app-crypt/ccid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/ccid
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.58 2010/12/29 17:40:15 tomka Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.59 2011/01/05 19:55:46 flameeyes Exp $
+
+*ccid-1.4.1-r2 (05 Jan 2011)
+
+ 05 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> +ccid-1.4.1-r2.ebuild:
+ Add a patch to reintroduce compatibility with a few readers such as the
+ O2Micro Oz776 and the blutronics bludrive II CCID that were threw off 1.4.x
+ series after the libusb 1.0 switch.
29 Dec 2010; Thomas Kahle <tomka@gentoo.org> ccid-1.4.1-r1.ebuild:
x86 stable per bug 349559
diff --git a/app-crypt/ccid/ccid-1.4.1-r2.ebuild b/app-crypt/ccid/ccid-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..754eea611c29
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.4.1-r2.ebuild,v 1.1 2011/01/05 19:55:46 flameeyes Exp $
+
+EAPI="3"
+
+STUPID_NUM="3475"
+
+inherit eutils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.bz2
+ http://dev.gentoo.org/~flameeyes/patches/${PN}/${P}-o2micro-oz776.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="twinserial +usb"
+
+DEPEND=">=sys-apps/pcsc-lite-1.6.5
+ usb? ( virtual/libusb:1 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's:GROUP="pcscd":ENV{PCSCD}="1":' \
+ src/92_pcscd_ccid.rules || die
+
+ epatch "${WORKDIR}/${P}-o2micro-oz776.patch"
+}
+
+src_configure() {
+ econf \
+ LEX=: \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS || die
+ insinto /lib/udev/rules.d
+ doins src/92_pcscd_ccid.rules || die
+}