summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:51:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:51:28 +0000
commit341943e0375e015454f781be2c12076397b26bf9 (patch)
tree86ed3797cbafe44fe64dbec3ab5297322e8105a4 /app-crypt/gnupg
parentStable for HPPA (bug #323729). (diff)
downloadgentoo-2-341943e0375e015454f781be2c12076397b26bf9.tar.gz
gentoo-2-341943e0375e015454f781be2c12076397b26bf9.tar.bz2
gentoo-2-341943e0375e015454f781be2c12076397b26bf9.zip
Bug #329583: security patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog8
-rw-r--r--app-crypt/gnupg/files/gnupg-realloc-X.509.patch10
-rw-r--r--app-crypt/gnupg/gnupg-2.0.16-r1.ebuild111
3 files changed, 128 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 2c86a78d0cac..eaf725a14b58 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gnupg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.379 2010/07/21 17:09:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.380 2010/08/10 15:51:28 robbat2 Exp $
+
+*gnupg-2.0.16-r1 (10 Aug 2010)
+
+ 10 Aug 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +gnupg-2.0.16-r1.ebuild, +files/gnupg-realloc-X.509.patch:
+ Bug #329583: security patch.
21 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> gnupg-2.0.15.ebuild:
ppc64 stable wrt #320037
diff --git a/app-crypt/gnupg/files/gnupg-realloc-X.509.patch b/app-crypt/gnupg/files/gnupg-realloc-X.509.patch
new file mode 100644
index 000000000000..123e4cd3202b
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-realloc-X.509.patch
@@ -0,0 +1,10 @@
+--- kbx/keybox-blob.c (revision 5367)
++++ kbx/keybox-blob.c (working copy)
+@@ -898,6 +898,7 @@
+ rc = gpg_error_from_syserror ();
+ goto leave;
+ }
++ names = tmp;
+ }
+ names[blob->nuids++] = p;
+ if (!i && (p=x509_email_kludge (p)))
diff --git a/app-crypt/gnupg/gnupg-2.0.16-r1.ebuild b/app-crypt/gnupg/gnupg-2.0.16-r1.ebuild
new file mode 100644
index 000000000000..3ea200d5acdf
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.0.16-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.16-r1.ebuild,v 1.1 2010/08/10 15:51:28 robbat2 Exp $
+
+EAPI="3"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
+# SRC_URI="ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns bzip2 caps doc ldap nls openct pcsc-lite static selinux smartcard"
+
+COMMON_DEPEND_LIBS="
+ >=dev-libs/libassuan-2
+ >=dev-libs/libgcrypt-1.4
+ >=dev-libs/libgpg-error-1.7
+ >=dev-libs/libksba-1.0.2
+ >=dev-libs/pth-1.3.7
+ >=net-misc/curl-7.10
+ adns? ( >=net-libs/adns-1.4 )
+ bzip2? ( app-arch/bzip2 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ smartcard? ( =virtual/libusb-0* )
+ ldap? ( net-nds/openldap )"
+COMMON_DEPEND_BINS="app-crypt/pinentry"
+
+# existence of bins are checked during configure
+DEPEND="${COMMON_DEPEND_LIBS}
+ ${COMMON_DEPEND_BINS}
+ static? ( >=dev-libs/libassuan-2[static-libs] )
+ nls? ( sys-devel/gettext )
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="!static? ( ${COMMON_DEPEND_LIBS} )
+ ${COMMON_DEPEND_BINS}
+ virtual/mta
+ !app-crypt/gpg-agent
+ !<=app-crypt/gnupg-2.0.1
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_prepare() {
+ EPATCH_OPTS="-l" epatch "${FILESDIR}"/gnupg-realloc-X.509.patch
+}
+
+src_configure() {
+ # 'USE=static' support was requested:
+ # gnupg1: bug #29299
+ # gnupg2: bug #159623
+ use static && append-ldflags -static
+
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-gpg \
+ --enable-gpgsm \
+ --enable-agent \
+ $(use_with adns) \
+ $(use_enable bzip2) \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable !elibc_SunOS symcryptrun) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ $(use_with caps capabilities) \
+ CC_FOR_BUILD=$(tc-getBUILD_CC)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd doc
+ emake html || die "emake html failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ mv "${ED}usr/share/gnupg/help"* "${ED}usr/share/doc/${PF}"
+ ecompressdir "/usr/share/doc/${PF}"
+
+ dosym gpg2 /usr/bin/gpg
+ dosym gpgv2 /usr/bin/gpgv
+ dosym gpg2keys_hkp /usr/libexec/gpgkeys_hkp
+ dosym gpg2keys_finger /usr/libexec/gpgkeys_finger
+ dosym gpg2keys_curl /usr/libexec/gpgkeys_curl
+ use ldap && dosym gpg2keys_ldap /usr/libexec/gpgkeys_ldap
+ echo ".so man1/gpg2.1" > "${ED}usr/share/man/man1/gpg.1"
+ echo ".so man1/gpgv2.1" > "${ED}usr/share/man/man1/gpgv.1"
+
+ use doc && dohtml doc/gnupg.html/* doc/*jpg doc/*png
+}
+
+pkg_postinst() {
+ elog "If you wish to view images emerge:"
+ elog "media-gfx/xloadimage, media-gfx/xli or any other viewer"
+ elog "Remember to use photo-viewer option in configuration file to activate"
+ elog "the right viewer."
+
+ ewarn "Please remember to restart gpg-agent if a different version"
+ ewarn "of the agent is currently used. If you are unsure of the gpg"
+ ewarn "agent you are using please run 'killall gpg-agent',"
+ ewarn "and to start a fresh daemon just run 'gpg-agent --daemon'."
+}