summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-09 15:01:35 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-09 15:01:35 +0000
commit37507880916395290f83f2c9addbee8cdf61214d (patch)
tree07bf150ef924dc7c39fb6e178b3df1481bfa30b3 /app-crypt/gnupg
parentx86 stable wrt bug #348080 (diff)
downloadgentoo-2-37507880916395290f83f2c9addbee8cdf61214d.tar.gz
gentoo-2-37507880916395290f83f2c9addbee8cdf61214d.tar.bz2
gentoo-2-37507880916395290f83f2c9addbee8cdf61214d.zip
Fixed configure options in app-crypt/gnupg wrt bug 348200. Small QA fixes.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog11
-rw-r--r--app-crypt/gnupg/gnupg-1.4.11.ebuild21
2 files changed, 21 insertions, 11 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 91e652055f72..07611c59714d 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/gnupg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.394 2010/10/19 05:35:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.395 2010/12/09 15:01:35 c1pher Exp $
+
+ 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
+ *Removed $(use_enable) static. No longer used upstream wrt bug 348200.
+ *Changed --disable-capabilities to --without-capabilities wrt bug 348200.
+ *Added some missing || die.
+ Not revbumping. --with-capabilites defaults to without so all current
+ installs
+ will be without. $(use_enable static) is gone completely so it also
+ won't change any current install.
19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> -gnupg-2.0.11.ebuild,
-gnupg-2.0.12.ebuild, -gnupg-2.0.13.ebuild, -gnupg-2.0.14.ebuild,
diff --git a/app-crypt/gnupg/gnupg-1.4.11.ebuild b/app-crypt/gnupg/gnupg-1.4.11.ebuild
index 6d2d3e66f140..129fdc2b5dd5 100644
--- a/app-crypt/gnupg/gnupg-1.4.11.ebuild
+++ b/app-crypt/gnupg/gnupg-1.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.11.ebuild,v 1.1 2010/10/19 00:49:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.11.ebuild,v 1.2 2010/12/09 15:01:35 c1pher Exp $
EAPI="3"
@@ -75,8 +75,10 @@ src_prepare() {
sed -e "/^man_MANS =/s/ gpg\.ru\.1//" -i doc/Makefile.in || die "sed doc/Makefile.in failed"
# Fix PIC definitions
- sed -i -e 's:PIC:__PIC__:' mpi/i386/mpih-{add,sub}1.S intl/relocatable.c
- sed -i -e 's:if PIC:ifdef __PIC__:' mpi/sparc32v8/mpih-mul{1,2}.S
+ sed -i -e 's:PIC:__PIC__:' mpi/i386/mpih-{add,sub}1.S intl/relocatable.c \
+ || die "sed PIC failed"
+ sed -i -e 's:if PIC:ifdef __PIC__:' mpi/sparc32v8/mpih-mul{1,2}.S || \
+ die"Sed PIC failed"
}
src_configure() {
@@ -102,10 +104,9 @@ src_configure() {
$(use_enable bzip2) \
$(use_enable smartcard card-support) \
$(use_enable selinux selinux-support) \
- --disable-capabilities \
+ --without-capabilities \
$(use_with readline) \
$(use_with usb libusb /usr) \
- $(use_enable static) \
--enable-static-rnd=linux \
--libexecdir="${EPREFIX}/usr/libexec" \
--enable-noexecstack \
@@ -117,18 +118,18 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
# keep the documentation in /usr/share/doc/...
- rm -rf "${ED}usr/share/gnupg/FAQ" "${ED}usr/share/gnupg/faq.html"
+ rm -rf "${ED}usr/share/gnupg/FAQ" "${ED}usr/share/gnupg/faq.html" || die
dodoc AUTHORS BUGS ChangeLog NEWS PROJECTS README THANKS \
- TODO VERSION doc/{FAQ,HACKING,DETAILS,OpenPGP}
+ TODO VERSION doc/{FAQ,HACKING,DETAILS,OpenPGP} || die
exeinto /usr/libexec/gnupg
- doexe tools/make-dns-cert
+ doexe tools/make-dns-cert || die
# install RU documentation in right location
if use linguas_ru; then
- cp doc/gpg.ru.1 "${T}/gpg.1"
- doman -i18n=ru "${T}/gpg.1"
+ cp doc/gpg.ru.1 "${T}/gpg.1" || die
+ doman -i18n=ru "${T}/gpg.1" || die
fi
}