summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-14 14:53:23 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-14 14:53:23 +0000
commit0adb589076b1292ff998e1fa32062060858cabfd (patch)
tree36f5746fceded5c94da06ca9c025da93ebfa24d4 /app-crypt/heimdal/heimdal-0.5.ebuild
parentkino ebuild added. (diff)
downloadgentoo-2-0adb589076b1292ff998e1fa32062060858cabfd.tar.gz
gentoo-2-0adb589076b1292ff998e1fa32062060858cabfd.tar.bz2
gentoo-2-0adb589076b1292ff998e1fa32062060858cabfd.zip
Security update.
Diffstat (limited to 'app-crypt/heimdal/heimdal-0.5.ebuild')
-rw-r--r--app-crypt/heimdal/heimdal-0.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/heimdal/heimdal-0.5.ebuild b/app-crypt/heimdal/heimdal-0.5.ebuild
new file mode 100644
index 000000000000..d00c144b382c
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.ebuild,v 1.1 2002/10/14 14:53:23 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kerberos 5 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+DEPEND=">=app-crypt/kth-krb-1.1-r1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ berkdb? ( sys-libs/db )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lib/krb5
+ mv Makefile.in Makefile.in.bak
+ sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
+
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="--with-openssl=/usr" || myconf="--without-openssl"
+
+ use ldap && myconf="${myconf} --with-open-ldap=/usr"
+
+ use ipv6 || myconf="${myconf} --without-ipv6"
+
+ use berkdb || myconf="${myconf} --without-berkely-db"
+
+echo $myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/heimdal \
+ --sysconfdir=/etc \
+ --with-krb4=/usr/athena \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr/heimdal \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/01heimdal ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}