summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-18 13:10:58 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-18 13:10:58 +0000
commit82d1aa381c77e62ec433162f6246e7a0edc81c5a (patch)
tree6d0a9f603113bb0f58a06ceb7545fd0043b7c83e /app-crypt/kth-krb
parentgnome 2.8 mask fixes (diff)
downloadgentoo-2-82d1aa381c77e62ec433162f6246e7a0edc81c5a.tar.gz
gentoo-2-82d1aa381c77e62ec433162f6246e7a0edc81c5a.tar.bz2
gentoo-2-82d1aa381c77e62ec433162f6246e7a0edc81c5a.zip
libedit fix
Diffstat (limited to 'app-crypt/kth-krb')
-rw-r--r--app-crypt/kth-krb/ChangeLog7
-rw-r--r--app-crypt/kth-krb/files/kth-krb-1.2.2-no_libedit.patch10
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild16
3 files changed, 26 insertions, 7 deletions
diff --git a/app-crypt/kth-krb/ChangeLog b/app-crypt/kth-krb/ChangeLog
index eea980d716d9..a90d9f3101fa 100644
--- a/app-crypt/kth-krb/ChangeLog
+++ b/app-crypt/kth-krb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/kth-krb
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.27 2004/06/24 21:34:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.28 2004/09/18 13:10:58 aliz Exp $
+
+ 18 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> kth-krb-1.2.2-r2.ebuild,
+ files/kth-krb-1.2.2-no_libedit.patch:
+ Don't check for el_init in -ledit, thanks to Jason Wever <wever@gentoo.org>
+ for finding the bug.
01 Jun 2004; Aron Griffis <agriffis@gentoo.org> kth-krb-1.2.1.ebuild,
kth-krb-1.2.2.ebuild, kth-krb-1.2.ebuild:
diff --git a/app-crypt/kth-krb/files/kth-krb-1.2.2-no_libedit.patch b/app-crypt/kth-krb/files/kth-krb-1.2.2-no_libedit.patch
new file mode 100644
index 000000000000..ebf87759ac3a
--- /dev/null
+++ b/app-crypt/kth-krb/files/kth-krb-1.2.2-no_libedit.patch
@@ -0,0 +1,10 @@
+--- cf/krb-readline.m4 2004-09-18 13:01:39.805429658 +0000
++++ cf/krb-readline.m4 2004-09-18 13:01:49.932972408 +0000
+@@ -6,7 +6,6 @@
+ dnl el_init
+
+ AC_DEFUN(KRB_READLINE,[
+-AC_FIND_FUNC_NO_LIBS(el_init, edit, [], [], [$LIB_tgetent])
+ if test "$ac_cv_func_el_init" = yes ; then
+ AC_CACHE_CHECK(for four argument el_init, ac_cv_func_el_init_four,[
+ AC_TRY_COMPILE([#include <stdio.h>
diff --git a/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild b/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild
index 7ef72fadd6be..499786d3d118 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild,v 1.5 2004/06/24 21:34:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2-r2.ebuild,v 1.6 2004/09/18 13:10:58 aliz Exp $
inherit eutils
@@ -14,21 +14,25 @@ KEYWORDS="x86 ppc sparc alpha ia64 amd64 s390 hppa mips"
IUSE="ssl afs"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
- !amd64? ( afs? ( >=net-fs/openafs-1.2.2-r7 ) )"
+ !amd64? ( afs? ( >=net-fs/openafs-1.2.2-r7 ) )
+ sys-devel/autoconf"
S=${WORKDIR}/krb4-${PV}
-src_compile() {
- local myconf=""
- echo ${PORTAGE_TMPDIR}
+src_unpack() {
+ unpack ${A} ; cd ${S}
epatch ${FILESDIR}/kth-gentoo.patch
epatch ${FILESDIR}/kth-gentoo-ssl.patch
epatch ${FILESDIR}/${P}-berkdb.patch
epatch ${FILESDIR}/${P}-fPIC.patch
+ epatch ${FILESDIR}/${P}-no_libedit.patch
- use ssl && myconf="${myconf} --with-openssl=/usr"
+ autoconf || die
+}
+src_compile() {
+ use ssl && myconf="${myconf} --with-openssl=/usr"
use afs || myconf="${myconf} --without-afs-support"
econf \