summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-15 06:10:04 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-15 06:10:04 +0000
commit395ee267931752b11f0020d7027f10cd3350f8cb (patch)
tree9bc52599af54d7cb951db01edc2980c3c2faa938 /app-crypt/p11-kit/p11-kit-0.18.2.ebuild
parentExplicitly disable lto in 4.5 to stop configure from helpfully re-enabling it... (diff)
downloadgentoo-2-395ee267931752b11f0020d7027f10cd3350f8cb.tar.gz
gentoo-2-395ee267931752b11f0020d7027f10cd3350f8cb.tar.bz2
gentoo-2-395ee267931752b11f0020d7027f10cd3350f8cb.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/p11-kit/p11-kit-0.18.2.ebuild')
-rw-r--r--app-crypt/p11-kit/p11-kit-0.18.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/p11-kit/p11-kit-0.18.2.ebuild b/app-crypt/p11-kit/p11-kit-0.18.2.ebuild
new file mode 100644
index 000000000000..c3d052736e21
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.18.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.18.2.ebuild,v 1.1 2013/05/15 06:10:04 radhermit Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}