summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-07-27 20:24:41 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-07-27 20:24:41 +0000
commitd7de352c2ebec85a1eaf396824d18a153993b2ac (patch)
treedae21b7e7a08654a620065ed46ee12ce8dbe794d /app-crypt/p11-kit
parentkeyword ~amd64-fbsd thanks to Yuta SATOH, bug #477644 (diff)
downloadgentoo-2-d7de352c2ebec85a1eaf396824d18a153993b2ac.tar.gz
gentoo-2-d7de352c2ebec85a1eaf396824d18a153993b2ac.tar.bz2
gentoo-2-d7de352c2ebec85a1eaf396824d18a153993b2ac.zip
Version bump, fixes bug#471956, bug#477486
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog8
-rw-r--r--app-crypt/p11-kit/files/p11-kit-0.19.3-build.patch21
-rw-r--r--app-crypt/p11-kit/p11-kit-0.19.3.ebuild38
3 files changed, 66 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index 89862fefd827..0f18ccddb078 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.46 2013/06/28 01:55:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.47 2013/07/27 20:24:41 alonbl Exp $
+
+*p11-kit-0.19.3 (27 Jul 2013)
+
+ 27 Jul 2013; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/p11-kit-0.19.3-build.patch, +p11-kit-0.19.3.ebuild:
+ Version bump, fixes bug#471956, bug#477486
*p11-kit-0.18.4 (28 Jun 2013)
diff --git a/app-crypt/p11-kit/files/p11-kit-0.19.3-build.patch b/app-crypt/p11-kit/files/p11-kit-0.19.3-build.patch
new file mode 100644
index 000000000000..c6d61773d37f
--- /dev/null
+++ b/app-crypt/p11-kit/files/p11-kit-0.19.3-build.patch
@@ -0,0 +1,21 @@
+[PATCH] do not assume dead code existence in autoconf checks
+
+when compiler optimize source, it removes dead code so a linkage error
+in these cases are not visisble.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+
+--- p11-kit-0.19.3/configure.ac 2013-07-24 11:13:03.000000000 +0300
++++ p11-kit-0.19.3.new/configure.ac 2013-07-27 23:05:53.470534878 +0300
+@@ -100,9 +100,9 @@ if test "$os_unix" = "yes"; then
+ AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])])
+ AC_CHECK_DECLS([__progname])
+- AC_LINK_IFELSE([AC_LANG_SOURCE([extern char *__progname; void main() { }])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[extern char *__progname;]], [[__progname=(char*)0;]])],
+ [AC_DEFINE(HAVE___PROGNAME, [1], [Whether __progname available])])
+- AC_LINK_IFELSE([AC_LANG_SOURCE([extern int __libc_enable_secure; void main() { }])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[extern int __libc_enable_secure;]], [[__libc_enable_secure = 0;]])],
+ [AC_DEFINE(HAVE___LIBC_ENABLE_SECURE, [1], [Whether __libc_enable_secure available])])
+ fi
+
diff --git a/app-crypt/p11-kit/p11-kit-0.19.3.ebuild b/app-crypt/p11-kit/p11-kit-0.19.3.ebuild
new file mode 100644
index 000000000000..df715026f40c
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.19.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.19.3.ebuild,v 1.1 2013/07/27 20:24:41 alonbl Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}