summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-02-06 11:50:54 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-02-06 11:50:54 +0000
commit6181c80d8d41cad1fde4e7d20ba195a6d2aea0f8 (patch)
tree7c5366b317b636749155ae1c69e2c4929fe7d768 /app-crypt/pinentry
parentRe-enable font vardir creation. (diff)
downloadgentoo-2-6181c80d8d41cad1fde4e7d20ba195a6d2aea0f8.tar.gz
gentoo-2-6181c80d8d41cad1fde4e7d20ba195a6d2aea0f8.tar.bz2
gentoo-2-6181c80d8d41cad1fde4e7d20ba195a6d2aea0f8.zip
new ebuild
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.6.71
-rw-r--r--app-crypt/pinentry/pinentry-0.6.7.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
new file mode 100644
index 000000000000..ba91670e4e5b
--- /dev/null
+++ b/app-crypt/pinentry/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-crypt/pinentry
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.1 2003/02/06 11:50:54 jrray Exp $
+
+*pinentry-0.6.7 (06 Feb 2003)
+
+ 06 Feb 2003; J Robert Ray <jrray@gentoo.org> : Initial ebuild. QT support
+ is currently broken and disabled.
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.6.7 b/app-crypt/pinentry/files/digest-pinentry-0.6.7
new file mode 100644
index 000000000000..fd5905ab7908
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.6.7
@@ -0,0 +1 @@
+MD5 d1fd852644571ab7edf6c01f51078210 pinentry-0.6.7.tar.gz 309895
diff --git a/app-crypt/pinentry/pinentry-0.6.7.ebuild b/app-crypt/pinentry/pinentry-0.6.7.ebuild
new file mode 100644
index 000000000000..4922132ce314
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.6.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.6.7.ebuild,v 1.1 2003/02/06 11:50:54 jrray Exp $
+
+DESCRIPTION="This is a collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol as described by the aegypten project."
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Note: qt support is currently broken,
+# this ebuild is hacked up to disable qt
+# - jrray
+
+#IUSE="qt gtk ncurses"
+IUSE="gtk ncurses"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ ncurses? ( sys-libs/ncurses )"
+#qt? ( x11-libs/qt )
+
+pkg_setup() {
+ #use qt || use gtk || use ncurses || die "You must have at least one of 'qt', 'gtk', or 'ncurses' in your USE"
+ use gtk || use ncurses || die "You must have at least one of 'gtk' or 'ncurses' in your USE"
+}
+
+src_compile() {
+ # $(use_enable qt pinentry-qt) \
+ econf --disable-pinentry-qt \
+ $(use_enable gtk pinentry-gtk) \
+ $(use_enable ncurses pinentry-curses) \
+ --disable-dependency-tracking
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+
+ # The other two pinentries don't spit out an insecure memory warning when
+ # not suid root, and gtk refuses to start if pinentry-gtk is suid root.
+ # chmod +s "${D}"/usr/bin/pinentry-qt
+}
+
+#pkg_postinst() {
+# einfo "pinentry-qt is installed SUID root to make use of protected memory space"
+# einfo "This is needed in order to have a secure place to store your passphrases,"
+# einfo "etc. at runtime but may make some sysadmins nervous"
+#}