summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-16 14:41:37 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-16 14:41:37 +0000
commitbfdccaacff2e3a6b81b557113ba178614e748959 (patch)
treeb2ea49b003e36597f084128ce400d1aec33a3d1a /app-crypt/pinentry
parentStabilise latest everywhere, remove older. (diff)
downloadgentoo-2-bfdccaacff2e3a6b81b557113ba178614e748959.tar.gz
gentoo-2-bfdccaacff2e3a6b81b557113ba178614e748959.tar.bz2
gentoo-2-bfdccaacff2e3a6b81b557113ba178614e748959.zip
Bump eapi in the ebuild and solve the log message print. Wrt bug#440540.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog5
-rw-r--r--app-crypt/pinentry/pinentry-0.8.2.ebuild80
2 files changed, 38 insertions, 47 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 295e590823d5..4ae363623405 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/pinentry
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.128 2012/10/29 10:52:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.129 2012/11/16 14:41:37 scarabeus Exp $
+
+ 16 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> pinentry-0.8.2.ebuild:
+ Bump eapi in the ebuild and solve the log message print. Wrt bug#440540.
29 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org>
-files/pinentry-0.7.5-grab.patch, -files/pinentry-0.8.0-qt-fix.patch,
diff --git a/app-crypt/pinentry/pinentry-0.8.2.ebuild b/app-crypt/pinentry/pinentry-0.8.2.ebuild
index 4a70b1709cd3..d8ba6ebb9eb3 100644
--- a/app-crypt/pinentry/pinentry-0.8.2.ebuild
+++ b/app-crypt/pinentry/pinentry-0.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.8.2.ebuild,v 1.2 2012/09/03 13:53:02 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.8.2.ebuild,v 1.3 2012/11/16 14:41:37 scarabeus Exp $
-EAPI=3
+EAPI=5
inherit multilib eutils flag-o-matic
@@ -15,50 +15,38 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="gtk ncurses qt4 caps static"
-RDEPEND="app-admin/eselect-pinentry
+RDEPEND="
+ app-admin/eselect-pinentry
+ caps? ( sys-libs/libcap )
+ gtk? ( x11-libs/gtk+:2 )
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( >=x11-libs/qt-gui-4.4.1:4 )
static? ( >=sys-libs/ncurses-5.7-r5[static-libs] )
- !static? (
- gtk? ( x11-libs/gtk+:2 )
- ncurses? ( sys-libs/ncurses )
- qt4? ( >=x11-libs/qt-gui-4.4.1:4 )
- !gtk? ( !qt4? ( !ncurses? ( sys-libs/ncurses ) ) )
- )
- caps? ( sys-libs/libcap )"
+"
DEPEND="${RDEPEND}
- !static? (
- gtk? ( virtual/pkgconfig )
- qt4? ( virtual/pkgconfig )
- )"
+ gtk? ( virtual/pkgconfig )
+ qt4? ( virtual/pkgconfig )
+"
+REQUIRED_USE="
+ || ( ncurses gtk qt4 )
+ gtk? ( !static )
+ qt4? ( !static )
+ static? ( ncurses )
+"
-pkg_setup() {
- use static && append-ldflags -static
-
- if use static && { use gtk || use qt4; }; then
- ewarn
- ewarn "The static USE flag is only supported with the ncurses USE flags, disabling the gtk and qt4 USE flags."
- ewarn
- fi
-}
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
src_prepare() {
if use qt4; then
- local file
- for file in qt4/*.moc; do
- "${EPREFIX}"/usr/bin/moc ${file/.moc/.h} > ${file} || die
+ local f
+ for f in qt4/*.moc; do
+ "${EPREFIX}"/usr/bin/moc ${f/.moc/.h} > ${f} || die
done
fi
}
src_configure() {
- local myconf=""
-
- if ! { use qt4 || use gtk || use ncurses; }
- then
- myconf="--enable-pinentry-curses --enable-fallback-curses"
- elif use static
- then
- myconf="--enable-pinentry-curses --enable-fallback-curses --disable-pinentry-gtk2 --disable-pinentry-qt4"
- fi
+ use static && append-ldflags -static
# Issues finding qt on multilib systems
export QTLIB="${QTDIR}/$(get_libdir)"
@@ -73,24 +61,24 @@ src_configure() {
$(use_enable ncurses fallback-curses) \
$(use_enable qt4 pinentry-qt4) \
$(use_with caps libcap) \
- --without-x \
- ${myconf}
+ --without-x
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ default
rm -f "${ED}"/usr/bin/pinentry || die
}
pkg_postinst() {
- elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
- elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
- elog "The soft resource limit for memory locking specifies the limit an"
- elog "unprivileged process may lock into memory. You can also use POSIX"
- elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
- elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
- elog "your users."
+ if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+ fi
eselect pinentry update ifunset
}