summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-04 12:44:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-04 12:44:56 +0000
commit95f25325030ff46862311009b618d91575e03c1d (patch)
tree166b283ec1f9a743483a51ae3b0d189bc96a6e34 /app-crypt/qca
parentVersion bump. (diff)
downloadgentoo-2-95f25325030ff46862311009b618d91575e03c1d.tar.gz
gentoo-2-95f25325030ff46862311009b618d91575e03c1d.tar.bz2
gentoo-2-95f25325030ff46862311009b618d91575e03c1d.zip
Apply correct pkgconfig patch. Should fix bug 268090
(Portage version: 2.2_rc32/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog8
-rw-r--r--app-crypt/qca/files/qca-2.0.2-pcfilespath.patch13
-rw-r--r--app-crypt/qca/qca-2.0.2-r1.ebuild60
3 files changed, 80 insertions, 1 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 5a1d04d6610a..09dee789bca0 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.61 2009/05/02 09:25:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.62 2009/05/04 12:44:56 hwoarang Exp $
+
+*qca-2.0.2-r1 (04 May 2009)
+
+ 04 May 2009; Markos Chandras <hwoarang@gentoo.org> +qca-2.0.2-r1.ebuild,
+ +files/qca-2.0.2-pcfilespath.patch:
+ Apply correct pkgconfig patch. Should fix bug 268090
*qca-2.0.2 (02 May 2009)
diff --git a/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch b/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch
new file mode 100644
index 000000000000..c52e8e78071b
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.0.2-pcfilespath.patch
@@ -0,0 +1,13 @@
+Index: qca-2.0.2/configure
+===================================================================
+--- qca-2.0.2.orig/configure
++++ qca-2.0.2/configure
+@@ -937,7 +937,7 @@ public:
+ if(!pcfiles.isEmpty())
+ {
+ str = QString(
+- "pcfiles.path = \$\$LIBDIR/pkgconfig\n"
++ "pcfiles.path = \$\$LIBDIR/../pkgconfig\n"
+ "pcfiles.files = %1\n"
+ "INSTALLS += pcfiles\n"
+ ).arg(pcfiles.join(" "));
diff --git a/app-crypt/qca/qca-2.0.2-r1.ebuild b/app-crypt/qca/qca-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..0f04b626cfff
--- /dev/null
+++ b/app-crypt/qca/qca-2.0.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.2-r1.ebuild,v 1.1 2009/05/04 12:44:56 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils multilib qt4
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+RESTRICT="test"
+
+DEPEND="!<app-crypt/qca-1.0-r3
+ x11-libs/qt-core:4[debug=]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pcfilespath.patch
+}
+
+src_configure() {
+ _libdir=$(get_libdir)
+
+ ./configure \
+ --prefix=/usr \
+ --qtdir=/usr \
+ --includedir="/usr/include/qca2" \
+ --libdir="/usr/${_libdir}/qca2" \
+ --no-separate-debug-info \
+ --disable-tests \
+ --$(use debug && echo debug || echo release) \
+ || die "configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README TODO || die "dodoc failed"
+
+ cat <<-EOF > "${WORKDIR}"/44qca2
+ LDPATH=/usr/${_libdir}/qca2
+ EOF
+ doenvd "${WORKDIR}"/44qca2 || die
+
+ if use doc; then
+ dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r "${S}"/examples || die "Failed to install examples"
+ fi
+}