summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-15 07:19:57 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-15 07:19:57 +0000
commitfd316f29362f03ea9fdaf84717658796f139ada4 (patch)
tree194ea1084e62561d3f0a91654866bb1f0dbfbf71 /app-crypt/truecrypt
parentuse dev-libs/boehm-gc #140043 (diff)
downloadgentoo-2-fd316f29362f03ea9fdaf84717658796f139ada4.tar.gz
gentoo-2-fd316f29362f03ea9fdaf84717658796f139ada4.tar.bz2
gentoo-2-fd316f29362f03ea9fdaf84717658796f139ada4.zip
added fix for 2.6.18 kernels as per bug #140387
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.2a_kernel-2.6.18-rc1_fix.patch13
-rw-r--r--app-crypt/truecrypt/truecrypt-4.2a.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 67a13b7cf413..ce9cc8664d70 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.5 2006/07/12 13:11:27 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.6 2006/07/15 07:19:57 dragonheart Exp $
+
+ 15 Jul 2006; Daniel Black <dragonheart@gentoo.org>
+ +files/truecrypt-4.2a_kernel-2.6.18-rc1_fix.patch, truecrypt-4.2a.ebuild:
+ added fix for 2.6.18 kernels as per bug #140387 thanks to Fredrik Smedberg
12 Jul 2006; Daniel Black <dragonheart@gentoo.org> truecrypt-4.2a.ebuild:
correct license name bug #140083 thanks to Alex Tarkovsky
diff --git a/app-crypt/truecrypt/files/truecrypt-4.2a_kernel-2.6.18-rc1_fix.patch b/app-crypt/truecrypt/files/truecrypt-4.2a_kernel-2.6.18-rc1_fix.patch
new file mode 100644
index 000000000000..e43dd5c5637d
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-4.2a_kernel-2.6.18-rc1_fix.patch
@@ -0,0 +1,13 @@
+--- truecrypt-4.2a/Linux/Kernel/Dm-target.c 2006-06-28 12:36:28.000000000 +0200
++++ truecrypt-4.2a_fixed/Linux/Kernel/Dm-target.c 2006-07-14 19:02:40.000000000 +0200
+@@ -26,6 +26,10 @@
+ #error Linux kernel 2.6.5 or later required
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
++#define DM_MSG_PREFIX "truecrypt"
++#endif
++
+ int trace_level = 0;
+
+ #define MSG_PREFIX "truecrypt: "
diff --git a/app-crypt/truecrypt/truecrypt-4.2a.ebuild b/app-crypt/truecrypt/truecrypt-4.2a.ebuild
index 320f7949e4a5..c2de4aae0145 100644
--- a/app-crypt/truecrypt/truecrypt-4.2a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-4.2a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.2a.ebuild,v 1.2 2006/07/12 13:11:27 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.2a.ebuild,v 1.3 2006/07/15 07:19:57 dragonheart Exp $
inherit linux-mod toolchain-funcs
@@ -30,6 +30,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}/${P}"_kernel-2.6.18-rc1_fix.patch
cd "${S}"
linux-mod_pkg_setup
epatch "${FILESDIR}/${P}-makefile.patch"