summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-11-05 13:08:11 +0000
committerEray Aslan <eras@gentoo.org>2011-11-05 13:08:11 +0000
commit003527957148377e74e76334ba655f285b4bb3d6 (patch)
tree955ab55a856651ba3fa7906c85f178f9b27aa3f2 /app-crypt
parentVersion bump. (diff)
downloadgentoo-2-003527957148377e74e76334ba655f285b4bb3d6.tar.gz
gentoo-2-003527957148377e74e76334ba655f285b4bb3d6.tar.bz2
gentoo-2-003527957148377e74e76334ba655f285b4bb3d6.zip
version bump - bug #389573
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mit-krb5/ChangeLog10
-rw-r--r--app-crypt/mit-krb5/files/mit-krb5-kprop_exit_on_error.patch25
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.8.5.ebuild110
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.9.2.ebuild121
4 files changed, 265 insertions, 1 deletions
diff --git a/app-crypt/mit-krb5/ChangeLog b/app-crypt/mit-krb5/ChangeLog
index 084b04df7876..43d65da39f6a 100644
--- a/app-crypt/mit-krb5/ChangeLog
+++ b/app-crypt/mit-krb5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/mit-krb5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.299 2011/10/24 13:44:20 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.300 2011/11/05 13:08:11 eras Exp $
+
+*mit-krb5-1.9.2 (05 Nov 2011)
+*mit-krb5-1.8.5 (05 Nov 2011)
+
+ 05 Nov 2011; Eray Aslan <eras@gentoo.org>
+ +files/mit-krb5-kprop_exit_on_error.patch, +mit-krb5-1.8.5.ebuild,
+ +mit-krb5-1.9.2.ebuild:
+ version bump - bug #389573
24 Oct 2011; Eray Aslan <eras@gentoo.org> mit-krb5-1.8.3-r5.ebuild,
-mit-krb5-1.8.4.ebuild, -mit-krb5-1.9.1.ebuild, -mit-krb5-1.9.1-r1.ebuild:
diff --git a/app-crypt/mit-krb5/files/mit-krb5-kprop_exit_on_error.patch b/app-crypt/mit-krb5/files/mit-krb5-kprop_exit_on_error.patch
new file mode 100644
index 000000000000..c2fb7aa008b5
--- /dev/null
+++ b/app-crypt/mit-krb5/files/mit-krb5-kprop_exit_on_error.patch
@@ -0,0 +1,25 @@
+http://krbdev.mit.edu/rt/Ticket/Display.html?id=7000
+
+Index: trunk/src/kadmin/server/ipropd_svc.c
+===================================================================
+diff -u -N -r24961 -r25433
+--- trunk/src/kadmin/server/ipropd_svc.c (.../ipropd_svc.c) (revision 24961)
++++ trunk/src/kadmin/server/ipropd_svc.c (.../ipropd_svc.c) (revision 25433)
+@@ -380,7 +380,7 @@
+ _("%s: pclose(popen) failed: %s"),
+ whoami,
+ error_message(errno));
+- goto out;
++ _exit(1);
+ }
+
+ DPRINT(("%s: exec `kprop -f %s %s' ...\n",
+@@ -401,7 +401,7 @@
+ _("%s: exec failed: %s"),
+ whoami,
+ error_message(errno));
+- goto out;
++ _exit(1);
+ }
+
+ default: /* parent */
diff --git a/app-crypt/mit-krb5/mit-krb5-1.8.5.ebuild b/app-crypt/mit-krb5/mit-krb5-1.8.5.ebuild
new file mode 100644
index 000000000000..0ab2890b02c9
--- /dev/null
+++ b/app-crypt/mit-krb5/mit-krb5-1.8.5.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.8.5.ebuild,v 1.1 2011/11/05 13:08:11 eras Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${P/mit-}
+P_DIR=$(get_version_component_range 1-2)
+DESCRIPTION="MIT Kerberos V"
+HOMEPAGE="http://web.mit.edu/kerberos/www/"
+SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc openldap test xinetd"
+
+RDEPEND="!!app-crypt/heimdal
+ >=sys-libs/e2fsprogs-libs-1.41.0
+ sys-apps/keyutils
+ openldap? ( net-nds/openldap )
+ xinetd? ( sys-apps/xinetd )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )
+ test? ( dev-lang/tcl
+ dev-lang/perl
+ dev-util/dejagnu )"
+
+S=${WORKDIR}/${MY_P}/src
+
+src_unpack() {
+ unpack ${A}
+ unpack ./"${MY_P}".tar.gz
+}
+
+src_configure() {
+ append-flags "-I/usr/include/et"
+ append-flags "-fno-strict-aliasing"
+ append-flags "-fno-strict-overflow"
+ econf \
+ $(use_with openldap ldap) \
+ $(use_with test tcl /usr) \
+ --enable-shared \
+ --with-system-et \
+ --with-system-ss \
+ --enable-dns-for-realm \
+ --enable-kdc-replay-cache \
+ --disable-rpath
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+
+ if use doc ; then
+ cd ../doc
+ for dir in api implement ; do
+ emake -C "${dir}" || die "doc emake failed"
+ done
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ EXAMPLEDIR="/usr/share/doc/${PF}/examples" \
+ install || die "install failed"
+
+ # default database dir
+ keepdir /var/lib/krb5kdc
+
+ cd ..
+ dodoc README
+ dodoc doc/*.{ps,txt}
+ doinfo doc/*.info*
+ dohtml -r doc/*.html
+
+ # die if we cannot respect a USE flag
+ if use doc ; then
+ dodoc doc/{api,implement}/*.ps || die "dodoc failed"
+ fi
+
+ newinitd "${FILESDIR}"/mit-krb5kadmind.initd mit-krb5kadmind || die
+ newinitd "${FILESDIR}"/mit-krb5kdc.initd mit-krb5kdc || die
+
+ insinto /etc
+ newins "${D}/usr/share/doc/${PF}/examples/krb5.conf" krb5.conf.example
+ insinto /var/lib/krb5kdc
+ newins "${D}/usr/share/doc/${PF}/examples/kdc.conf" kdc.conf.example
+
+ if use openldap ; then
+ insinto /etc/openldap/schema
+ doins "${S}/plugins/kdb/ldap/libkdb_ldap/kerberos.schema" || die
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/kpropd.xinetd" kpropd || die
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-1.8.0" ; then
+ elog "MIT split the Kerberos applications from the base Kerberos"
+ elog "distribution. Kerberized versions of telnet, rlogin, rsh, rcp,"
+ elog "ftp clients and telnet, ftp deamons now live in"
+ elog "\"app-crypt/mit-krb5-appl\" package."
+ fi
+}
diff --git a/app-crypt/mit-krb5/mit-krb5-1.9.2.ebuild b/app-crypt/mit-krb5/mit-krb5-1.9.2.ebuild
new file mode 100644
index 000000000000..6e8f58db1707
--- /dev/null
+++ b/app-crypt/mit-krb5/mit-krb5-1.9.2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.9.2.ebuild,v 1.1 2011/11/05 13:08:11 eras Exp $
+
+EAPI=3
+
+inherit eutils flag-o-matic versionator
+
+MY_P="${P/mit-}"
+P_DIR=$(get_version_component_range 1-2)
+DESCRIPTION="MIT Kerberos V"
+HOMEPAGE="http://web.mit.edu/kerberos/www/"
+SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc +keyutils openldap +pkinit +threads test xinetd"
+
+RDEPEND="!!app-crypt/heimdal
+ >=sys-libs/e2fsprogs-libs-1.41.0
+ keyutils? ( sys-apps/keyutils )
+ openldap? ( net-nds/openldap )
+ xinetd? ( sys-apps/xinetd )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ doc? ( virtual/latex-base )
+ test? ( dev-lang/tcl
+ dev-lang/python
+ dev-util/dejagnu )"
+
+S=${WORKDIR}/${MY_P}/src
+
+src_unpack() {
+ unpack ${A}
+ unpack ./"${MY_P}".tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-kprop_exit_on_error.patch"
+}
+
+src_configure() {
+ append-flags "-I${EPREFIX}/usr/include/et"
+ # QA
+ append-flags -fno-strict-aliasing
+ append-flags -fno-strict-overflow
+ use keyutils || export ac_cv_header_keyutils_h=no
+ econf \
+ $(use_with openldap ldap) \
+ "$(use_with test tcl "${EPREFIX}/usr")" \
+ $(use_enable pkinit) \
+ $(use_enable threads thread-support) \
+ --without-hesiod \
+ --enable-shared \
+ --with-system-et \
+ --with-system-ss \
+ --enable-dns-for-realm \
+ --enable-kdc-lookaside-cache \
+ --disable-rpath
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+
+ if use doc ; then
+ cd ../doc
+ for dir in api implement ; do
+ emake -C "${dir}" || die "doc emake failed"
+ done
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ EXAMPLEDIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ install || die "install failed"
+
+ # default database dir
+ keepdir /var/lib/krb5kdc
+
+ cd ..
+ dodoc NOTICE README
+ dodoc doc/*.{ps,txt}
+ doinfo doc/*.info*
+ dohtml -r doc/*.html
+
+ # die if we cannot respect a USE flag
+ if use doc ; then
+ dodoc doc/{api,implement}/*.ps || die "dodoc failed"
+ fi
+
+ newinitd "${FILESDIR}"/mit-krb5kadmind.initd mit-krb5kadmind || die
+ newinitd "${FILESDIR}"/mit-krb5kdc.initd mit-krb5kdc || die
+ newinitd "${FILESDIR}"/mit-krb5kpropd.initd mit-krb5kpropd || die
+
+ insinto /etc
+ newins "${ED}/usr/share/doc/${PF}/examples/krb5.conf" krb5.conf.example
+ insinto /var/lib/krb5kdc
+ newins "${ED}/usr/share/doc/${PF}/examples/kdc.conf" kdc.conf.example
+
+ if use openldap ; then
+ insinto /etc/openldap/schema
+ doins "${S}/plugins/kdb/ldap/libkdb_ldap/kerberos.schema" || die
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/kpropd.xinetd" kpropd || die
+ fi
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-1.8.0" ; then
+ elog "MIT split the Kerberos applications from the base Kerberos"
+ elog "distribution. Kerberized versions of telnet, rlogin, rsh, rcp,"
+ elog "ftp clients and telnet, ftp deamons now live in"
+ elog "\"app-crypt/mit-krb5-appl\" package."
+ fi
+}