summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2015-01-24 18:17:08 +0000
committerSven Vermeulen <swift@gentoo.org>2015-01-24 18:17:08 +0000
commit25792d7ad7ee4cb033824ec1650bc7ca85b4e0ac (patch)
treef653d17367d9900443a067d59e63e32df50dc5d9 /app-crypt
parentVersion bump (diff)
downloadgentoo-2-25792d7ad7ee4cb033824ec1650bc7ca85b4e0ac.tar.gz
gentoo-2-25792d7ad7ee4cb033824ec1650bc7ca85b4e0ac.tar.bz2
gentoo-2-25792d7ad7ee4cb033824ec1650bc7ca85b4e0ac.zip
Use github as source repo and bump to 4.0.6_p1620
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/eid-mw/ChangeLog11
-rw-r--r--app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild62
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild15
3 files changed, 77 insertions, 11 deletions
diff --git a/app-crypt/eid-mw/ChangeLog b/app-crypt/eid-mw/ChangeLog
index 896b8a3b335a..900c8fdba1e9 100644
--- a/app-crypt/eid-mw/ChangeLog
+++ b/app-crypt/eid-mw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/eid-mw
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/eid-mw/ChangeLog,v 1.10 2014/08/10 02:26:59 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/eid-mw/ChangeLog,v 1.11 2015/01/24 18:17:08 swift Exp $
+
+*eid-mw-4.0.6_p1620 (24 Jan 2015)
+
+ 24 Jan 2015; Sven Vermeulen <swift@gentoo.org> +eid-mw-4.0.6_p1620.ebuild,
+ eid-mw-9999.ebuild:
+ Fix bug #536504 - Use github as source repo and bump to 4.0.6_p1620 thanks to
+ Vincent Hardy
10 Aug 2014; Patrick Lauer <patrick@gentoo.org> eid-mw-4.0.2_p1188.ebuild,
eid-mw-4.0.4_p1253.ebuild, eid-mw-4.0.6_p1480.ebuild, eid-mw-9999.ebuild:
diff --git a/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild b/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild
new file mode 100644
index 000000000000..83044ed3a2d5
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/eid-mw/eid-mw-4.0.6_p1620.ebuild,v 1.1 2015/01/24 18:17:08 swift Exp $
+
+EAPI=5
+
+inherit eutils versionator mozextension multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
+ https://github.com/Fedict/${PN}.git"
+ inherit git-2 autotools
+ SRC_URI=""
+else
+ MY_P="${PN}-${PV/_p/-}"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-258906.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+ S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
+fi
+
+SLOT="0"
+LICENSE="LGPL-3"
+DESCRIPTION="Belgian Electronic Identity Card middleware supplied by the Belgian Federal Government"
+
+HOMEPAGE="http://eid.belgium.be"
+
+IUSE="+gtk +xpi"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ >=sys-apps/pcsc-lite-1.2.9
+ xpi? ( || ( >=www-client/firefox-bin-3.6.24
+ >=www-client/firefox-3.6.20 ) )
+ !app-misc/beid-runtime"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]]; then
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf $(use_enable gtk dialogs) --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use xpi; then
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/firefox-3.6.20'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ if has_version '>=www-client/firefox-bin-3.6.24'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ fi
+ rm -r "${D}/usr/share" "${D}"/usr/lib*/*.la
+}
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index b3b8fd285a7e..ba4ce6e38eec 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/eid-mw/eid-mw-9999.ebuild,v 1.2 2014/08/10 02:26:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/eid-mw/eid-mw-9999.ebuild,v 1.3 2015/01/24 18:17:08 swift Exp $
EAPI=5
inherit eutils versionator mozextension multilib
if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="http://eid-mw.googlecode.com/svn/trunk/"
- inherit subversion autotools
+ EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
+ https://github.com/Fedict/${PN}.git"
+ inherit git-2 autotools
SRC_URI=""
else
MY_P="${PN}-${PV/_p/-}"
- SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-250016.gz -> ${MY_P}.tar.gz"
+ SRC_URI="http://eid.belgium.be/en/binaries/${MY_P}.tar_tcm406-258906.gz -> ${MY_P}.tar.gz"
KEYWORDS="~x86 ~amd64"
S="${WORKDIR}/eid-mw-$(get_version_component_range 1-3)"
fi
@@ -38,10 +39,6 @@ if [[ ${PV} == "9999" ]]; then
src_prepare() {
eautoreconf
}
-else
- src_prepare() {
- epatch "${FILESDIR}"/fix-nodialog-bug.patch
- }
fi
src_configure() {