summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 23:56:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 23:56:05 +0000
commit3bcfaf1215341e96c83fa4f752be42312556e078 (patch)
tree91dbcf1e8714c2d8dd5904ccef3ba4aa94b48ab3 /app-crypt
parentAdd truecrypt-2.7 license. (diff)
downloadgentoo-2-3bcfaf1215341e96c83fa4f752be42312556e078.tar.gz
gentoo-2-3bcfaf1215341e96c83fa4f752be42312556e078.tar.bz2
gentoo-2-3bcfaf1215341e96c83fa4f752be42312556e078.zip
Version bump.
(Portage version: 13671-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog8
-rw-r--r--app-crypt/truecrypt/truecrypt-6.2a.ebuild105
2 files changed, 112 insertions, 1 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 8edbd3b01e2e..a96699b83629 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.46 2009/05/21 17:39:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.47 2009/06/22 23:56:05 arfrever Exp $
+
+*truecrypt-6.2a (22 Jun 2009)
+
+ 22 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +truecrypt-6.2a.ebuild:
+ Version bump.
21 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
truecrypt-6.2.ebuild:
diff --git a/app-crypt/truecrypt/truecrypt-6.2a.ebuild b/app-crypt/truecrypt/truecrypt-6.2a.ebuild
new file mode 100644
index 000000000000..b22e9cfd117d
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-6.2a.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.2a.ebuild,v 1.1 2009/06/22 23:56:05 arfrever Exp $
+
+EAPI="2"
+
+inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="truecrypt-2.7"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+RESTRICT="bindist fetch mirror"
+
+RDEPEND="|| ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper )
+ sys-fs/fuse
+ x11-libs/wxGTK:2.8[X?]"
+DEPEND="${RDEPEND}
+ || ( dev-libs/pkcs11-helper dev-libs/opensc )"
+
+S="${WORKDIR}/${P}-source"
+
+pkg_nofetch() {
+ einfo "Please download tar.gz source from:"
+ einfo "http://www.truecrypt.org/downloads2.php"
+ einfo "Then put the file in ${DISTDIR}/${SRC_URI}"
+}
+
+pkg_setup() {
+ local CONFIG_CHECK="BLK_DEV_DM DM_CRYPT FUSE_FS CRYPTO"
+ linux-info_pkg_setup
+
+ local WX_GTK_VER="2.8"
+ if use X; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+}
+
+src_prepare() {
+ if has_version x11-libs/wxGTK[X]; then
+ # Fix linking when NOGUI=1
+ sed -e "s/WX_CONFIG_LIBS := base/&,core/" -i Main/Main.make || die "sed Main/Main.make failed"
+ fi
+}
+
+src_compile() {
+ local EXTRA pkcs11_include_directory
+
+ use X || EXTRA+=" NOGUI=1"
+
+ if has_version dev-libs/pkcs11-helper; then
+ pkcs11_include_directory="/usr/include/pkcs11-helper-1.0"
+ else
+ pkcs11_include_directory="/usr/include/opensc"
+ fi
+ append-flags -DCKR_NEW_PIN_MODE=0x000001B0 -DCKR_NEXT_OTP=0x000001B1
+
+ emake \
+ ${EXTRA} \
+ NOSTRIP=1 \
+ NOTEST=1 \
+ VERBOSE=1 \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ TC_EXTRA_CFLAGS="${CFLAGS}" \
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ TC_EXTRA_LFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${WX_CONFIG}" \
+ PKCS11_INC="${pkcs11_include_directory}" \
+ || die "emake failed"
+}
+
+src_test() {
+ "${S}/Main/truecrypt" --text --test || die "tests failed"
+}
+
+src_install() {
+ dobin Main/truecrypt
+ dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf"
+ insinto "/$(get_libdir)/rcscripts/addons"
+ newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+}
+
+pkg_postinst() {
+ warn_license
+}
+pkg_preinst() {
+ warn_license
+}
+
+warn_license() {
+ ewarn "TrueCrypt has very restrictive license."
+ ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
+ ewarn "directory before using TrueCrypt. Please be explicitly aware of"
+ ewarn "the limitations on redistribution of binaries or modified source."
+ ebeep 5
+}