summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-02-06 10:16:31 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-02-06 10:16:31 +0000
commit63c032948c16d637db27ef807df4e071d0eca55c (patch)
treea8cfa0fc13c87e53058b64097ff9b1f0154609eb /app-crypt
parentSynced up with perl-5.8.0-r9.ebuild. (diff)
downloadgentoo-2-63c032948c16d637db27ef807df4e071d0eca55c.tar.gz
gentoo-2-63c032948c16d637db27ef807df4e071d0eca55c.tar.bz2
gentoo-2-63c032948c16d637db27ef807df4e071d0eca55c.zip
New ebuild (to replace gpgsm ebuild)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/newpg/ChangeLog10
-rw-r--r--app-crypt/newpg/files/digest-newpg-0.9.41
-rw-r--r--app-crypt/newpg/newpg-0.9.4.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/newpg/ChangeLog b/app-crypt/newpg/ChangeLog
new file mode 100644
index 000000000000..47bf0b82d882
--- /dev/null
+++ b/app-crypt/newpg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/newpg
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/ChangeLog,v 1.1 2003/02/06 10:16:31 jrray Exp $
+
+*newpg-0.9.4 (06 Feb 2003)
+
+ 06 Feb 2003; J Robert Ray <jrray@gentoo.org> : Initial ebuild. This
+ package occupies the same space as the 'gpgsm' ebuild. That ebuild
+ will be phased out in favor of this one, it makes more sense to give
+ the package the same name that the package developers call it: newpg.
diff --git a/app-crypt/newpg/files/digest-newpg-0.9.4 b/app-crypt/newpg/files/digest-newpg-0.9.4
new file mode 100644
index 000000000000..2117898946c9
--- /dev/null
+++ b/app-crypt/newpg/files/digest-newpg-0.9.4
@@ -0,0 +1 @@
+MD5 6b478f1ce8e37a55064ffc69b7325ea8 newpg-0.9.4.tar.gz 606811
diff --git a/app-crypt/newpg/newpg-0.9.4.ebuild b/app-crypt/newpg/newpg-0.9.4.ebuild
new file mode 100644
index 000000000000..17460968b9bf
--- /dev/null
+++ b/app-crypt/newpg/newpg-0.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/newpg-0.9.4.ebuild,v 1.1 2003/02/06 10:16:31 jrray Exp $
+
+DESCRIPTION="NewPG is the S/MIME variant of GnuPG which does also include the gpg-agent, useful even for GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/aegypten/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="sys-devel/perl
+ >=dev-libs/libksba-0.4.6
+ >=dev-libs/libgcrypt-1.1.8
+ dev-libs/pth"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} --disable-dependency-tracking
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO VERSION
+
+ chmod +s "${D}/usr/bin/gpgsm"
+}
+
+pkg_postinst() {
+ einfo "gpgsm is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}