summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-02-10 20:55:11 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-02-10 20:55:11 +0000
commit750e1c26b315354f1e4644889654348f8a866535 (patch)
treebc567baf550ba333e1ae8d0f4ce93d6ade523524 /app-crypt
parentbump to 2.12.4, gcc 4.3 fixes and implement Gtk::RecentAction (diff)
downloadgentoo-2-750e1c26b315354f1e4644889654348f8a866535.tar.gz
gentoo-2-750e1c26b315354f1e4644889654348f8a866535.tar.bz2
gentoo-2-750e1c26b315354f1e4644889654348f8a866535.zip
Workaround wxGTK with odbc USE flag, bug#209467
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-bool.patch32
-rw-r--r--app-crypt/truecrypt/truecrypt-5.0.ebuild13
3 files changed, 39 insertions, 12 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 22d4480c99eb..dac5c7a3d615 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.30 2008/02/09 20:42:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.31 2008/02/10 20:55:10 alonbl Exp $
+
+ 10 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-5.0-bool.patch, truecrypt-5.0.ebuild:
+ Workaround wxGTK with odbc USE flag, bug#209467
09 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org>
+files/truecrypt-5.0-64bit.patch, truecrypt-5.0.ebuild:
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch b/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch
new file mode 100644
index 000000000000..2cfd8df11714
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-5.0-bool.patch
@@ -0,0 +1,32 @@
+
+xwGTK undef BOOL if ODBC is used.
+Next version of xwGTK does not have db support.
+
+---
+
+diff -urNp truecrypt-5.0-source/Common/Crypto.h truecrypt-5.0-source.new/Common/Crypto.h
+--- truecrypt-5.0-source/Common/Crypto.h 2008-02-04 19:15:38.000000000 +0200
++++ truecrypt-5.0-source.new/Common/Crypto.h 2008-02-10 22:40:55.000000000 +0200
+@@ -29,6 +29,10 @@
+
+ #include "Tcdefs.h"
+
++#ifndef BOOL
++#define BOOL BOOL1
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+diff -urNp truecrypt-5.0-source/Makefile truecrypt-5.0-source.new/Makefile
+--- truecrypt-5.0-source/Makefile 2008-02-04 20:19:02.000000000 +0200
++++ truecrypt-5.0-source.new/Makefile 2008-02-10 22:40:34.000000000 +0200
+@@ -42,7 +42,7 @@ export CFLAGS := -W
+ export CXXFLAGS := -Wall
+
+ C_CXX_FLAGS := -MMD -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
+-C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
++C_CXX_FLAGS += -DBOOL=int -DBOOL1=int -DFALSE=0 -DTRUE=1
+ C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long long' # Tested in PlatformTest
+
+ export LFLAGS :=
diff --git a/app-crypt/truecrypt/truecrypt-5.0.ebuild b/app-crypt/truecrypt/truecrypt-5.0.ebuild
index 73eb0b80c3e0..c35cdf83684e 100644
--- a/app-crypt/truecrypt/truecrypt-5.0.ebuild
+++ b/app-crypt/truecrypt/truecrypt-5.0.ebuild
@@ -1,16 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-5.0.ebuild,v 1.2 2008/02/09 20:42:26 alonbl Exp $
-
-#
-# NOTES:
-# - Upstream overwrite CFLAGS, and does not wish us to mess with them.
-# - Upstream insist on hiding the Makefile commands... Don't wish to patch it
-# again.
-# - Some issues with parallel make of user mode library.
-# - Upstream is not responsive, even new kernel versions are not supported
-# by upstream, but by other users.
-#
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-5.0.ebuild,v 1.3 2008/02/10 20:55:10 alonbl Exp $
inherit eutils toolchain-funcs multilib wxwidgets
@@ -41,6 +31,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-build.patch"
epatch "${FILESDIR}/${P}-64bit.patch"
+ epatch "${FILESDIR}/${P}-bool.patch"
}
src_compile() {