summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2001-10-10 09:22:49 +0000
committerBruce A. Locke <blocke@gentoo.org>2001-10-10 09:22:49 +0000
commit8d000d7a73cc05ee07975a32d1662b06d0b2d262 (patch)
treef9a69e576a90b7e4f23b65137a30c1dfb02262ca /app-crypt
parentadded gdk-pixbuf and libxml to dep lines, thanks aeoo for reporting (diff)
downloadgentoo-2-8d000d7a73cc05ee07975a32d1662b06d0b2d262.tar.gz
gentoo-2-8d000d7a73cc05ee07975a32d1662b06d0b2d262.tar.bz2
gentoo-2-8d000d7a73cc05ee07975a32d1662b06d0b2d262.zip
gpgme 0.2.3
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgme/files/digest-gpgme-0.2.31
-rw-r--r--app-crypt/gpgme/gpgme-0.2.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/gpgme/files/digest-gpgme-0.2.3 b/app-crypt/gpgme/files/digest-gpgme-0.2.3
new file mode 100644
index 000000000000..1f54c3c0368c
--- /dev/null
+++ b/app-crypt/gpgme/files/digest-gpgme-0.2.3
@@ -0,0 +1 @@
+MD5 2e2eeedb5a708c75bf8e581de2091dc1 gpgme-0.2.3.tar.gz
diff --git a/app-crypt/gpgme/gpgme-0.2.3.ebuild b/app-crypt/gpgme/gpgme-0.2.3.ebuild
new file mode 100644
index 000000000000..68ab091dab2e
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gpgme/${A}"
+HOMEPAGE="http://www.gnupg.org/gpgme.html"
+
+DEPEND="virtual/glibc
+ nls? ( >=sys-devel/gettext-0.10.35 )
+ >=sys-libs/zlib-1.1.3 >=app-crypt/gnupg-1.0.6"
+
+RDEPEND=">=app-crypt/gnupg-1.0.6"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf}
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README README-alpha THANKS TODO
+
+}