summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-10-10 21:27:01 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-10-10 21:27:01 +0000
commit90db18b5909dc297e6100fd8e522a0b6ddb76326 (patch)
treec6789019cb55a5aedbf0fd581a8cdc31087467cd /app-crypt
parentstable ppc, bug #195212 (diff)
downloadgentoo-2-90db18b5909dc297e6100fd8e522a0b6ddb76326.tar.gz
gentoo-2-90db18b5909dc297e6100fd8e522a0b6ddb76326.tar.bz2
gentoo-2-90db18b5909dc297e6100fd8e522a0b6ddb76326.zip
Fix for 2.6.23, bug#186901, thanks to virdiq
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch15
-rw-r--r--app-crypt/truecrypt/truecrypt-4.3a.ebuild8
3 files changed, 27 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 38206447e54f..b62ce5d1c85e 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.21 2007/08/11 08:47:20 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.22 2007/10/10 21:27:00 alonbl Exp $
+
+ 10 Oct 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-4.3a-2.6.23.patch, truecrypt-4.3a.ebuild:
+ Fix for 2.6.23, bug#186901, thanks to virdiq
11 Aug 2007; Alon Bar-Lev <alonbl@gentoo.org>
-files/truecrypt-4.2a-2.6.19.patch, -files/truecrypt-4.2a-2.6.20.patch,
diff --git a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch
new file mode 100644
index 000000000000..cfa54bf19adc
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch
@@ -0,0 +1,15 @@
+diff -urNp truecrypt-4.3a-source-code.org/Linux/Kernel/Dm-target.c truecrypt-4.3a-source-code/Linux/Kernel/Dm-target.c
+--- truecrypt-4.3a-source-code.org/Linux/Kernel/Dm-target.c 2007-04-24 19:32:06.000000000 +0300
++++ truecrypt-4.3a-source-code/Linux/Kernel/Dm-target.c 2007-10-10 23:18:24.000000000 +0200
+@@ -656,7 +656,11 @@ int __init dm_truecrypt_init(void)
+ goto err;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
+ bio_ctx_cache = kmem_cache_create ("truecrypt-bioctx", sizeof (struct bio_ctx), 0, 0, NULL, NULL);
++#else
++ bio_ctx_cache = kmem_cache_create ("truecrypt-bioctx", sizeof (struct bio_ctx), 0, 0, NULL);
++#endif
+ if (!bio_ctx_cache)
+ {
+ error ("kmem_cache_create failed");
diff --git a/app-crypt/truecrypt/truecrypt-4.3a.ebuild b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
index 551c17e4c99a..be7adba8bb19 100644
--- a/app-crypt/truecrypt/truecrypt-4.3a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.1 2007/06/07 16:50:20 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.2 2007/10/10 21:27:00 alonbl Exp $
#
# NOTES:
@@ -41,6 +41,12 @@ pkg_setup() {
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-2.6.23.patch"
+}
+
src_compile() {
linux-mod_src_compile || die "Truecrypt module compilation failed."