summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-07-05 23:27:41 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-07-05 23:27:41 +0000
commit9a583808341a125ad926260cacb0809b06999b16 (patch)
treeaccb8a4cecfb3614bbc1fb48c0f6d84063ffabfa /app-crypt
parentStable on SPARC wrt bug #135093. (diff)
downloadgentoo-2-9a583808341a125ad926260cacb0809b06999b16.tar.gz
gentoo-2-9a583808341a125ad926260cacb0809b06999b16.tar.bz2
gentoo-2-9a583808341a125ad926260cacb0809b06999b16.zip
Fix build when configure is regenerated using autoconf-2.60 by
ed@catmur.co.uk, bug #138535. Use ewarn consistenly, bug #137484. (Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mit-krb5/ChangeLog7
-rw-r--r--app-crypt/mit-krb5/files/krb5.conf1
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild9
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild8
4 files changed, 15 insertions, 10 deletions
diff --git a/app-crypt/mit-krb5/ChangeLog b/app-crypt/mit-krb5/ChangeLog
index 20aa967883d9..72cb5acba5e8 100644
--- a/app-crypt/mit-krb5/ChangeLog
+++ b/app-crypt/mit-krb5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/mit-krb5
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.121 2006/06/29 20:31:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.122 2006/07/05 23:27:41 exg Exp $
+
+ 05 Jul 2006; Emanuele Giaquinta <exg@gentoo.org> files/krb5.conf,
+ mit-krb5-1.4.3.ebuild, mit-krb5-1.4.3-r1.ebuild:
+ Fix build when configure is regenerated using autoconf-2.60 by
+ ed@catmur.co.uk, bug #138535. Use ewarn consistenly, bug #137484.
29 Jun 2006; Seemant Kulleen <seemant@gentoo.org>
mit-krb5-1.4.3-r1.ebuild:
diff --git a/app-crypt/mit-krb5/files/krb5.conf b/app-crypt/mit-krb5/files/krb5.conf
index e68a5ccbbf48..2b7231d1c9da 100644
--- a/app-crypt/mit-krb5/files/krb5.conf
+++ b/app-crypt/mit-krb5/files/krb5.conf
@@ -22,4 +22,3 @@
kdc = FILE:/var/log/krb5kdc.log
admin_server = FILE:/var/log/kadmin.log
default = FILE:/var/log/krb5lib.log
-
diff --git a/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild b/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild
index a8d2ae1ecc1f..1484aa68d56d 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild,v 1.12 2006/06/29 20:31:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3-r1.ebuild,v 1.13 2006/07/05 23:27:41 exg Exp $
inherit eutils flag-o-matic versionator autotools
@@ -38,6 +38,7 @@ src_unpack() {
ebegin "Reconfiguring configure scripts (be patient)"
cd ${S}/appl/telnet
autoreconf --force -I ${S}
+ sed -i 's/^# \(@lib\(obj\)\?_frag@\)/\1/' libtelnet/Makefile.in
eend $?
}
@@ -133,9 +134,9 @@ pkg_postinst() {
fi
echo ""
ewarn "PLEASE READ THIS"
- einfo "This release of mit-krb5 now depends on an external version"
- einfo "of the com_err library. Please make sure to run revdep-rebuild"
- einfo "to ensure the integrity of the linking on your system"
+ ewarn "This release of mit-krb5 now depends on an external version"
+ ewarn "of the com_err library. Please make sure to run revdep-rebuild"
+ ewarn "to ensure the integrity of the linking on your system"
echo ""
epause 10
ebeep
diff --git a/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild b/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild
index 1903f7b54a6a..c1e8ff60f7e4 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild,v 1.12 2006/05/22 13:44:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3.ebuild,v 1.13 2006/07/05 23:27:41 exg Exp $
inherit eutils flag-o-matic versionator
@@ -121,9 +121,9 @@ pkg_postinst() {
fi
echo ""
ewarn "PLEASE READ THIS"
- einfo "This release of mit-krb5 now depends on an external version"
- einfo "of the com_err library. Please make sure to run revdep-rebuild"
- einfo "to ensure the integrity of the linking on your system"
+ ewarn "This release of mit-krb5 now depends on an external version"
+ ewarn "of the com_err library. Please make sure to run revdep-rebuild"
+ ewarn "to ensure the integrity of the linking on your system"
echo ""
epause 10
ebeep