summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-09-14 12:08:53 +0000
committerMike Auty <ikelos@gentoo.org>2008-09-14 12:08:53 +0000
commit9dccd8c2fba5f89ebcc2d02eaecccc17f63b259a (patch)
tree5dbe19cb6853c1e9492dfd673849abc3547f92fd /app-crypt
parentAdd the 'Natural Gentoo' theme (bug #233198). (diff)
downloadgentoo-2-9dccd8c2fba5f89ebcc2d02eaecccc17f63b259a.tar.gz
gentoo-2-9dccd8c2fba5f89ebcc2d02eaecccc17f63b259a.tar.bz2
gentoo-2-9dccd8c2fba5f89ebcc2d02eaecccc17f63b259a.zip
Fix up broken quoting that made the installs pointless.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ophcrack-tables/ChangeLog7
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/app-crypt/ophcrack-tables/ChangeLog b/app-crypt/ophcrack-tables/ChangeLog
index c9475f597cb9..f5cb2d94d156 100644
--- a/app-crypt/ophcrack-tables/ChangeLog
+++ b/app-crypt/ophcrack-tables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ophcrack-tables
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ChangeLog,v 1.2 2008/07/24 21:46:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ChangeLog,v 1.3 2008/09/14 12:08:53 ikelos Exp $
+
+*ophcrack-tables-1.0-r1 (14 Sep 2008)
+
+ 14 Sep 2008; Mike Auty <ikelos@gentoo.org> +ophcrack-tables-1.0-r1.ebuild:
+ Fix up broken quoting that made the installs pointless.
24 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild
new file mode 100644
index 000000000000..bf7c4608f769
--- /dev/null
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r1.ebuild,v 1.1 2008/09/14 12:08:53 ikelos Exp $
+
+EAPI="1"
+
+DESCRIPTION="Tables available for ophcrack"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
+ xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
+ vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="+xpfast xpsmall +vistafree"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ for i in ${A};
+ do
+ table=${i#tables_}
+ table=${table%.zip}
+ mkdir "${S}/${table}"
+ cd "${S}/${table}"
+ unpack "${i}"
+ done
+}
+
+src_install() {
+ dodir /usr/share/ophcrack/
+ cp -r "${S}"/* "${D}/usr/share/ophcrack"
+}