summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-05-09 03:50:52 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-05-09 03:50:52 +0000
commitafde094f3cb0ac691dbc254427d13cb75d81ee4d (patch)
tree47e04b5dbd3fd3628b2add3fa0afdf48e923aafd /app-crypt
parentVersion bump (diff)
downloadgentoo-2-afde094f3cb0ac691dbc254427d13cb75d81ee4d.tar.gz
gentoo-2-afde094f3cb0ac691dbc254427d13cb75d81ee4d.tar.bz2
gentoo-2-afde094f3cb0ac691dbc254427d13cb75d81ee4d.zip
Version bump. Cleaned up ebuild. Thanks to Torsten Kurbad and Eray Aslan.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/ChangeLog10
-rw-r--r--app-crypt/heimdal/files/heimdal-kadmind.initd30
-rw-r--r--app-crypt/heimdal/files/heimdal-kcm.initd25
-rw-r--r--app-crypt/heimdal/files/heimdal-kdc.initd29
-rw-r--r--app-crypt/heimdal/files/heimdal-kpasswdd.initd29
-rw-r--r--app-crypt/heimdal/files/krb5.conf27
-rw-r--r--app-crypt/heimdal/heimdal-1.3.2.ebuild103
7 files changed, 252 insertions, 1 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 6ca8126da51b..bf847dd9ccbd 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/heimdal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.150 2010/02/13 16:32:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.151 2010/05/09 03:50:51 darkside Exp $
+
+*heimdal-1.3.2 (09 May 2010)
+
+ 09 May 2010; Jeremy Olexa <darkside@gentoo.org>
+ +files/heimdal-kadmind.initd, +files/heimdal-kcm.initd,
+ +files/heimdal-kdc.initd, +files/heimdal-kpasswdd.initd, +files/krb5.conf,
+ +heimdal-1.3.2.ebuild:
+ Version bump. Cleaned up ebuild. Thanks to Torsten Kurbad and Eray Aslan.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> heimdal-1.2.1-r4.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #300686
diff --git a/app-crypt/heimdal/files/heimdal-kadmind.initd b/app-crypt/heimdal/files/heimdal-kadmind.initd
new file mode 100644
index 000000000000..da90485873bf
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kadmind.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/files/heimdal-kadmind.initd,v 1.1 2010/05/09 03:50:52 darkside Exp $
+
+depend() {
+ need net
+ use heimdal-kdc
+ after logger
+}
+
+start() {
+ ebegin "Starting Heimdal kadmind"
+ /usr/sbin/kadmind &
+ echo $! > /var/run/heimdal-kadmind.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kadmind"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kadmind
+ eend $?
+}
+
+restart() {
+ svc_stop
+ svc_start
+}
+
diff --git a/app-crypt/heimdal/files/heimdal-kcm.initd b/app-crypt/heimdal/files/heimdal-kcm.initd
new file mode 100644
index 000000000000..9e46d03e4745
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kcm.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/files/heimdal-kcm.initd,v 1.1 2010/05/09 03:50:52 darkside Exp $
+
+depend() {
+ after heimdal-kdc
+}
+
+start() {
+ ebegin "Starting Heimdal KCM..."
+ start-stop-daemon --start --pidfile /var/run/kcm.pid --exec /usr/sbin/kcm -- --detach
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal KCM..."
+ start-stop-daemon --stop --pidfile /var/run/kcm.pid
+ eend $?
+}
+
+restart() {
+ svc_stop
+ svc_start
+}
diff --git a/app-crypt/heimdal/files/heimdal-kdc.initd b/app-crypt/heimdal/files/heimdal-kdc.initd
new file mode 100644
index 000000000000..c56f9c5fb697
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kdc.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/files/heimdal-kdc.initd,v 1.1 2010/05/09 03:50:52 darkside Exp $
+
+depend() {
+ need net
+ after logger
+}
+
+start() {
+ ebegin "Starting Heimdal kdc"
+ start-stop-daemon --start --quiet --exec \
+ /usr/sbin/kdc -- --detach
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kdc"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kdc
+ eend $?
+}
+
+restart() {
+ svc_stop
+ svc_start
+}
+
diff --git a/app-crypt/heimdal/files/heimdal-kpasswdd.initd b/app-crypt/heimdal/files/heimdal-kpasswdd.initd
new file mode 100644
index 000000000000..905522d0eba6
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kpasswdd.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/files/heimdal-kpasswdd.initd,v 1.1 2010/05/09 03:50:52 darkside Exp $
+
+depend() {
+ need net
+ use heimdal-kdc
+ after logger
+}
+
+start() {
+ ebegin "Starting Heimdal kpasswdd"
+ start-stop-daemon --background --start --quiet --exec \
+ /usr/sbin/kpasswdd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kpasswdd"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kpasswdd
+ eend $?
+}
+
+restart() {
+ svc_stop
+ svc_start
+}
diff --git a/app-crypt/heimdal/files/krb5.conf b/app-crypt/heimdal/files/krb5.conf
new file mode 100644
index 000000000000..906eb4d087d0
--- /dev/null
+++ b/app-crypt/heimdal/files/krb5.conf
@@ -0,0 +1,27 @@
+[libdefaults]
+ default_realm = MY.REALM
+# clockskew = 300
+# v4_instance_resolve = false
+# v4_name_convert = {
+# host = {
+# rcmd = host
+# ftp = ftp
+# }
+# plain = {
+# something = something-else
+# }
+# }
+
+[realms]
+ MY.REALM = {
+ kdc = MY.COMPUTER
+ }
+# OTHER.REALM = {
+# v4_instance_convert = {
+# kerberos = kerberos
+# computer = computer.some.other.domain
+# }
+# }
+
+[domain_realm]
+ .my.domain = MY.REALM
diff --git a/app-crypt/heimdal/heimdal-1.3.2.ebuild b/app-crypt/heimdal/heimdal-1.3.2.ebuild
new file mode 100644
index 000000000000..213662f206bd
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-1.3.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.3.2.ebuild,v 1.1 2010/05/09 03:50:51 darkside Exp $
+
+EAPI=2
+VIRTUALX_REQUIRED="manual"
+
+inherit autotools libtool eutils virtualx toolchain-funcs
+
+PATCHVER=0.2
+PATCH_P=${PN}-gentoo-patches-${PATCHVER}
+RESTRICT="test"
+
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.h5l.org/"
+SRC_URI="http://www.h5l.org/dist/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86"
+IUSE="afs +berkdb hdb-ldap ipv6 otp pkinit ssl test threads X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ berkdb? ( sys-libs/db )
+ !berkdb? ( sys-libs/gdbm )
+ >=dev-db/sqlite-3.5.7
+ >=sys-libs/e2fsprogs-libs-1.41.11
+ afs? ( net-fs/openafs )
+ hdb-ldap? ( >=net-nds/openldap-2.3.0 )
+ !virtual/krb5"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/autoconf-2.62
+ test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+
+PROVIDE="virtual/krb5"
+
+GENTOODIR=${WORKDIR}/gentoo
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-kcm \
+ --disable-osfc2 \
+ --enable-shared \
+ --with-libintl=/usr \
+ --with-readline=/usr \
+ --with-sqlite3=/usr \
+ --libexecdir=/usr/sbin \
+ $(use_enable afs afs-support) \
+ $(use_enable berkdb berkeley-db) \
+ $(use_enable otp) \
+ $(use_enable pkinit kx509) \
+ $(use_enable pkinit pk-init) \
+ $(use_enable threads pthread-support) \
+ $(use_with hdb-ldap openldap /usr) \
+ $(use_with ipv6) \
+ $(use_with ssl openssl /usr) \
+ $(use_with X x)
+}
+
+src_install() {
+ INSTALL_CATPAGES="no" emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README NEWS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd,rshd,popper}
+ do
+ mv "${D}"/usr/share/man/man8/{,k}${i}.8
+ mv "${D}"/usr/sbin/{,k}${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp,su,login,pagsh,kf}
+ do
+ mv "${D}"/usr/share/man/man1/{,k}${i}.1
+ mv "${D}"/usr/bin/{,k}${i}
+ done
+
+ mv "${D}"/usr/share/man/man5/{,k}ftpusers.5
+ mv "${D}"/usr/share/man/man5/{,k}login.access.5
+
+ newinitd "${FILESDIR}"/heimdal-kdc.initd heimdal-kdc
+ newinitd "${FILESDIR}"/heimdal-kadmind.initd heimdal-kadmind
+ newinitd "${FILESDIR}"/heimdal-kpasswdd.initd heimdal-kpasswdd
+ newinitd "${FILESDIR}"/heimdal-kcm.initd heimdal-kcm
+
+ insinto /etc
+ newins "${FILESDIR}"/krb5.conf krb5.conf.example
+
+ if use hdb-ldap; then
+ insinto /etc/openldap/schema
+ newins "${S}"/lib/hdb/hdb.schema "${S}"/lib/hdb/krb5-kdc.schema
+ fi
+
+ # default database dir
+ keepdir /var/heimdal
+}