summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-07-09 07:53:46 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-07-09 07:53:46 +0000
commitba54d43a6b89c587b4b562ded8524d317b1ec6a7 (patch)
tree892b44d7cfe05d491d644ea7d6a00875b519a37e /app-crypt
parentnew truecrypt licence version (diff)
downloadgentoo-2-ba54d43a6b89c587b4b562ded8524d317b1ec6a7.tar.gz
gentoo-2-ba54d43a6b89c587b4b562ded8524d317b1ec6a7.tar.bz2
gentoo-2-ba54d43a6b89c587b4b562ded8524d317b1ec6a7.zip
version bump as per bug #230862 thanks to Sebastian and m.nawaz
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog8
-rw-r--r--app-crypt/truecrypt/files/truecrypt-6.0a-gcc-4.3.patch33
-rw-r--r--app-crypt/truecrypt/truecrypt-6.0a.ebuild78
3 files changed, 118 insertions, 1 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 6ba515827c63..79da16a0cf71 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.37 2008/04/18 05:26:42 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.38 2008/07/09 07:53:46 dragonheart Exp $
+
+*truecrypt-6.0a (09 Jul 2008)
+
+ 09 Jul 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/truecrypt-6.0a-gcc-4.3.patch, +truecrypt-6.0a.ebuild:
+ version bump as per bug #230862 thanks to Sebastian and m.nawaz
18 Apr 2008; Alon Bar-Lev <alonbl@gentoo.org>
+files/truecrypt-5.1a-gcc-4.3.patch, truecrypt-5.1a.ebuild:
diff --git a/app-crypt/truecrypt/files/truecrypt-6.0a-gcc-4.3.patch b/app-crypt/truecrypt/files/truecrypt-6.0a-gcc-4.3.patch
new file mode 100644
index 000000000000..9855c8eea612
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-6.0a-gcc-4.3.patch
@@ -0,0 +1,33 @@
+diff -urNp truecrypt-6.0-source.dist/Core/FatFormatter.cpp truecrypt-6.0-source/Core/FatFormatter.cpp
+--- truecrypt-6.0-source.dist/Core/FatFormatter.cpp 2008-07-05 14:17:17.000000000 +0200
++++ truecrypt-6.0-source/Core/FatFormatter.cpp 2008-07-05 14:43:32.000000000 +0200
+@@ -14,6 +14,7 @@
+ #include "Platform/Platform.h"
+ #include "FatFormatter.h"
+ #include "RandomNumberGenerator.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
+diff -urNp truecrypt-6.0-source.dist/Platform/Memory.cpp truecrypt-6.0-source/Platform/Memory.cpp
+--- truecrypt-6.0-source.dist/Platform/Memory.cpp 2008-07-05 14:17:17.000000000 +0200
++++ truecrypt-6.0-source/Platform/Memory.cpp 2008-07-05 14:42:53.000000000 +0200
+@@ -8,6 +8,7 @@
+
+ #include "Memory.h"
+ #include "Exception.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
+diff -urNp truecrypt-6.0-source.dist/Volume/EncryptionTest.cpp truecrypt-6.0-source/Volume/EncryptionTest.cpp
+--- truecrypt-6.0-source.dist/Volume/EncryptionTest.cpp 2008-07-05 14:17:17.000000000 +0200
++++ truecrypt-6.0-source/Volume/EncryptionTest.cpp 2008-07-05 14:42:53.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include "EncryptionModeXTS.h"
+ #include "EncryptionTest.h"
+ #include "Pkcs5Kdf.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
diff --git a/app-crypt/truecrypt/truecrypt-6.0a.ebuild b/app-crypt/truecrypt/truecrypt-6.0a.ebuild
new file mode 100644
index 000000000000..df67bc4d4b34
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-6.0a.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.0a.ebuild,v 1.1 2008/07/09 07:53:46 dragonheart Exp $
+
+inherit eutils toolchain-funcs multilib wxwidgets
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+#SRC_URI="TrueCrypt ${PV} Source.tar.gz"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="truecrypt-collective-1.4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+RESTRICT="fetch"
+
+RDEPEND="sys-fs/fuse
+ =x11-libs/wxGTK-2.8*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-source"
+
+pkg_nofetch() {
+ einfo "Please download tar.gz source from:"
+ einfo "http://www.truecrypt.org/downloads2.php"
+ einfo "Then put the file in ${DISTDIR}/${SRC_URI}"
+}
+
+pkg_setup() {
+ WX_GTK_VER="2.8"
+ if use X; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${PN}-5.1a-external-wx.patch"
+ epatch "${FILESDIR}/${PN}-5.1-64bit.patch"
+ epatch "${FILESDIR}/${PN}-5.0-bool.patch"
+}
+
+src_compile() {
+ local EXTRA
+ use amd64 && EXTRA="${EXTRA} USE64BIT=1"
+ use X || EXTRA="${EXTRA} NOGUI=1"
+ emake \
+ ${EXTRA} \
+ NOSTRIP=1 \
+ VERBOSE=1 \
+ NOTEST=1 \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CXX="$(tc-getCXX)" \
+ RANLIB="$(tc-getRANLIB)" \
+ EXTRA_CFLAGS="${CFLAGS}" \
+ EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${WX_CONFIG}" \
+ WX_CONFIG_EXTRA="" \
+ || die
+}
+
+src_test() {
+ "${S}/Main/truecrypt" --text --test
+}
+
+src_install() {
+ dobin Main/truecrypt
+ dodoc Readme.txt 'Release/Setup Files/TrueCrypt User Guide.pdf'
+ insinto "/$(get_libdir)/rcscripts/addons"
+ newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+}