summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 20:11:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 20:11:18 +0000
commitd4cc3314f74c5963848a57a62c3804c89bfb3071 (patch)
tree0bf77670f5e099454e815af313d6b3cb1121e3ff /app-crypt
parentversion bump (diff)
downloadgentoo-2-d4cc3314f74c5963848a57a62c3804c89bfb3071.tar.gz
gentoo-2-d4cc3314f74c5963848a57a62c3804c89bfb3071.tar.bz2
gentoo-2-d4cc3314f74c5963848a57a62c3804c89bfb3071.zip
Version bump (bug #286940).
(Portage version: 14479-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/ChangeLog8
-rw-r--r--app-crypt/xca/xca-0.7.0.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 5336cc65aa41..41ec46e90ddf 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.18 2009/04/20 20:15:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.19 2009/10/03 20:11:18 arfrever Exp $
+
+*xca-0.7.0 (03 Oct 2009)
+
+ 03 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +xca-0.7.0.ebuild:
+ Version bump (bug #286940).
20 Apr 2009; Markus Meier <maekke@gentoo.org> xca-0.6.4:
amd64 stable, bug #247555
diff --git a/app-crypt/xca/xca-0.7.0.ebuild b/app-crypt/xca/xca-0.7.0.ebuild
new file mode 100644
index 000000000000..7fee753ea689
--- /dev/null
+++ b/app-crypt/xca/xca-0.7.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.7.0.ebuild,v 1.1 2009/10/03 20:11:18 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.8
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+# Upstream:
+# http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+#
+# 1. Qt detection.
+# 2. doc hacks.
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.4-build.patch"
+ sed -e 's/$(LD) $(LDFLAGS)/$(LD) $(RAW_LDFLAGS)/' -i Makefile Rules.mak || die "sed failed"
+}
+
+src_configure() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR=/usr \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CXXFLAGS}" \
+ prefix=/usr \
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake RAW_LDFLAGS="$(raw-ldflags)" || die "emake failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install || die "emake install failed"
+
+ dodoc AUTHORS
+
+ insinto /etc/xca
+ doins misc/*.txt
+}