summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-06 12:58:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-06 12:58:10 +0000
commitdb494a3cd634544ab94988294e48e5a37440b8e7 (patch)
tree45b2541172a593d363d508d368f6e5483c671a4b /app-crypt
parentpin old seahorse to old libnotify (diff)
downloadgentoo-2-db494a3cd634544ab94988294e48e5a37440b8e7.tar.gz
gentoo-2-db494a3cd634544ab94988294e48e5a37440b8e7.tar.bz2
gentoo-2-db494a3cd634544ab94988294e48e5a37440b8e7.zip
Fix building with x11-libs/libnotify >= 0.7. Pin gtk to slot 2 while at it
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse-plugins/ChangeLog9
-rw-r--r--app-crypt/seahorse-plugins/files/seahorse-plugins-2.30.1-libnotify-0.7.patch26
-rw-r--r--app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild12
3 files changed, 40 insertions, 7 deletions
diff --git a/app-crypt/seahorse-plugins/ChangeLog b/app-crypt/seahorse-plugins/ChangeLog
index c06c07c6edb7..6a1e94d2c64e 100644
--- a/app-crypt/seahorse-plugins/ChangeLog
+++ b/app-crypt/seahorse-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/seahorse-plugins
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/ChangeLog,v 1.31 2010/11/24 14:06:41 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/ChangeLog,v 1.32 2011/02/06 12:58:10 ssuominen Exp $
+
+ 06 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ seahorse-plugins-2.30.1-r1.ebuild,
+ +files/seahorse-plugins-2.30.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
24 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
-seahorse-plugins-2.28.1-r1.ebuild, metadata.xml:
diff --git a/app-crypt/seahorse-plugins/files/seahorse-plugins-2.30.1-libnotify-0.7.patch b/app-crypt/seahorse-plugins/files/seahorse-plugins-2.30.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..060340707bf9
--- /dev/null
+++ b/app-crypt/seahorse-plugins/files/seahorse-plugins-2.30.1-libnotify-0.7.patch
@@ -0,0 +1,26 @@
+--- libseahorse/seahorse-notification.c
++++ libseahorse/seahorse-notification.c
+@@ -34,6 +34,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ /* -----------------------------------------------------------------------------
+@@ -213,7 +216,12 @@
+ heading = format_key_text (snotif->heading);
+ message = format_key_text (snotif->message);
+
+- notif = notify_notification_new (heading, message, snotif->icon, attachto);
++ notif = notify_notification_new (heading, message, snotif->icon
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , attachto);
++#endif
+
+ g_free (heading);
+ g_free (message);
diff --git a/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild b/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild
index e8458c48b05f..841c06e08e7e 100644
--- a/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild
+++ b/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild,v 1.7 2010/10/17 15:26:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/seahorse-plugins-2.30.1-r1.ebuild,v 1.8 2011/02/06 12:58:10 ssuominen Exp $
EAPI="2"
@@ -16,7 +16,7 @@ IUSE="applet debug gedit libnotify nautilus test"
RDEPEND="
>=gnome-base/gconf-2.0
- >=x11-libs/gtk+-2.18
+ >=x11-libs/gtk+-2.18:2
>=dev-libs/glib-2.16
>=dev-libs/dbus-glib-0.72
>=app-crypt/gpgme-1.0.0
@@ -53,10 +53,12 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
# Use gpgme_engine_check_version() before gpgm_new() due current gpgme, bug #281729
- epatch "${FILESDIR}/${PN}-2.28.1-gpgme_check_version.patch"
+ epatch "${FILESDIR}"/${PN}-2.28.1-gpgme_check_version.patch
+
+ gnome2_src_prepare
}
src_install() {