summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2006-10-20 15:03:41 +0000
committerOlivier Crête <tester@gentoo.org>2006-10-20 15:03:41 +0000
commit28ce82e9032d0e096295743fbab1267979a1329d (patch)
tree577c2c353add48c810882fda78e4bf6fc166b6b2 /app-dicts/verbiste
parentrevert lib_dir, thanks peper (diff)
downloadgentoo-2-28ce82e9032d0e096295743fbab1267979a1329d.tar.gz
gentoo-2-28ce82e9032d0e096295743fbab1267979a1329d.tar.bz2
gentoo-2-28ce82e9032d0e096295743fbab1267979a1329d.zip
Version bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-dicts/verbiste')
-rw-r--r--app-dicts/verbiste/ChangeLog7
-rw-r--r--app-dicts/verbiste/files/digest-verbiste-0.1.163
-rw-r--r--app-dicts/verbiste/verbiste-0.1.16.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/app-dicts/verbiste/ChangeLog b/app-dicts/verbiste/ChangeLog
index d0123d7cd058..74f9c1f91392 100644
--- a/app-dicts/verbiste/ChangeLog
+++ b/app-dicts/verbiste/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/verbiste
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/verbiste/ChangeLog,v 1.18 2006/09/16 13:41:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/verbiste/ChangeLog,v 1.19 2006/10/20 15:03:41 tester Exp $
+
+*verbiste-0.1.16 (20 Oct 2006)
+
+ 20 Oct 2006; Olivier Crête <tester@gentoo.org> +verbiste-0.1.16.ebuild:
+ Version bump
16 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org>
verbiste-0.1.14.ebuild:
diff --git a/app-dicts/verbiste/files/digest-verbiste-0.1.16 b/app-dicts/verbiste/files/digest-verbiste-0.1.16
new file mode 100644
index 000000000000..15dffe3fa600
--- /dev/null
+++ b/app-dicts/verbiste/files/digest-verbiste-0.1.16
@@ -0,0 +1,3 @@
+MD5 2589b1374113b7ceec11acdb0f800047 verbiste-0.1.16.tar.gz 566860
+RMD160 f2ec766a7996fbef44b6c1260897562d00a21ec4 verbiste-0.1.16.tar.gz 566860
+SHA256 e39bc10a9bf9690a872ec7366bf0ca9d22c5642b2854909c0592786c419a61c6 verbiste-0.1.16.tar.gz 566860
diff --git a/app-dicts/verbiste/verbiste-0.1.16.ebuild b/app-dicts/verbiste/verbiste-0.1.16.ebuild
new file mode 100644
index 000000000000..8bf4de82a679
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/verbiste/verbiste-0.1.16.ebuild,v 1.1 2006/10/20 15:03:41 tester Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://www3.sympatico.ca/sarrazip/dev/verbiste.html"
+SRC_URI="http://www3.sympatico.ca/sarrazip/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/libxml2-2.4.0
+ gnome? ( >=gnome-base/gnome-panel-2.0
+ >=gnome-base/libgnomeui-2.0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+
+#from enlightenment eclass
+gettext_modify() {
+# use nls || return 0
+ cp $(which gettextize) "${T}"/ || die "could not copy gettextize"
+ sed -i \
+ -e 's:read dummy < /dev/tty::' \
+ "${T}"/gettextize
+}
+
+
+src_unpack() {
+ unpack ${A}
+
+ gettext_modify
+
+ cd ${S}
+ "${T}"/gettextize --force --intl --copy
+ AT_M4DIR=macros eautoreconf
+}
+
+
+src_compile() {
+ econf $(use_with gnome) || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "can't install"
+ dodoc AUTHORS ChangeLog HACKING LISEZMOI NEWS README THANKS TODO
+}
+